Author Topic: "NVIDIA GeForce 4 MX440 64MB AGP" and UI1  (Read 4020 times)

FFIXCollector

  • Newbie
  • *
  • Posts: 9
    • View Profile
"NVIDIA GeForce 4 MX440 64MB AGP" and UI1
« on: January 16, 2009, 03:06:47 am »
I have a "NVIDIA GeForce 4 MX440 64MB AGP" video card and I am unable to get UI1 working. I keep getting "Orbiter failed to setup transparency." I have tried to  install new nvidia drivers, but when I run "sh NVIDIA-Linux-x86-<version>-pkg1.run" it tells me that it is an invalid command. When I try to run nvidia-settings, it tells me that nvidia is not configured with Xorg, and to run nvidia-config. After I do that and restart the system, it flashes dcrouter login, and does not load.

I have been working on this for several days and am quite frustrated with LinuxMCE. All I want is UI1. any help would be appreciated.

FFIXCollector

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: "NVIDIA GeForce 4 MX440 64MB AGP" and UI1
« Reply #1 on: January 16, 2009, 03:08:50 am »
I am trying to do this on a Pentium 4 core/hybrid with 4 gig of ram

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5495
  • DOES work for LinuxMCE.
    • View Profile
Re: "NVIDIA GeForce 4 MX440 64MB AGP" and UI1
« Reply #2 on: January 16, 2009, 04:38:41 am »
Your error message indicates that you selected the alpha blending UI. Your card does not support this.

Either:

(1) get up-to-date hardware, or
(2) re-run the AVWizard by booting, and pressing shift when you hear the beeps, and selecting the BASIC UI setting.

-Thom

FFIXCollector

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: "NVIDIA GeForce 4 MX440 64MB AGP" and UI1
« Reply #3 on: January 16, 2009, 06:04:43 am »
My card supports DirectX and OpenGL. What do I need to support alpha blending?

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5495
  • DOES work for LinuxMCE.
    • View Profile
Re: "NVIDIA GeForce 4 MX440 64MB AGP" and UI1
« Reply #4 on: January 16, 2009, 06:20:15 am »
Currently the card must be able to handle xv and opengl and compositing at the same time. The MX 440 does not have anywhere near the required bandwidth to do this.

The lowest recommended card for this is the NVIDIA 6200 or its embedded brother, the 6150.

-Thom

itsmeok

  • Veteran
  • ***
  • Posts: 100
    • View Profile
Re: "NVIDIA GeForce 4 MX440 64MB AGP" and UI1
« Reply #5 on: January 16, 2009, 09:04:49 am »
I have a GeForce 4 card from Asus working. This is what I did. By the way I only run it on my TV through s-vhs connection

1 Go to a console (text) terminal on KDE desktop.
<you>@dcerouter:~$ sudo -s
2. Download the latest linux drivers from NVidia (depending on your hardware, one of versions: 1XX.XX.XX, 1.0-96xx or 1.0-71XX), if you haven't done so already. When you have found the URL for downloading the package on the nvidia site you could download it like this:
root@dcerouter:~# wget http://us.download.nvidia.com/XFree86/Linux-x86/96.43.07/NVIDIA-Linux-x86-96.43.07-pkg1.run

The first time I tried I was able to follow the instructions provided on the website. The second time I had the issue that it kept restarting when I brought the system to level 1. So try another way that xserver is not running. I think I went to recovery mode but am not sure anymore.

Then look where the file is stored and run it. with the remaining instructions on the website.
http://wiki.linuxmce.org/index.php/Display_Drivers

Also keep looking at another post I am still working on. When you change settings in nvidia settings they donĀ“t work after a reboot. If you know how to change that or are also interested please let me know.
http://forum.linuxmce.org/index.php?topic=7171.0

Succes

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2935
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: "NVIDIA GeForce 4 MX440 64MB AGP" and UI1
« Reply #6 on: January 16, 2009, 10:42:00 am »
I have a GeForce 4 card from Asus working. This is what I did. By the way I only run it on my TV through s-vhs connection

Please define "working". Do you have the Geforce4 card working with
  • UI1?
  • UI2 masked
  • UI2 alpha

rgds
Oliver

itsmeok

  • Veteran
  • ***
  • Posts: 100
    • View Profile
Re: "NVIDIA GeForce 4 MX440 64MB AGP" and UI1
« Reply #7 on: January 16, 2009, 01:41:28 pm »
I am using UI1 but also tried UI2 masked. This seemed to work fine but am still testing a lot and find UI 1 more practical for this.
« Last Edit: January 16, 2009, 01:43:10 pm by itsmeok »

itsmeok

  • Veteran
  • ***
  • Posts: 100
    • View Profile
Re: "NVIDIA GeForce 4 MX440 64MB AGP" and UI1
« Reply #8 on: January 16, 2009, 04:30:37 pm »
I changed my system to UI2 alpha and it works on my system.

My system has an ASUS V8420 De Luxe card and 768 MB memory.

FFIXCollector

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: "NVIDIA GeForce 4 MX440 64MB AGP" and UI1
« Reply #9 on: January 16, 2009, 04:57:16 pm »
my card is only working with static images, with no overlay.

I would like to use a better card, but I have a slim case with only a agp slot to work with.

After downloading nvidia drivers and bringing the system to runlevel1, I get
dcrouterlogin_
then I type:sh NVIDIA-Linux-x86-96.43.07-pkg1.run
I get
File or directory does not exist.



If I try to install NVidia in Telinit  I get

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Fri Jan 16 08:38:49 2009
installer version: 1.0.7

option status:
  license pre-accepted    : false
  update                  : false
  force update            : false
  expert                  : false
  uninstall               : false
  driver info             : false
  precompiled interfaces  : true
  no ncurses color        : false
  query latest version    : false
  OpenGL header files     : true
  no questions            : false
  silent                  : false
  no recursion            : false
  no backup               : false
  kernel module only      : false
  sanity                  : false
  add this kernel         : false
  no runlevel check       : false
  no network              : false
  no ABI note             : false
  no RPMs                 : false
  no kernel module        : false
  force SELinux           : default
  no X server check       : false
  no cc version check     : false
  force tls               : (not specified)
  X install prefix        : (not specified)
  X library install path  : (not specified)
  X module install path   : (not specified)
  OpenGL install prefix   : (not specified)
  OpenGL install libdir   : (not specified)
  utility install prefix  : (not specified)
  utility install libdir  : (not specified)
  doc install prefix      : (not specified)
  kernel name             : (not specified)
  kernel include path     : (not specified)
  kernel source path      : (not specified)
  kernel output path      : (not specified)
  kernel install path     : (not specified)
  proc mount point        : /proc
  ui                      : (not specified)
  tmpdir                  : /tmp
  ftp mirror              : ftp://download.nvidia.com
  RPM file list           : (not specified)

Using: nvidia-installer ncurses user interface
-> The file '/tmp/.X0-lock' exists and appears to contain the process ID
   '16190' of a runnning X server.
ERROR: You appear to be running an X server; please exit X before installing.
       For further details, please see the section INSTALLING THE NVIDIA DRIVER
       in the README available on the Linux driver download page at
       www.nvidia.com.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.
« Last Edit: January 16, 2009, 05:42:05 pm by FFIXCollector »

seth

  • Guru
  • ****
  • Posts: 485
  • A day w/o LinuxMCE is like a day w/o sunshine!
    • View Profile
Re: "NVIDIA GeForce 4 MX440 64MB AGP" and UI1
« Reply #10 on: January 16, 2009, 05:41:30 pm »
 ;)
You will have to run that command from the directory you downloaded it to.

For example if you downloaded as user linuxmce, it will be in /home/linuxmce
if you downloaded as root it would be in /root/

Also you may have to make the file executable by running

Code: [Select]
chmod +x NVIDIA-Linux-x86-96.43.07-pkg1.run
And then I would run the command as either:

Code: [Select]
sh NVIDIA-Linux-x86-96.43.07-pkg1.run
as you did or:

Code: [Select]
./NVIDIA-Linux-x86-96.43.07-pkg1.run
That should get you going.

Regards,

Seth
".....Because Once you've LinuxMCE'd....."
System stats located at my user page:

http://wiki.linuxmce.org/index.php/User:Seth

FFIXCollector

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: "NVIDIA GeForce 4 MX440 64MB AGP" and UI1
« Reply #11 on: January 16, 2009, 06:17:31 pm »
I got it. now with the nvidia settings working, is there any way to change the UI without having to do the AV wizard?

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5495
  • DOES work for LinuxMCE.
    • View Profile
Re: "NVIDIA GeForce 4 MX440 64MB AGP" and UI1
« Reply #12 on: January 16, 2009, 06:37:34 pm »
No.

-Thom

FFIXCollector

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: "NVIDIA GeForce 4 MX440 64MB AGP" and UI1
« Reply #13 on: January 17, 2009, 01:51:57 am »
When I try to re-run the video wizard, the computer reboots, and after the kubuntu loading screen the tv goes blank. like it is not receiving a signal through the s-video.

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: "NVIDIA GeForce 4 MX440 64MB AGP" and UI1
« Reply #14 on: January 17, 2009, 02:34:36 am »
When I try to re-run the video wizard, the computer reboots, and after the kubuntu loading screen the tv goes blank. like it is not receiving a signal through the s-video.
Gee I don't think that has ever happened to anyone before,  you must be really "special".  :P
"Change is inevitable. Progress is optional."
-- Anonymous