Author Topic: chose 1080, appears to be scaled?  (Read 1234 times)

nosebreaker

  • Guru
  • ****
  • Posts: 202
    • View Profile
chose 1080, appears to be scaled?
« on: January 10, 2009, 05:34:27 am »
I bought a Panasonic 42" 1080p display, and tried to set it to use 1080, which it does in the setup wizard (I also adjusted the borders and such).  However when it goes to load, the text on the LinuxMCE admin thing is unreadable, I mean it appears as if it is scaled way down.  Any ideas?

I can use a lower resolution and read the text, I was using 1024x768 and it appeared fine (just stretched of course).

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4437
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: chose 1080, appears to be scaled?
« Reply #1 on: January 10, 2009, 08:52:20 am »
I bought a Panasonic 42" 1080p display, and tried to set it to use 1080, which it does in the setup wizard (I also adjusted the borders and such).  However when it goes to load, the text on the LinuxMCE admin thing is unreadable, I mean it appears as if it is scaled way down.  Any ideas?

I can use a lower resolution and read the text, I was using 1024x768 and it appeared fine (just stretched of course).

Searching the wiki/forum for solutions to this kind of issue is always (almost) productive;

http://wiki.linuxmce.org/index.php/Display_Drivers#Microscopic_fonts_in_KDE

All the best

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

nosebreaker

  • Guru
  • ****
  • Posts: 202
    • View Profile
Re: chose 1080, appears to be scaled?
« Reply #2 on: January 10, 2009, 11:15:46 pm »
I don't think that's it, I mean even ubuntu has tiny fonts that I can't read.  If I plug a mac into the screen and tell it 1920x1080 it works fine.

Also, how do I restore the original nvidia driver that came with LMCE?  I tried installing the latest one from nvidia and now it won't boot into X, I also tried an older version with no luck.

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2421
    • View Profile
    • ago control
Re: chose 1080, appears to be scaled?
« Reply #3 on: January 11, 2009, 12:41:00 am »
your screen seems to send a wrong dpi value in the EDID.

br, Hari
rock your home - http://www.agocontrol.com home automation

nosebreaker

  • Guru
  • ****
  • Posts: 202
    • View Profile
New discovery!
« Reply #4 on: January 11, 2009, 06:54:54 am »
I discovered that if I boot off the kubuntu 7.10 live CD it works fine!  So I reinstalled and all goes well until LMCE install, upon which after it chooses the nvidia driver it has the scaling issue again. I copied my old xorg.conf file from before LMCE install (which uses the nv driver, not nvidia) and it works fine!

So there seems to be something wrong with the nvidia driver and this display, but how do I fix it?  I can't use alpha blending without the nvidia driver!

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: chose 1080, appears to be scaled?
« Reply #5 on: January 11, 2009, 09:17:59 am »
Seriously, nosebreaker, you need to heed the advice you are given!

As I said to you in another thread and as Hari and Andrew here, you have an EDID problem. Your screen is reporting the incorrect size, which X then uses to divide into the screen resolution to determine the DPI for the screen. This then is used to calculate the size of fonts. You can see this happening in your /var/log/Xorg.0.log file...

You can either turn off your EDID in the xorg.conf file:

Option "UseEDID" "False"

Or override the DPI part:

Option "UseEDIDDPI" "False"
Option "DPI" "100 x 100"

And choose a value that suits. Note that UseEDID appears in both the Device and Screen sections. Also, do not use the nv driver, only use the nvidia driver.

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: chose 1080, appears to be scaled?
« Reply #6 on: January 11, 2009, 09:10:11 pm »
Often simply specifying the display's physical dimensions as described in the wiki is enough.
"Change is inevitable. Progress is optional."
-- Anonymous


nosebreaker

  • Guru
  • ****
  • Posts: 202
    • View Profile
Re: chose 1080, appears to be scaled?
« Reply #7 on: January 11, 2009, 11:39:25 pm »
I did try that, but since nobody was kind enough to say "use these flags in your xorg.conf file", I googled it, and found... not much.  I found people that compiled their own edid.bin files, which I didn't think was necessary.  I don't have an analog connection to my TV so I can't do that, plus it does seem that the flags it is putting in there are correct.  This flag was already in the config file:
Option "UseEDID" "False"

What does the Option "DPI" "100 x 100" part do exactly?

Besides, how can it be sending the wrong EDID when Vista, OSX and the nv driver all work fine?  For now I changed it to 720p and used the nvidia driver so I can read the text, but it is still "blurry".

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: chose 1080, appears to be scaled?
« Reply #8 on: January 11, 2009, 11:57:11 pm »
Both the link that Totallymaxed posted as the first reply in this thread and my post which lists the options, both clearly state the xorg.conf file... but no matter

If X tries to use the EDID data to calculate the DPI (and I say again, please read your Xorg.0.log file, you will see it state the DPI it is using - if it is something substantially lower than 90 then this is the issue) and your screen is reporting the wrong physical size, which is very common, then when X divides the resolution you chose by screen's physical size in inchs to get the number of Dots Per Inch (DPI) it will get the wrong screen density. It then uses this to calculate how many pixels large a font of particular a "point" size needs to be, and thus the font is the wrong size.

If UseEDID is false in both locations in your xorg.conf file, then X is probably assuming a screen size as it has no other information to base it on. You can either switch UseEDID to true and hopefully your screen does report the correct size, or just use the DPI option I gave you and manually set the DPI. 90 is normal, 100 would be slightly bigger. I use 130 so that I can read my screen comfortably from the lounge.

Different OS's use different approaches to calculating this, or simply fix the DPI (like Windows so that there is no consistency or relationship between on screen and real world, or another screen). And obviously, if one system uses an assumption about how big the screen is, then what the fonts look like is entirely dependent on what assumption the program/driver made. My screen is a 46" Samsung LCD but it reports in EDID that the screen size is 160mm x 90mm

indulis

  • Veteran
  • ***
  • Posts: 147
    • View Profile
Re: chose 1080, appears to be scaled?
« Reply #9 on: January 12, 2009, 04:54:46 am »
I found that for my Panasonic 1024x768 display that

Option "UseEDID" "True"
Option "UseEDIDDPI" "False"
Option "DPI" "100 x 100"

worked fine, so it would read the EDID info from the panel and choose the right modeline settings for the screen (I set max vert and horizontal refresh rates as per the Pana manual).  I also set the panel explictely to max of 1024x768.

I'll append my xorg.conf here or put it into the Wiki.  Have been meaning to do it but been trying to get around other problems with my LMCE core (which are now solved or pretty much solved anyway).

I found setting the screen size to the correct physical dimensions or the correct physical DPI (something like 25 dpi on the 42" plasma) made the fonts ultra tiny as they are set to be "points" which are related to DPI.  IN other words the video driver tries to make a 12 point typeface physically be 12 points- i.e. if you printed out a word in 12 point on a typewriter and held it up to your plasma screen the video display driver is trying to make the on screen fonts the same size! So you have to lie about the size of the screen.

Anyway I found if I set my DPI explicitely and correctly in my xorg.conf then the fonts would be tiny.  If I pretended that the screen was 100 dpi then they were back to a readable size.  If you want bigger fonts you could try to set 150 or 300 dpi and the fonts should get bigger to "compensate".

nosebreaker

  • Guru
  • ****
  • Posts: 202
    • View Profile
Fixed!
« Reply #10 on: January 13, 2009, 07:48:36 pm »
I fixed the problem, and now the nvidia driver works fine!

The solution was to remove ALL lines that specify a resolution, EDID, or refresh rate from my xorg.conf file.  Now it looks crystal clear in 1080p!  I did not use the A/V wizard, I just removed the lines and LMCE detected the resolution changed so it redrew the menus.

Thanks for your help!