Author Topic: Getting HDMI audio to work on the Abit AN-M2HD mother board  (Read 4959 times)

paddyboy73

  • Newbie
  • *
  • Posts: 5
    • View Profile
Getting HDMI audio to work on the Abit AN-M2HD mother board
« on: January 13, 2009, 04:04:26 am »
Has any one got the HDMI audio to work with the Abit AN-M2HD mother board? I've read that new Realtek drivers should be downloaded and installed.....but there has been a lot of talk about the install not working with Ubuntu based OSs. Anyone, anyone...Bueller, Bueller? Thanks.

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Getting HDMI audio to work on the Abit AN-M2HD mother board
« Reply #1 on: January 13, 2009, 04:24:59 am »
I've never gotten it to work on that mobo, but then again I haven't really tried either. Totallymaxed's team got it working on some mobos ages ago, but it was unreliable. He was looking into it, but never provided an update, so I don't think it is high on the priority list. Seems more a driver issue than LMCE.

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: Getting HDMI audio to work on the Abit AN-M2HD mother board
« Reply #2 on: January 13, 2009, 05:48:52 am »
the msi media live hdmi audio works fine.
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Getting HDMI audio to work on the Abit AN-M2HD mother board
« Reply #3 on: January 13, 2009, 01:08:57 pm »
I found on Ubuntu and nVidia forums a few threads about solution to pass audio via HDMI (for example, that one). As I understand it should be possible with kernel 2.6.27-7 (Ubuntu 8.10) and ALSA 1.0.18. I tried to build that kernel and ALSA under LMCE 0701 but without success. Integrated card is not recognized by system as digital HD.

But when I boot Ubuntu 8.10 the card was recognized as digital HD and I suspect the only one step should be done to have audio over HDMI - build ALSA 1.0.18.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4660
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Getting HDMI audio to work on the Abit AN-M2HD mother board
« Reply #4 on: January 13, 2009, 05:44:48 pm »
the msi media live hdmi audio works fine.

Yep we find that too... but most others dont :-(

Andrew
Andy Herron,
CHT Ltd

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, totallymaxed+inquiries@gmail.com via email or PM me here.

Get Dianemo-Rpi2 ARM Licenses http://forum.linuxmce.org/index.php?topic=14026.0

Get RaspSqueeze-CEC or Raspbmc-CEC for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

paddyboy73

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Getting HDMI audio to work on the Abit AN-M2HD mother board
« Reply #5 on: January 20, 2009, 03:13:05 am »
Thank you for the HDMI help. Has anyone had any problems with the analog audio for this board? I figured I would take the easy way out and just use the analog outputs....no sound. Any help would be appreciated.

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Getting HDMI audio to work on the Abit AN-M2HD mother board
« Reply #6 on: January 20, 2009, 03:28:09 am »
Thank you for the HDMI help. Has anyone had any problems with the analog audio for this board? I figured I would take the easy way out and just use the analog outputs....no sound. Any help would be appreciated.
Try running alsamixer from a terminal (Konsole) and unmute everything, that usually fixes it.
"Change is inevitable. Progress is optional."
-- Anonymous


colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Getting HDMI audio to work on the Abit AN-M2HD mother board
« Reply #7 on: January 20, 2009, 04:02:41 am »
Why not use the SPDIF optical connector? That works perfectly. (although you have to trim the connectors a bit if using HDMI at the same time as they are too close together!)

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: Getting HDMI audio to work on the Abit AN-M2HD mother board
« Reply #8 on: January 20, 2009, 05:46:27 am »
Yes use spdif and make sure you unmute IEC598





Tim
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Getting HDMI audio to work on the Abit AN-M2HD mother board
« Reply #9 on: January 20, 2009, 06:36:57 am »
(typo - 958 not 598 :) )

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Getting HDMI audio to work on the Abit AN-M2HD mother board
« Reply #10 on: January 20, 2009, 08:50:27 am »
Quote
Why not use the SPDIF optical connector? That works perfectly. (although you have to trim the connectors a bit if using HDMI at the same time as they are too close together!)
I prefer HDMI because I don't have separate audio system. To use SPDIF I have to buy some home cinema or audio receiver plus acoustics.

2paddyboy73: You should unmute analog or digital outputs using alsamixer as suggested above. Another reason why you don't have a sound can be problem with TT DVB-S cards. The system can recognize them as sound card. To avoid that module snd_aw2 should be added to the blacklist.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

paddyboy73

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Getting HDMI audio to work on the Abit AN-M2HD mother board
« Reply #11 on: January 23, 2009, 01:51:53 am »
Thanks for the suggestions. I'm setting up this system for a friend of mine, I have to use either the HDMI or the analog because he doesn't have a Receiver. Th optical output works great...I had it working on my receiver while I was building the system. I never tested the HDMI or Analog out puts because...silly me...I thought everyone had a receiver..lol. I will try the "un-muting" suggestions and let everyone know how it works out. Again, thank you all, VERY MUCH, for your help.

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Getting HDMI audio to work on the Abit AN-M2HD mother board
« Reply #12 on: January 23, 2009, 08:40:13 am »
Quote
I have to use either the HDMI or the analog because he doesn't have a Receiver.
Note that modern TVs don't allow to use both digital video and analog sound. So, you can use HDMI for video and sound or you should use analog video and analog audio. That's why I'm trying to configure sound over HDMI. I also don't have receiver yet (but thinking to buy some :))

Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

marrandy

  • Guru
  • ****
  • Posts: 162
    • View Profile
Re: Getting HDMI audio to work on the Abit AN-M2HD mother board
« Reply #13 on: February 02, 2009, 09:00:21 pm »
Note that modern TVs don't allow to use both digital video and analog sound. So, you can use HDMI for video and sound or you should use analog video and analog audio. That's why I'm trying to configure sound over HDMI. I also don't have receiver yet (but thinking to buy some :))


Actually, that is not correct.

I have a Sharp Aquos LC-42D64U and Input 6 has a HDMI and Left & Right audio.

My motherboard is a Asus M2NPV-VM and I use its DVI output with a DVI-HDMI adapter with a HDMI-HDMI cable for video and straight L/R audio cables and it works fine.

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Getting HDMI audio to work on the Abit AN-M2HD mother board
« Reply #14 on: February 02, 2009, 10:19:49 pm »
Quote
Actually, that is not correct.

I have a Sharp Aquos LC-42D64U and Input 6 has a HDMI and Left & Right audio.

My motherboard is a Asus M2NPV-VM and I use its DVI output with a DVI-HDMI adapter with a HDMI-HDMI cable for video and straight L/R audio cables and it works fine.

Thanks for correction, marrandy. I had experience with a few Pioneer, Panasonic and Sony TVs and they didn't allow mix digital and analog inputs. It's nice that your Sharp does :)

In any case, it won't be a bad thing to configure  audio over HDMI even TV allows mix digital and analog inputs ;)
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru