Author Topic: Mythtv or Xine player play same IPTV recording differently - interlace ?  (Read 1173 times)

bulek

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 890
  • Living with LMCE
    • View Profile
Hi,

I've recorded MPEG2 stream from IPTV under mythtv. I've made symlink with show title also to Video library, so I can see it in Video repository.

Now if I play this recording from inside Mythtv, it plays much more smoothly and acceptable. If I play it via LMCE and Xine player I see deinterlacing artifacts and picture is stopping for short moments....

I guess this is the difference in settings. It seems Xine has Deinterlacing Mode setting, but cannot find how to use it ?

Has anyone else spotted this Xine behavour and what are my options to solve it ?

Thanks in advance,

regards,

Bulek.
Thanks in advance,

regards,

Bulek.

indulis

  • Veteran
  • ***
  • Posts: 147
    • View Profile
Re: Mythtv or Xine player play same IPTV recording differently - interlace ?
« Reply #1 on: January 11, 2009, 05:29:43 am »
Try
/etc/pluto/xine.conf

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Mythtv or Xine player play same IPTV recording differently - interlace ?
« Reply #2 on: January 11, 2009, 05:59:56 am »
With VDR integration using the xineliboutput plugin the config looks like this for the most common deinterlace. I note that with VDR I had jerkiness and artifacts using this config, but when I switched the "cheap_mode" to =0 oth got much better. You should be able to adapt this config as they are standard parameters.

xineliboutput.Video.Deinterlace = tvtime
xineliboutput.Video.DeinterlaceOptions = method=Linear,cheap_mode=1,pulldown=none,framerate_mode=full,judder_correction=1,use_progressive_frame_flag=1,chroma_filter=0,enabled=1

skeptic

  • Addicted
  • *
  • Posts: 615
    • View Profile
Re: Mythtv or Xine player play same IPTV recording differently - interlace ?
« Reply #3 on: January 12, 2009, 04:34:43 pm »
There should be no need to manually create symlinks anywhere ever.  Let Myth and LMCE do their thing without mucking with it under the covers.  On a properly setup system all the MythTV recordings will show up in the LMCE Videos with proper titles without intervention.

As to xine playback, there is a known bug that affects at least some of us including me.  After a while Xine_Player video playback can get choppy/jumpy.  This may be what you are seeing.  For now the easy work around is to do a quick router reload.  Next time you are seeing choppy video do a quick reload and see if it goes away.  Beyond that my recorded TV shows play the same from LMCE and from within Myth.

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Mythtv or Xine player play same IPTV recording differently - interlace ?
« Reply #4 on: January 12, 2009, 08:47:36 pm »
There should be no need to manually create symlinks anywhere ever.  Let Myth and LMCE do their thing without mucking with it under the covers.  On a properly setup system all the MythTV recordings will show up in the LMCE Videos with proper titles without intervention.

As to xine playback, there is a known bug that affects at least some of us including me.  After a while Xine_Player video playback can get choppy/jumpy.  This may be what you are seeing.  For now the easy work around is to do a quick router reload.  Next time you are seeing choppy video do a quick reload and see if it goes away.  Beyond that my recorded TV shows play the same from LMCE and from within Myth.

We suspect there to be a small memory leak in Xine_Player but haven't gotten really around to looking into the issue, reloading the router restarts it fresh again.
"Change is inevitable. Progress is optional."
-- Anonymous