Author Topic: LMCE keeps hard locking....  (Read 3132 times)

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2974
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: LMCE keeps hard locking....
« Reply #15 on: January 13, 2009, 10:26:36 am »
(Zaerc did squeezecenter make it into the alpha1?)

I ain't Zaerc, but yes, the latest alpha contains support for the latest Logitech Squeezeboxes, as we have changed the port of the plugin to the default port of the squeezeboxes.

rgds
Oliver

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: LMCE keeps hard locking....
« Reply #16 on: January 13, 2009, 10:40:04 am »
phew! thx possy, that'll make it much easier when I rebuild for the betas :)

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2974
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: LMCE keeps hard locking....
« Reply #17 on: January 13, 2009, 10:41:20 am »
phew! thx possy, that'll make it much easier when I rebuild for the betas :)

Could you give me a link to the beta's ;)

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: LMCE keeps hard locking....
« Reply #18 on: January 13, 2009, 10:44:40 am »
was a loaded statement ;)

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: LMCE keeps hard locking....
« Reply #19 on: January 13, 2009, 11:49:16 am »
The easiest way to get out of the current dependency-hell that you're stuck in, I reckon would be to create a dummy slimserver .deb package and install it.  Unfortunately I cannot reach my notes on how to do that at the moment, try googling for "equivs" (iirc). 
"Change is inevitable. Progress is optional."
-- Anonymous


colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: LMCE keeps hard locking....
« Reply #20 on: January 15, 2009, 03:58:44 am »
Zaerc - seems to be a catch 22! You have to install equivs and this triggers the same problem (and others):

linuxmce@dcerouter:~$ sudo apt-get install equivs
[sudo] password for linuxmce:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  equivs: Depends: debhelper (>= 4) but it is not going to be installed
          Depends: devscripts but it is not going to be installed
          Depends: fakeroot but it is not going to be installed
  pluto-slim-server-streamer: PreDepends: slimserver but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
linuxmce@dcerouter:~$

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: LMCE keeps hard locking....
« Reply #21 on: January 15, 2009, 04:27:52 am »
I'll see if I can wrestle up a dummy package for you tomorrow.
"Change is inevitable. Progress is optional."
-- Anonymous


colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: LMCE keeps hard locking....
« Reply #22 on: January 15, 2009, 05:03:22 am »
Thanks Zaerc - how will I install it? Can I override using a dpkg command or something?

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: LMCE keeps hard locking....
« Reply #23 on: January 15, 2009, 12:45:17 pm »
Now that you mention it, try downloading the equivs package manually and install it with dpkg directly, which would go something like this:

wget -c 'http://ftp.iinet.net.au/pub/ubuntu/pool/universe/e/equivs/equivs_2.0.7_all.deb'
dpkg -i equivs_2.0.7_all.deb

Or maybe you prefer another mirror to download it from.
"Change is inevitable. Progress is optional."
-- Anonymous


colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: LMCE keeps hard locking....
« Reply #24 on: January 15, 2009, 12:51:48 pm »
hmm damn! Not sure what happened, seems like it installed but didn't configure...

linuxmce@dcerouter:~$ sudo dpkg -i equivs_2.0.7_all.deb
Selecting previously deselected package equivs.
(Reading database ... 111976 files and directories currently installed.)
Unpacking equivs (from equivs_2.0.7_all.deb) ...
dpkg: dependency problems prevent configuration of equivs:
 equivs depends on debhelper (>= 4); however:
  Package debhelper is not installed.
 equivs depends on devscripts; however:
  Package devscripts is not installed.
 equivs depends on fakeroot; however:
  Package fakeroot is not installed.
dpkg: error processing equivs (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 equivs


Any thoughts?

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: LMCE keeps hard locking....
« Reply #25 on: January 15, 2009, 01:42:44 pm »
Well, dpkg doesn't try to automatically resolve dependencies like apt-get does, so I'm afraid you'll have to download and install those manually too.  Normally an apt-get install -f could solve them afterwards.  This page might help a bit to locate them: http://packages.ubuntu.com/gutsy/equivs

They don't call it dependency hell for nothing.  :-\

If I wasn't so busy at the moment I would have generated the dummy for you already, but right now I have a few other things I need to take care of first. 
"Change is inevitable. Progress is optional."
-- Anonymous


colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: LMCE keeps hard locking....
« Reply #26 on: January 16, 2009, 12:33:50 am »
no no I don't want you to help me any more than you already have... don't want your attention distracted from the "bigger issues" at the moment .... (how long til beta do you think? :) )

thx for the pointers, will start looking through this and work it out.