Author Topic: MD pxe boot - call failed: 13 - Retrying nfs mount - SOLUTION  (Read 1363 times)

schaferj

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Hello,

My family room MD has been working for many more than a year, but tonight I rebooted the core and the MD just runs in a loop -

         mount call failed: 13 ... Retrying nfs mount

until it drops into busybox.  I tried rebooting several times and tried running:

         # exportfs -ra

on the core/hybrid as suggested in an earlier post, but it did not work.

I searched the forum and wiki and found earlier mentions of similiar issues at:
http://forum.linuxmce.org/index.php?topic=5479.0 and
http://forum.linuxmce.org/index.php?topic=2902.0

Looks like others have had similiar issues, but I haven't found a resolution.

A brute force solution may be to delete the md from the core and redo, but I'd like to hear other ideas first.
much thanks,
joseph

« Last Edit: March 07, 2009, 10:21:48 pm by schaferj »

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: MD pxe boot - call failed: 13 - Retrying nfs mount
« Reply #1 on: March 07, 2009, 08:50:26 am »
I had same problem the other night.

A complete power down of core seemed to fix it.
Not just reboot




HTH


Tim
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

schaferj

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: MD pxe boot - call failed: 13 - Retrying nfs mount
« Reply #2 on: March 07, 2009, 08:53:16 am »
Tim,
Thank you very much for the quick reply.  I'll try it.
joseph

schaferj

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: MD pxe boot - call failed: 13 - Retrying nfs mount
« Reply #3 on: March 07, 2009, 09:09:45 am »
no joy - and it's now after 3AM, so I think I'll call it a night.

Maybe I'll try leaving it off for a while so the electrons can rest up a bit...

thanks again for the quick response!
joseph

schaferj

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: MD pxe boot - call failed: 13 - Retrying nfs mount
« Reply #4 on: March 07, 2009, 09:55:35 pm »
Further checking - all of my MDs now suffer the same fate.

So, something got messed up on the core somewhere.

thoughts welcome,
joseph

schaferj

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: MD pxe boot - call failed: 13 - Retrying nfs mount - SOLUTION
« Reply #5 on: March 07, 2009, 10:28:28 pm »
OK,

I deleted a Vmware MD from the webgui and then in the webgui MD page, I clicked the
"Setup New Diskless MD*" button.

Part of that setup re-exports directories for NFS kernel daemon...

Then I started the new vm-md, it announced and then began setting up.

And then I turned on the family room MD - and it worked!

The VM MD finished and works as well.

hope this helps someone - probably I did not actually have to delete the MD.

I suspect that clicking the "Setup New Diskless MD*" button on the MD page in the webgui would have done it.

I have marked this as a "SOLUTION" rather than "SOLVED" because I still do not have a root cause of this unhappiness.

joseph