Author Topic: p5q-em install drama's  (Read 2482 times)


  • Newbie
  • *
  • Posts: 5
    • View Profile
p5q-em install drama's
« on: December 27, 2008, 12:19:04 pm »
Hi all, I'm complete noob (linuxmce is first dabble into linux)

mobo - asus p5q-em
processor - intel e5200
memory - 2Gb kingston (single stick)
hdd - 2x 750Gb samsung 32Mb cache sata
optical - lg ggc-h20l blu-ray combo drive
case - antec fusion v2

tv card - hauppauge wintv nova t 500mce (not installed yet)

anyway trying to install linuxmce - first got hung up by a 'buffer i/o error device fd0 logical block 0 error.
solved that with someone elses solution of f6 at first load screen and disabling legasy drive I found elsewhere in wiki.

now dvd has installed (i assume os has opied to hdd) and been spat out and system reboots.
it takes me strait to busybox screen (initramfs) ????

any ideas??? be gentle by the way have exactly 20 mins of linux experience  :)

oh yeah using linuxmce 0710 dvd... i386 (if that helps)
« Last Edit: December 27, 2008, 12:20:46 pm by slick »


  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3666
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: p5q-em install drama's
« Reply #1 on: December 27, 2008, 01:01:48 pm »
A quick google search


results in a single result



  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: p5q-em install drama's
« Reply #2 on: December 27, 2008, 10:41:19 pm »
you could try that f6 thingy again, only this time you have to hit [Esc] during boot when grub tells you to, then you should be able to edit a similar line.  If that helps, edit /boot/grub/menu.list to make it permanent.
"Change is inevitable. Progress is optional."
-- Anonymous


  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: p5q-em install drama's
« Reply #3 on: December 28, 2008, 03:56:52 am »
Thanks guys.

Will give it a go and let you know how I go with using this mobo  :)


  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: p5q-em install drama's
« Reply #4 on: December 29, 2008, 05:44:06 am »
Ok, tried all the above with no joy... so I decided to attack the problem a different way.

I downloaded and tried to install kubuntu 7.10 (ie no linuxmce) to see if it was kubuntu causing the problems. It was... sata was causing all the problems.. found solution on ubuntu forums.

I set bios storage configuration to AHCI.... and joy... kubuntu 7.10 running perfectly from blueray drive (connected via sata)

So shutdown machine and inserted linuxmce dvd.

Loading went perfectly (recognised previous install attempt and told it to overwrite, setup linuxmce user and password), until AVWizard reared its ugly head

"Failed to setup X"

rebooted and jumped in at grub and tried the second option (boot in safe mode) and it still hangs at same point.

I get no beeps (in fact no sound at all) to tell me when to hit {shift} to run AV wizard as per wiki.

My mobo has 3 outs (vga, HDMI, and DVI) currently have only vga connected and no way to test other connections yet.

Any ideas??


  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: p5q-em install drama's
« Reply #5 on: January 03, 2009, 05:29:29 pm »

Decided to install Kubuntu 7.10 and then install Linuxmce on top.

Very quickly discovered shortcoming of this board, onboard NIC doesn't work with device driver that Kubuntu loads on install. 3 days and lots of cursing later, I solved this problem, heres how I did it;

1st     I updated BIOS rom to version 1605 (you can find instructions to do this on ASUS website)
         (not sure if this helped solve problem but I did it and in the interest of someone following in my footsteps I would recommend it)
2nd    installed Kubuntu 7.10 on hard drive in safe graphics mode
3rd    downloaded linux drivers from ASUS website and copied them to desktop using a usb thumbdrive I had (you need the driver that matches your kernal distro for me it was r8168-8.010.00.tar)
4th     and this is where it gets interesting;

opened a Konsole session (Alt+Spacebar then type 'konsole' then enter)

Check your Kernal build - type;
'uname -r'

use this info to put correct driver on your desktop (check the readme file from ASUS)

To check what driver is currently being used by your kernal;


This will show you all drivers in your Kernal to run system. You are looking for r8168 or r8169, r8168 is the one you want... r8169 is the wrong one for realtek 8111c NIC. Ok to get rid of r8169 type;

'sudo modprobe -r r8169'

Then confirm it worked by using 'lsmod' command. Now you need to put in the new driver, find the file you saved to desktop and type;

'tar xvf ~/dev/'

This unpacks file (tar ball) to /dev directory, aaa and bb will match filename (for some reason it changes all the time, I have no idea why). Next

'cd /dev'

and have a look 'ls' to check it unpacked. now to install it in kernal; type the following one line after another

'make clean'
'make modules'
'sudo make install'
'sudo depmod -a'
'sudo mkinitramfs -o /boot/initrd.img-`uname -r` `uname -r`'

(the ` key is above Tab key btw)
Ok that should have installed new driver in the kernal confirm by using 'lsmod' command again

before you get excited that its finished, its not... r8169 keeps rearing its ugly head every time you reboot, so you have to blacklist it. Heres how, type this;

sudo sh -c 'echo "blacklist r8169" >> /etc/modprobe.d/blacklist-network'

Now get excited cause this is where I managed to get NIC to work. Update your network settings and off you go  :)

Now to sort out the rest of the hardware problems... graphics, sound.. arrgghh hope it gets easier