Author Topic: Linux mce, xmltv_grab_de_prisma and mythfilldatabase  (Read 794 times)

Scyth

  • Regular Poster
  • **
  • Posts: 25
    • View Profile
Linux mce, xmltv_grab_de_prisma and mythfilldatabase
« on: December 27, 2008, 11:12:06 pm »
HI...

Big problem in little Austria:
I'm trying to configure the in Linux-MCE integrated Mythtv. Unfortunately (for me) Every country has its own xmltv_grab support, but not Germany nor Austria (sarkasm on: of course - I live here - it just had to be like this Wink )
So I got xmltv_grab_de_prisma and installed it. I even got the xml file, wich I could add to the mythtv database. AND I know how to add it:

Code:

mythfilldatabase --update --file <sourceid> test123.xml


I'm sure, that you've already realized, that I wrote 'Sourceid' - I don't know, what it could be. I already found out, that I could obtain it by:

Code: [Select]

$ mysql -u root mythconverg
mysql> select * from cardinput\G
cardinputid
cardid
sourceid=4
etc.

... but that returns: "Empty set (0.00 sec)"

Why? What could I do?

Scyth

Edit: when executing mythfilldatabase I get tthe following errors

Code: [Select]
Database error was:
Access denied for user 'mythtv'@localhost' (using Password: YES)

QSqlQuery::exec:database not open
QSqlQuery::exec:database not open
2008-12-27 20:06:56.658 DB Error (KickDatabase):
Query was:
SELECT NUL;
No error type from QSqlError? Strange...
2008-12-27 20:06:56.688 Failed to init MythContext, exiting.
2008-12-27 20:06:56.690 DataDirect: Deleting temporary files

indulis

  • Veteran
  • ***
  • Posts: 147
    • View Profile
Re: Linux mce, xmltv_grab_de_prisma and mythfilldatabase
« Reply #1 on: December 29, 2008, 12:54:39 am »
Were you trying to run mythfilldatabase from a terminal session?

Try running the mythfilldatabase while you are logged in as user 'mythtv'.  It looks like your mythfilldatabase is not picking up the correct password to access mysql.  If you can't access the database then you can't populate it with data!

In a terminal session try

Code: [Select]
sudo su - mythtv
Then try the mythfilldatabase again.  Type Ctrl-D to exit back out of the mythtv user.

Scyth

  • Regular Poster
  • **
  • Posts: 25
    • View Profile
Re: Linux mce, xmltv_grab_de_prisma and mythfilldatabase
« Reply #2 on: December 29, 2008, 08:30:26 pm »
Well... I have no user called mythtv    :-[    when I installed LMCE I didn't realize, that I should have one.
But I could rename my actual user. That should do it too, right?

Yesterday I found out, that a file named mysql.txt exists in /etc/mythtv. There you can find the DBUserName, PW and Database... I'll try to rename that one...  [Edit: No, no effect]

Edit:
I created a user called mythtv. When I entered mythtvfilldatabase --manual he did not gave me the same error again. I will now try it with mythfilldatabase and .xml - files.
Hm. What should I select in the setup? No grabber I suppose?
« Last Edit: December 29, 2008, 08:47:29 pm by Scyth »

Scyth

  • Regular Poster
  • **
  • Posts: 25
    • View Profile
Re: Linux mce, xmltv_grab_de_prisma and mythfilldatabase
« Reply #3 on: December 29, 2008, 10:05:30 pm »
All right... mythfilldatabase with an xml-file works now.

But when I enter the setup and leave it, mythtv asks me:
Card 8 (Type television) will start on channel 1, which does not exist.
Do you want to solve that problem?


But I think, that I don't have a 'card 8'. What does this mean?

When I start TV the screen is just black. Aften one minuite a LinuxMCE-screen appears, on which I'm told, that mythtv has some problems and he asks me, if I would like to reset the backend.
« Last Edit: December 29, 2008, 11:48:55 pm by Scyth »