Author Topic: Playing files with "special chars" (äöü) on MDs fails  (Read 1283 times)

chriss

  • Veteran
  • ***
  • Posts: 140
    • View Profile
Playing files with "special chars" (äöü) on MDs fails
« on: December 16, 2008, 06:21:10 pm »
Hi,

just discovered a strange behavior. Files with umlauts or other special characters in the file name fail to play on my MDs but are playing fine on the core (where they are stored).

Error in DEClog:
Quote
08      12/16/08 17:45:22.982           Received Message from 36 (.[36;1mXine Player / Wohnzimmer.[0m) to 33 (.[36;1mOnScreen Orbiter WZ / Wohnzimmer.[0m), type 1 id 809 Command:.[35;1mDisplay Alert.[0m, retry none, parameters: <0x7d079950>
08      12/16/08 17:45:22.982             Parameter 9(Text): File not found: /home/public/data/audio/Nils Landgren - Christmas With My Friends/10 - Nils Landgren - Gläns över sjö och strand.mp3 <0x7d079950>
08      12/16/08 17:45:22.982             Parameter 70(Tokens): xine_player_message <0x7d079950>
08      12/16/08 17:45:22.982             Parameter 182(Timeout): 10 <0x7d079950>
08      12/16/08 17:45:22.982             Parameter 251(Interruption): 0 <0x7d079950>
08      12/16/08 17:45:22.983           Received Message from 23 (.[36;1mXine Plug-in / Arbeitszimmer.[0m) to 36 (.[36;1mXine Player / Wohnzimmer.[0m), type 1 id 38 Command:.[35;1mStop Media.[0m, retry none, parameters: <0x5782e950>
08      12/16/08 17:45:22.983             Parameter 41(StreamID): 1001 <0x5782e950>
08      12/16/08 17:45:22.983             Parameter 42(MediaPosition):  <0x5782e950>
05      12/16/08 17:45:23.094           .[33;1mConnect() failed, Error Code 111 (Connection refused)).[0m <0x5a834950>

Any ideas why this is going wrong? I hope I don't have to rename all of those files...  :-\

Thanks,
/chriss

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2420
    • View Profile
    • ago control
Re: Playing files with "special chars" (äöü) on MDs fails
« Reply #1 on: December 16, 2008, 06:25:45 pm »
Hi Chriss,

you know that using spaces, special chars and umlauts in filenames is not the best practice?

br, Hari
rock your home - http://www.agocontrol.com home automation

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Playing files with "special chars" (äöü) on MDs fails
« Reply #2 on: December 16, 2008, 07:24:50 pm »
Does the file exist under that exact name and path on your MD, or does it get mangled somehow?
"Change is inevitable. Progress is optional."
-- Anonymous


sambuca

  • Guru
  • ****
  • Posts: 439
    • View Profile
Re: Playing files with "special chars" (äöü) on MDs fails
« Reply #3 on: December 17, 2008, 09:29:55 am »
Hi chriss

I had to add
Code: [Select]
iocharset=utf8 to the options of my /home mount on the MD to get such files to play.

/etc/fstab should contain a line somewhat like this:
Code: [Select]
//192.168.0.50/home /home cifs iocharset=utf8,forcedirectio,credentials=/usr/pluto/var/sambaCredentials.secret 1 1
br,
sambuca

chriss

  • Veteran
  • ***
  • Posts: 140
    • View Profile
Re: Playing files with "special chars" (äöü) on MDs fails
« Reply #4 on: December 17, 2008, 10:22:48 am »
hari,

you know that using spaces, special chars and umlauts in filenames is not the best practice?
Well, I think, if a file system and the applications support those characters, I should be able to use them without problems  ;D

zaerc,
Does the file exist under that exact name and path on your MD, or does it get mangled somehow?
thanks for this hint. This is exactly the problem. I was about to dig into this but sambuca already came up with a solution.

sambuca,
thank you very much. I will try that!

/chriss

EDIT: just verified the solution. works perfect :) thanks again. I'll post this to trac to have it included in 0810
« Last Edit: December 17, 2008, 10:42:09 am by chriss »

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2420
    • View Profile
    • ago control
Re: Playing files with "special chars" (äöü) on MDs fails
« Reply #5 on: December 17, 2008, 11:16:23 am »

you know that using spaces, special chars and umlauts in filenames is not the best practice?
Well, I think, if a file system and the applications support those characters, I should be able to use them without problems  ;D

well, maybe you are correct but I'm a bit more pessimistic about that. I've seen too many problems in my life regarding umlauts and whatnot. A bit funny that we still hit those things in 2008 :-)

@sambuca: good find!

br, Hari
rock your home - http://www.agocontrol.com home automation

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Playing files with "special chars" (äöü) on MDs fails
« Reply #6 on: December 17, 2008, 07:46:06 pm »
Just on a side-note, we also still need to convert the DB itself to UTF-8 properly.
"Change is inevitable. Progress is optional."
-- Anonymous


roberto99

  • Veteran
  • ***
  • Posts: 101
  • ...dreams of becoming a LMCExpert
    • View Profile
Re: Playing files with "special chars" (äöü) on MDs fails
« Reply #7 on: July 17, 2009, 10:29:17 am »
Hi chriss

I had to add
Code: [Select]
iocharset=utf8 to the options of my /home mount on the MD to get such files to play.

/etc/fstab should contain a line somewhat like this:
Code: [Select]
//192.168.0.50/home /home cifs iocharset=utf8,forcedirectio,credentials=/usr/pluto/var/sambaCredentials.secret 1 1
br,
sambuca

Hi Sambuca

I am having the same problem. Could you explain all that so that a linux newby like me can just follow instructions step by step?

Would appreciate very much
thanks
Roberto

sambuca

  • Guru
  • ****
  • Posts: 439
    • View Profile
Re: Playing files with "special chars" (äöü) on MDs fails
« Reply #8 on: July 17, 2009, 01:47:29 pm »
Hi roberto99

I'll try to give some more details, I'm cannot verify every detail as I'm not at my home:
You have to log in to the console of either the MD or the core. On the MD press ctrl+alt+f1 to get to a console. log in as root, no password should be required. type
Code: [Select]
nano /etc/fstab If this editor (nano) is not installed, you will be told that. To install it type
Code: [Select]
apt-get install nano.
Find the line and change it.
Ctrl+o to save, ctrl+x to exit.
You could try umount and then mount the /home share to apply the new settings but it might be as easy to just reboot.

hope this helps,
sambuca

roberto99

  • Veteran
  • ***
  • Posts: 101
  • ...dreams of becoming a LMCExpert
    • View Profile
Re: Playing files with "special chars" (äöü) on MDs fails
« Reply #9 on: July 17, 2009, 09:34:37 pm »
Ok, thanks, I'll try
greets
Roberto