Author Topic: Bluez/JavaMo  (Read 1191 times)

compaqpresario

  • Veteran
  • ***
  • Posts: 76
    • View Profile
Bluez/JavaMo
« on: December 10, 2008, 10:12:05 pm »
 ??? Having some trouble here, I bought a bluetooth adapter with the specs suggested in the wiki.  I plugged it in the usb and it goes into a constant installation loop. I went on to the pluto-admin site and made sure it was enabled as blue bluetooth adapter for every MD.  When i switch on any bluetooth phone phone (made visible), i continue to get the installation loop and it constantly finds the phone and asks me to use it, so when you go onto the admin site and there is long list of windows and symbian (javamo) orbiters.  If i try to pair it on the KDE desktop it goes into a constant loop, saying connectable then connect (phone model) and then back to connectable every 2 seconds.  I did get it to send a file to my phone via bluetooth obex push.  I thought maybe it was the bluetooth adapter. So I went out and bought the d-link dbt-120 list in wiki.  I didn't even recognize the device or install at all on either the desktop or in Bluez.  I've been trying to use the javamo which i have installed on my phone.  What is wrong and what can i do?? ??? I'm still using 7.10 by the way.         

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2421
    • View Profile
    • ago control
Re: Bluez/JavaMo
« Reply #1 on: December 10, 2008, 10:44:50 pm »
some dongles make the bluez stack crash when it has a connection open and does a device inquiry. Maybe it is related to that? What is in the logs?

br, Hari
rock your home - http://www.agocontrol.com home automation

compaqpresario

  • Veteran
  • ***
  • Posts: 76
    • View Profile
Re: Bluez/JavaMo
« Reply #2 on: December 11, 2008, 08:01:59 pm »
========== NEW LOG SECTION ==========
1   12/03/08 20:08:18   67 (spawning-device)   Starting... 50
1   12/03/08 20:08:19   67 (spawning-device)   Found /usr/pluto/bin/LaunchBluetooth_Dongle.sh
05   12/03/08 20:08:24.523      Inquiry started <0x40800950>
05   12/03/08 20:08:27.921      Detected device mac: 00:07:E0:84:F5:CD link quality: -56 <0x42003950>
05   12/03/08 20:08:27.930      About to connect to PlutoMO. We'll suspend scanning... <0x41802950>
05   12/03/08 20:08:27.930      Suspending scanning... <0x41802950>
01   12/03/08 20:08:31.676      received channel: 19
 <0x41802950>
05   12/03/08 20:08:31.748      Can't connect RFCOMM socket 00:07:E0:84:F5:CD, channel 19 <0x41802950>
05   12/03/08 20:08:31.748      Waiting any operation with the socket to finish... <0x41802950>
05   12/03/08 20:08:31.748      BDCommandProcessor_Linux_Bluetooth is destroyed. <0x41802950>
05   12/03/08 20:08:31.748      Failed to connect to PlutoMO. We'll resume scanning <0x41802950>
05   12/03/08 20:08:31.748      Resuming scanning... <0x41802950>
05   12/03/08 20:08:31.755      Inquiry started <0x40800950>
05   12/03/08 20:08:35.625      Detected device mac: 00:07:E0:84:F5:CD link quality: -57 <0x42003950>
05   12/03/08 20:08:35.628      About to connect to PlutoMO. We'll suspend scanning... <0x41802950>
05   12/03/08 20:08:35.628      Suspending scanning... <0x41802950>
01   12/03/08 20:08:39.671      received channel: 19
 <0x41802950>
05   12/03/08 20:08:39.717      Can't connect RFCOMM socket 00:07:E0:84:F5:CD, channel 19 <0x41802950>
05   12/03/08 20:08:39.717      Waiting any operation with the socket to finish... <0x41802950>
05   12/03/08 20:08:39.717      BDCommandProcessor_Linux_Bluetooth is destroyed. <0x41802950>
05   12/03/08 20:08:39.717      Failed to connect to PlutoMO. We'll resume scanning <0x41802950>
05   12/03/08 20:08:39.717      Resuming scanning... <0x41802950>
05   12/03/08 20:08:39.796      Inquiry started <0x40800950>
05   12/03/08 20:08:43.841      Detected device mac: 00:07:E0:84:F5:CD link quality: -54 <0x42003950>
05   12/03/08 20:08:43.860      About to connect to PlutoMO. We'll suspend scanning... <0x41802950>
05   12/03/08 20:08:43.860      Suspending scanning... <0x41802950>
01   12/03/08 20:08:47.705      received channel: 19
 <0x41802950>
05   12/03/08 20:08:47.787      Can't connect RFCOMM socket 00:07:E0:84:F5:CD, channel 19 <0x41802950>
05   12/03/08 20:08:47.787      Waiting any operation with the socket to finish... <0x41802950>
05   12/03/08 20:08:47.787      BDCommandProcessor_Linux_Bluetooth is destroyed. <0x41802950>
05   12/03/08 20:08:47.787      Failed to connect to PlutoMO. We'll resume scanning <0x41802950>
05   12/03/08 20:08:47.787      Resuming scanning... <0x41802950>
05   12/03/08 20:08:47.813      Inquiry started <0x40800950>
05   12/03/08 20:08:51.903      Detected device mac: 00:07:E0:84:F5:CD link quality: -54 <0x42003950>
05   12/03/08 20:08:51.907      About to connect to PlutoMO. We'll suspend scanning... <0x41802950>
05   12/03/08 20:08:51.908      Suspending scanning... <0x41802950>
01   12/03/08 20:08:55.725      received channel: 19
 <0x41802950>
05   12/03/08 20:08:55.794      Can't connect RFCOMM socket 00:07:E0:84:F5:CD, channel 19 <0x41802950>
05   12/03/08 20:08:55.794      Waiting any operation with the socket to finish... <0x41802950>
05   12/03/08 20:08:55.794      BDCommandProcessor_Linux_Bluetooth is destroyed. <0x41802950>
05   12/03/08 20:08:55.794      Failed to connect to PlutoMO. We'll resume scanning <0x41802950>
05   12/03/08 20:08:55.794      Resuming scanning... <0x41802950>
05   12/03/08 20:08:55.861      Inquiry started <0x40800950>
05   12/03/08 20:09:00.077      Detected device mac: 00:07:E0:84:F5:CD link quality: -53 <0x42003950>
05   12/03/08 20:09:00.081      About to connect to PlutoMO. We'll suspend scanning... <0x41802950>
05   12/03/08 20:09:00.081      Suspending scanning... <0x41802950>
01   12/03/08 20:09:03.809      received channel: 19
 <0x41802950>
05   12/03/08 20:09:03.881      Can't connect RFCOMM socket 00:07:E0:84:F5:CD, channel 19 <0x41802950>
05   12/03/08 20:09:03.882      Waiting any operation with the socket to finish... <0x41802950>
05   12/03/08 20:09:03.882      BDCommandProcessor_Linux_Bluetooth is destroyed. <0x41802950>
05   12/03/08 20:09:03.882      Failed to connect to PlutoMO. We'll resume scanning <0x41802950>
05   12/03/08 20:09:03.882      Resuming scanning... <0x41802950>
05   12/03/08 20:09:03.926      Inquiry started <0x40800950>
05   12/03/08 20:09:07.971      Detected device mac: 00:07:E0:84:F5:CD link quality: -53 <0x42003950>
05   12/03/08 20:09:07.975      About to connect to PlutoMO. We'll suspend scanning... <0x41802950>
05   12/03/08 20:09:07.976      Suspending scanning... <0x41802950>
Return code: 139
3   12/03/08 20:09:22   67 (spawning-device)   Device died... count=50/50 dev=67
Wed Dec  3 20:09:22 EST 2008 died
3   12/03/08 20:09:32   67 (spawning-device)   Aborting restart of device 67...

I was always getting the above, since I replaced the libcommon.so file as directed in the JavaMo wiki, if I regen orbiter it says device #67 failed to start.  What is really strange is that i bought the d-link dbt-120 listed in the wiki and i get nothing, it doesn't even recognize it. ??? 

compaqpresario

  • Veteran
  • ***
  • Posts: 76
    • View Profile
Re: Bluez/JavaMo
« Reply #3 on: December 12, 2008, 06:57:25 pm »
any ideas hari?  ???

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2421
    • View Profile
    • ago control
Re: Bluez/JavaMo
« Reply #4 on: December 12, 2008, 07:11:46 pm »
it looks like the javamo is not running on the phone...

as the bluetooth_dongle device was restarted 50 times, it is now prolly disabled.

br, hari
rock your home - http://www.agocontrol.com home automation

compaqpresario

  • Veteran
  • ***
  • Posts: 76
    • View Profile
Re: Bluez/JavaMo
« Reply #5 on: December 12, 2008, 07:33:20 pm »
the javamo on the phone says waiting for connection, but even if i don't have bluetooth enabled on the phone it just loops in the install when i plug in the no name adapter.  Do you have any idea why my other dlink adapter would not even be detected?  in addition to that, since i changed the libcommon.so file, it gets to starting up the adapter, and then says device failed. do you have any idea what this means....05   12/03/08 20:08:31.748      BDCommandProcessor_Linux_Bluetooth is destroyed.

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2421
    • View Profile
    • ago control
Re: Bluez/JavaMo
« Reply #6 on: December 12, 2008, 08:18:27 pm »
of course you should enable bluetooth on the phone :-)

br, Hari
rock your home - http://www.agocontrol.com home automation

compaqpresario

  • Veteran
  • ***
  • Posts: 76
    • View Profile
Re: Bluez/JavaMo
« Reply #7 on: December 13, 2008, 03:21:23 am »
lol, yeah i meant whether or not the bluetooth was enabled on the phone it just says waiting for connection and the dongle loops in installation until i swapped out with the the new libcommon. Now it fails at 80% saying the device failed and i have to press ok. any thoughts as to why the dlink is not even detected but listed as working in the wiki? ;D