Author Topic: twitchy video playback, how to tweak away?  (Read 1364 times)

johanr

  • Veteran
  • ***
  • Posts: 144
    • View Profile
twitchy video playback, how to tweak away?
« on: October 11, 2008, 10:07:28 pm »
Hi again!

as the subject implies I have problems with a twitchy playback when watching ripped dvds or even dvd from the disc drive.(especially noticed during alot of camera movement sideways)

I am sure it's just a setting thing but since I cannot find any tip on the web how to increase buffer size or similar for _this matter_ I decided to start a new thread here.

The Hw I am using is the following and should handle the playback flawlessly(I think)
I am using the Mobo vga output since I am just testdriving the setup, can that cause this? (I am used to have an external card before in previous machines)

Core/Hybrid:
ANTEC NSK2480-EC HTPC-CHASSI M-ATX
ABIT AN-M2HD, nForce 630a+GF7050PV, Socket-AM2, DDR2, HDMI, m-ATX, PCI-Ex16
NOCTUA NC-U6 CHIPSET COOLER
AMD ATHLON X2 4850E 2.5 GHZ 512KB 1000MHZ BOXED S-AM2
Noctua NH-C12P CPU cooler Socket 754/939/940/775/AM2/AM2+
Corsair TWIN2X 6400 DDR2, 4096MB CL5,Kit w/two matched CM2X2048-6400 Dimm's
Samsung SpinPoint T166 320GB SATA2 16MB 7200RPM  (SATA)
D-Link PCI Gigabit Ethernet Adapter    
Creative SB0886 X-Fi Titanium Fatal1ty Pro series, PCI Express    
D-LINK DBT-122 USB BLUETOOTH V1.2 ADAPTER

Br
Johan

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: twitchy video playback, how to tweak away?
« Reply #1 on: October 12, 2008, 04:04:08 am »
Switch to ui 2 no alpha blending, make sure  you have vsync on in all options in nvidia settings and you should get minimal or no tearing with that configuration.



good luck

TIm
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: twitchy video playback, how to tweak away?
« Reply #2 on: October 12, 2008, 04:27:30 pm »
Also make sure your machine is using the "nvidia" driver, not "nv" or "vesa".
"Change is inevitable. Progress is optional."
-- Anonymous


johanr

  • Veteran
  • ***
  • Posts: 144
    • View Profile
Re: twitchy video playback, how to tweak away?
« Reply #3 on: October 12, 2008, 09:04:56 pm »
Hey Thanks!  It now plays without twitching.. at least the few movies I have quickly gone trough.
Maybe I should google this but what am I loosing when not choosing alpha blending/to me it sounded like the best of the best) Still possible to do 1080p on a 180 inch screen(I use projector) with top notch picture?


Zaerc, at first I did not know where to look what driver there was(was thinking console command) but found it in the Lmce launch manager under the Video.. Hehe, I think I am sometimes too used by using console all the time so I don't spend so much time looking at what really is there in these Really helpful Gui:s (linux admin, launch mgr etc)

Wow this piece of sw impresses me(and challenges me) even more every day...
Great Work once more(can't be said enough I think)

-johan

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: twitchy video playback, how to tweak away?
« Reply #4 on: October 12, 2008, 10:48:25 pm »
It is the best option, if you can stand the tearing which is particularly bad on a large screen. Most people find they are more than happy in overlay mode. And btw, you change your driver at the command line - edit /etc/X11/xorg.conf, you will find a line for the driver, which you can then change to nvidia if it isn't already. The next time X starts up you will see any change reflected in the launch manager.

Col.

johanr

  • Veteran
  • ***
  • Posts: 144
    • View Profile
Re: twitchy video playback, how to tweak away?
« Reply #5 on: October 12, 2008, 11:12:32 pm »
ok, well I am currently watching  on a 20" cheap o' crappo monitor and suffer from the tearing. Lets see what happens when watching on the projector. Maybe I need to get a PCI-E graphic card anyway, guess that will help(?) however by reading a few posts it looks like it won't.. hmm..

 Can't really test that until the house is ready though.
Thanks for the tip.Great!
 Learning more and more everyday.  :)

-johan

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: twitchy video playback, how to tweak away?
« Reply #6 on: October 12, 2008, 11:34:43 pm »
Its not a performance thing, so higher end graphics cards or PCIe will not make much difference. People experience this from the low end cards all the way up through the 8xxx series. I believe it is a bug in the nvidia proprietary driver in the way it syncs buffer flips whilst an alpha blend map exists, but I'm not holding my breath for a fix from them!

All I meant was a larger screen tends to make a tear more visible. The tear will be there on both. The key is whether the alpha blend map exists, not whether it is actually being used at the time which is why you still see the tear even when there are no menus on screen. If it was a performance thing, then the tear should disappear as soon as the menus disappear.

Have fun!

andreasm

  • First post!
  • Posts: 1
    • View Profile
Re: twitchy video playback, how to tweak away?
« Reply #7 on: December 22, 2008, 10:41:08 pm »
@colinjones

I am "sorry" to confirm your conclusion...
I have been reading this board "empty" of tips'n tricks and read several other forums to make video playback smooth. But no luck. And the last post (unfortunately) I read was yours.
The way I see it (after testing every settings possible in X (xorg.conf) and adjustments in the Nvidia Control Panel) there is no way to get this work ok with AlphaBlend and certain Nvidia cards (and respective driver).

Even though it seems pretty dark in the end of the tunnel for Alpha Blending and some Nvidia cards/drivers, I have not yet tried as the threadstarter mentioned a 32-bit MD. And the only Nvidia driver I have actually tested with is the latest Nvidia Driver 177.82 x64.
Do you think it is worth trying older drivers?

My card is a GF7800GT, and with the latest driver it does not work well with alpha blending. It works flawlessy without.

This is not LinuxMCE's fault. Which by the way must be the most complete solution I have ever laid my hands on. And it works more or less "out-of-the-box".

Andreas

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: twitchy video playback, how to tweak away?
« Reply #8 on: December 24, 2008, 02:15:26 am »
Andreas

There are many conclusions we could draw from this info, but most would be assumptions!

But for one thing, x64 will not make any difference over x32 for this issue by virtue of the 64bits alone - this is for the CPU not the GPU, so only if one version of the driver happened to have a bug that causes this issue and the other didn't - but that seems unlikely as the code for each is likely to be the same or extremely similar. Even then, there is no reason to assume that the x64 would be the driver without the bug!

I would like to think that the but is in the nVidia driver - but logic doesn't necessarily support that. If it was, then most OpenGL/SDL apps would suffer the same issues, and they do not. For instance, I have run Savage 2 which is an extremely graphics intensive application - vastly moreso than the Orbiter, with no issue at all. The frame rate on a particular application may slow right down under extreme workloads, but that still shouldn't introduce tearing. Tearing really ought to be a functional timing issue, rather than a performance issue.

Again, that doesn't necessarily point the finger at the Orbiter either. My guess (based on nothing whatsoever) is it is something to do with the way the Orbiter code interacts with the driver - so a combination of the two. But that would require someone with a really deep level understanding both of the Orbiter code and graphics generally. These people are very thin on the ground here, and otherwise occupied at the moment!