Author Topic: Screensaver panning/zoom  (Read 3640 times)

Dale_K

  • Veteran
  • ***
  • Posts: 149
    • View Profile
Screensaver panning/zoom
« on: December 09, 2008, 04:18:17 pm »
How would I go about turning off the panning/zoom of the screensaver pics.  I've disabled flickr and copied my own photos to the core and everything is working great except the panning/zoom thing.  I can't find a setting for it in WebAdmin so I'm assuming it's a file I need to edit.

Thanks

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5549
  • DOES work for LinuxMCE.
    • View Profile
Re: Screensaver panning/zoom
« Reply #1 on: December 09, 2008, 04:32:45 pm »
web admin > advanced > configuration > devices

Select Core/Hybrid > OnScreen Orbiter > Photo Screen Saver

Change the ZoomTime to 0.

Why do you want this off, anyway? :-/

-Thom

krys

  • Addicted
  • *
  • Posts: 583
    • View Profile
Re: Screensaver panning/zoom
« Reply #2 on: December 09, 2008, 05:28:50 pm »
Thom you crack me up!  ;D

Dale_K

  • Veteran
  • ***
  • Posts: 149
    • View Profile
Re: Screensaver panning/zoom
« Reply #3 on: January 28, 2009, 07:08:15 pm »
Got It!!

Big thanks to tschak for pointing me in the right direction.

Changing the ZoomTime to 0 makes the images stop panning, but does not make the image not zoom in randomly.

So, I spoke with tschak in IRC about it and he indicated that I probably needed to modify the source code.  I went to the wiki to find out how to build a development environment and found this: http://wiki.linuxmce.org/index.php/Setting_Up_A_Development_Environment

However, tschak told me I didn't want to use 'trunk' but LinuxMCE-0710 so with some more searching I found this:
http://wiki.linuxmce.org/index.php/Building_From_Source
(Thanks to Zaerc for the info.)

So, having my new handy dandy development environment I went to the ~/LinuxMCE-0710/src/Photo_Screen_Saver folder and started looking at .cpp files.  Understand that I'm completely clueless in terms of programming but I ain't scared to break some shit.

Finally after a number of failed attempts I finally found this section in the ZoomSimple.cpp file:

ZoomAmount1 = RandomInInterval(500, 1000)/1000.0f;

and

ZoomAmount2 = RandomInInterval(500, 1000)/1000.0f;

I changed both of these lines to:

ZoomAmount1 = RandomInInterval(1, 2)/1.0f;
ZoomAmount2 = RandomInInterval(1, 2)/1.0f;

Then in my terminal session from ~/LinuxMCE-0710/src/Photo_Screen_Saver  (running as root)

make bin
cp Photo_Screen_Saver /usr/pluto/bin

Do a quick reload and shazaam!  I now have images that do not zoom in, I can see the entire image.

Thanks again to tschak for bearing with a noob and to Zaerc for authoring the wiki that got me started.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5549
  • DOES work for LinuxMCE.
    • View Profile
Re: Screensaver panning/zoom
« Reply #4 on: January 28, 2009, 07:17:50 pm »
Congratulations!

For future improvement, an enterprising hacker can look at adding a single field for Device Data called Zoom Interval, and using it inside the code to set this value, rather than hard-coding it.

There are examples in any generated DCE device (the example may even still be in the photo screensaver), for using DATA_foo to access a device data called foo.

-Thom

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Screensaver panning/zoom
« Reply #5 on: January 28, 2009, 08:28:50 pm »
And the other way around, it would also be nice to be able to have the screensaver pan and zoom under UI1 (when the hardware and drivers support it, of course).
"Change is inevitable. Progress is optional."
-- Anonymous


b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: Screensaver panning/zoom
« Reply #6 on: January 28, 2009, 10:28:52 pm »
Or ...
web admin > advanced > configuration > devices

Select Core/Hybrid or your md > OnScreen Orbiter > Photo Screen Saver

Scroll to device data at the bottom and change 'Type' to static.
 ;)

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5549
  • DOES work for LinuxMCE.
    • View Profile
Re: Screensaver panning/zoom
« Reply #7 on: January 28, 2009, 10:41:23 pm »
Static gets rid of the fade.

-Thom

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: Screensaver panning/zoom
« Reply #8 on: January 28, 2009, 10:48:40 pm »
Sorry Thom,
Didn't know fade was still required!
 :-[

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5549
  • DOES work for LinuxMCE.
    • View Profile
Re: Screensaver panning/zoom
« Reply #9 on: January 28, 2009, 10:53:09 pm »
static is selected when a non-openGL media director is used. It disables all openGL functions and uses a static SDL bitblt.

-Thom


b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: Screensaver panning/zoom
« Reply #10 on: January 28, 2009, 11:11:33 pm »
Personally I prefer the animated photo screen saver but my intel graphics card disagrees!
 :)

Dale_K

  • Veteran
  • ***
  • Posts: 149
    • View Profile
Re: Screensaver panning/zoom
« Reply #11 on: January 30, 2009, 03:15:07 pm »
Or ...
web admin > advanced > configuration > devices

Select Core/Hybrid or your md > OnScreen Orbiter > Photo Screen Saver

Scroll to device data at the bottom and change 'Type' to static.
 ;)

That doesn't prevent the image from being zoomed in.

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: Screensaver panning/zoom
« Reply #12 on: January 30, 2009, 03:37:28 pm »
That doesn't prevent the image from being zoomed in.
Strange! It stops all animations (fades/pans/zooms) on my md and just shows static pictures.
Might need to reboot your md and/or quick reload router.
Barney

Dale_K

  • Veteran
  • ***
  • Posts: 149
    • View Profile
Re: Screensaver panning/zoom
« Reply #13 on: February 02, 2009, 04:33:46 pm »
Strange! It stops all animations (fades/pans/zooms) on my md and just shows static pictures.
Might need to reboot your md and/or quick reload router.
Barney

It does stop animations, the image doesn't move or do an animated zoom in/out, but the images are zoomed at different levels when they appear.  Remove all images but one from your screen saver selections and click reload screen saver in webadmin, you'll see what I mean.

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: Screensaver panning/zoom
« Reply #14 on: February 02, 2009, 05:41:44 pm »
Ah! Right. Good point. I thought I'd saved my pics at the wrong resolution. :-\

It would be nice to display full images (depending on screen size) if it is possible with the 'static' setting. Anyone else achieved this?
Barney