Author Topic: Reinstalled Os, but now internet won't work!  (Read 2521 times)

ukulele_ninja

  • Regular Poster
  • **
  • Posts: 34
    • View Profile
Reinstalled Os, but now internet won't work!
« on: December 06, 2008, 09:11:32 am »
Well I decided to go ahead and reinstall linuxmce after running into roadblocks trying to login to the server.

Anyway, that issue is resolved except now I can't get online! It did the updates at the beginning ok but none of my browsers are responding.

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: Reinstalled Os, but now internet won't work!
« Reply #1 on: December 06, 2008, 09:47:25 am »
Check your IP address:
http://192.168.80.1/pluto-admin/index.php?section=networkSettings

What's your "GATEWAY" IP address?

Maybe you have the NIC cards back to front?

ukulele_ninja

  • Regular Poster
  • **
  • Posts: 34
    • View Profile
Re: Reinstalled Os, but now internet won't work!
« Reply #2 on: December 06, 2008, 04:52:10 pm »
I only hae one onboard NIC card, but I let it go overnight and didnt touch it and now all of a sudden this morning it decided to wrok.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: Reinstalled Os, but now internet won't work!
« Reply #3 on: December 06, 2008, 05:10:48 pm »
You need to have two NIC cards.

*hmm* people just don't #@($@#( listen.

-Thom

ukulele_ninja

  • Regular Poster
  • **
  • Posts: 34
    • View Profile
Re: Reinstalled Os, but now internet won't work!
« Reply #4 on: December 06, 2008, 05:18:26 pm »
I thought the two NIC cards were only if I had more than one unit? Currently I am running MCE on my main computer and having it act as my core and media manager. Besides, the internet started working.


tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: Reinstalled Os, but now internet won't work!
« Reply #5 on: December 06, 2008, 05:43:45 pm »
God damn it, will you listen to me?! *Smack-you-hard!*

The reason it's acting goofy is, that it created an ethernet alias.

It created two cards, eth0 for the internet, and eth0:0 for the internal network. These are going to the same card, and the network packets are going out the same cable.

LinuxMCE starts its own DHCP server to handle the internal network, and if you have an existing DHCP server running, it will collide! causing EXACTLY THE SAME PROBLEMS YOU ARE EXPERIENCING. and guess what? it will come back!

The solution, is to put another nic card in, and simply don't use it. LMCE will configure it, and put the DHCP on the empty NIC card, _AVOIDING_ the problem you're experiencing.

(yes, you will need to reinstall.)

*hmm* people never read... people never listen, and then they whine and complain. What will it take for you people? we write it down for you all so you guys don't go THROUGH this shit!

-Thom

ukulele_ninja

  • Regular Poster
  • **
  • Posts: 34
    • View Profile
Re: Reinstalled Os, but now internet won't work!
« Reply #6 on: December 06, 2008, 05:48:13 pm »
Dude calm yourself, I read that but was under the impression that it would only affect me if I was running more than one device from this box. I apologize for wasting your precious time man but come on.

So adding a second NIC card and reinstalling the Os takes care of the problem, got it.

takeitngo

  • Making baby steps
  • Posts: 2
    • View Profile
Re: Reinstalled Os, but now internet won't work!
« Reply #7 on: December 07, 2008, 12:12:03 am »
Yeah, tschak909 shut the fuck up, stop being such a bitch about it, ever think he might be new to this type of linux huh? A lot of people start out not knowing anything about linux and come to forums for answers instead of researching, it's easier and if people weren't such asses to them maybe there would be less problems.

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Reinstalled Os, but now internet won't work!
« Reply #8 on: December 07, 2008, 01:35:19 am »
Yeah, tschak909 shut the fuck up, stop being such a bitch about it, ever think he might be new to this type of linux huh? A lot of people start out not knowing anything about linux and come to forums for answers instead of researching, it's easier and if people weren't such asses to them maybe there would be less problems.
Oh look it's another hungry troll...  ::)
"Change is inevitable. Progress is optional."
-- Anonymous


tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: Reinstalled Os, but now internet won't work!
« Reply #9 on: December 07, 2008, 01:35:55 am »
takeitngo: I'm one of the devs, you twit.

My frustrations come out of people who i've talked to, who refuse to listen to things we tell them, and then wonder why things break?

-Thom

uplink

  • Administrator
  • Guru
  • *****
  • Posts: 191
  • Linux and LinuxMCE witchdoctor
    • View Profile
Re: Reinstalled Os, but now internet won't work!
« Reply #10 on: December 07, 2008, 01:47:18 am »
takeitngo: Easier to come to the forums than to research? Can I quote you on that when I come to kick your ass?

Your affirmation simply pisses me off. I mean, I do my best not to bother people unless I'm pretty sure the information I'm looking for is not out there, or, if it is, it's so well hidden that no matter how I twist my search terms it just won't show up, and here you are, and the likes of you, that consider it _easier_ to bother others than _research_. You deserve a smacking for this affirmation alone. The forumers aren't search engine replacements you know.

Also, the proper attitude is: "Oh, alright then." (acceptance of the fact) and, if you don't like it, change it and submit a patch (involvement). In no way whining is going to get you a medal. Unless it's in the form of a foot up your ass.

Now, Tschack is pissed off, and he should take a break from the forums to chill. But that's another story, and it doesn't excuse ignorance.

Hope you catch my drift.

**** Update ****

takeitngo: I just noticed this your first post in the forums. This means one thing: bend over, or you'll be bent over by force, and we'll form a queue behind you, each with his own thoughts in mind
« Last Edit: December 07, 2008, 02:12:30 am by uplink »

ukulele_ninja

  • Regular Poster
  • **
  • Posts: 34
    • View Profile
Re: Reinstalled Os, but now internet won't work!
« Reply #11 on: December 07, 2008, 03:30:23 am »
Ive made an honest effort to try and learn this distro and learn MCE, but its been over 7 years since Ive even used Linux.

One problem I have run into on this site is that when using the search function, articles and threads that are displayed have been outdated and rendered irrelevant. For example, the search function and the wiki both presented conflicting and confusing views regarding JavaMO and its compatibility. The wiki has a very short article and only mentions a few devices it is even compatible with, meanwhile, the search function showed me threads that lead one to believe that it JavaMO does not even exist or is still in development! Same goes for looking for information on motherboards that are compatible, the wiki said yes, and threads said no.

So I apologize if I pissed anyone off, it was not my intention and all I really wanted to do was learn without sounding 'whiny'. Therefore, Im not going to mess with it anymore till I get my box put together after the holidays and meanwhile i try my best to learn more about the LinuxMCE and some other media center options which I have already discovered may be better for my needs and with more understanding forum users.

No hard feelings toward anyone, ill reserve posting anymore until I have the box put together i intend to use permanently.   

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: Reinstalled Os, but now internet won't work!
« Reply #12 on: December 07, 2008, 03:34:38 am »
and I apologise for flying off the handle.

-Thom

Afkpuz

  • Guru
  • ****
  • Posts: 211
    • View Profile
Re: Reinstalled Os, but now internet won't work!
« Reply #13 on: December 07, 2008, 03:55:11 am »
Is it any better to turn off DHCP when you only have 1 ethernet card?

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: Reinstalled Os, but now internet won't work!
« Reply #14 on: December 07, 2008, 03:57:26 am »
Yes, but again, by design the external IP is locked down...so it becomes more difficult to reach the web admin, among other things...

-Thom