Author Topic: Device Template  (Read 3062 times)

cesarscav

  • Veteran
  • ***
  • Posts: 55
    • View Profile
Device Template
« on: December 04, 2008, 08:08:25 am »
Hi all,
I get a new tv sharp aquos with rs232c port try to connect it to my core/hybrid and it was not autodetected so I try to add it manually, but first I need to edit the A/V Properties of the template as posted on wiki  http://wiki.linuxmce.org/index.php/Alx9r%27s_Aquos_TV_Setup follow steps listed there but, when I try Edit Audio/Video Properties. I have an error telling


    ERROR!
Cannot retrieve IR codes.

I'm Running a new installation, Unfortunately I don't have the old installation any more, to compare, but I found out that if I try to add an other av equipment it do the same thing, same error Cannot retrieve IR codes, bellow this it is a retry link when I click on it it give me an other error in the same frame saying "Device template # 0 was not found". I'm using LMCE 7.10 RC2 I386 I also tried the AMD64 same results.

thank you for any help you can give me on this.


cesarscav

  • Veteran
  • ***
  • Posts: 55
    • View Profile
Re: Device Template
« Reply #1 on: December 04, 2008, 03:44:51 pm »
any one please?
I'm clueless.
I do not know where to start to troubleshoot this.
Searched wiki searched forum no similar problem.
It seems that it is related with the sqlCVS?
could I start here. how do I rebuild it?



cesarscav

  • Veteran
  • ***
  • Posts: 55
    • View Profile
Re: Device Template gone
« Reply #2 on: December 04, 2008, 05:10:55 pm »
If some one please can tell me where to look for a log file to see a detail of the error
Thanks

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: Device Template
« Reply #3 on: December 04, 2008, 05:33:13 pm »
I am now seeing the same issue on my system.
Did you modify your db by any chance.

I did reinitialize my pluto_media but even after restoring a backup the problem remains.


So I too am looking into this.   I thought it was just me.


Tim
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

cesarscav

  • Veteran
  • ***
  • Posts: 55
    • View Profile
Re: Device Template
« Reply #4 on: December 04, 2008, 10:01:35 pm »
Tim,
It is a clean installation I did not touch the DB.
its possible that during installation the system tries to download something from a repository that is broken or inaccessible?
where to look for some logs tho see what could be happening? I'm not a Linux expert but I know my way around.
 

Cesar

cesarscav

  • Veteran
  • ***
  • Posts: 55
    • View Profile
Re: Device Template
« Reply #5 on: December 04, 2008, 10:03:59 pm »
In the previous message is an attachment of the error screen.

cesarscav

  • Veteran
  • ***
  • Posts: 55
    • View Profile
Re: Device Template( Lost)
« Reply #6 on: December 05, 2008, 01:19:33 am »
He guys New installation different hawrdware new downloaded isos same problem I thinks somenthig is meessing on installation.

The Device Templates are installed locally with the cd or DVDs or they came from an other source like they are downloded at installation from some other source?

Thanks
Cesar

cesarscav

  • Veteran
  • ***
  • Posts: 55
    • View Profile
Re: Device Template
« Reply #7 on: December 05, 2008, 04:55:53 am »
Serching the wiki I found that, as I though, the the device template's infrared or Ruby codes are fetched from the linuxmce.org website
with this script
Quote
/usr/pluto/bin/WebDB_GetIR.sh [deviceID] [deviceTemplateID] [restriction flag]
I ran this scripts on linux shell and it response
Code: [Select]
linuxmce@dcerouter:/usr/pluto/bin$ /usr/pluto/bin/WebDB_GetIR.sh 1856
ERROR. Empty result
linuxmce@dcerouter:/usr/pluto/bin$
Is there an alternative url that I can use to test?
what should I see if I put the parameters of the script on a browser?
I get this

cesarscav

  • Veteran
  • ***
  • Posts: 55
    • View Profile
Re: Device Template
« Reply #8 on: December 05, 2008, 06:35:36 am »
An other update on this problem
I decided to take a look at the InfraredGroup_Command table on the pluto_main database. It is empty. Is this normal? from where can I download a sql file to import locally? It is possible to do this?

Thanks in advance


Cesar

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2421
    • View Profile
    • ago control
Re: Device Template
« Reply #9 on: December 05, 2008, 10:23:21 am »
good point, this script does not work any more after we've moved services. I'll fix it.

br Hari
rock your home - http://www.agocontrol.com home automation

cesarscav

  • Veteran
  • ***
  • Posts: 55
    • View Profile
Re: Device Template
« Reply #10 on: December 05, 2008, 04:14:41 pm »
Hari,
Thanks for your reply.
Are you going to fix the script or the service?
is something that i can do to help or test?

Thanks again

Cesar

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2421
    • View Profile
    • ago control
Re: Device Template
« Reply #11 on: December 05, 2008, 04:38:02 pm »
the script is the service :-) I'm sure i will find time tonite or tomorrow.

br, Hari
rock your home - http://www.agocontrol.com home automation

cesarscav

  • Veteran
  • ***
  • Posts: 55
    • View Profile
Re: Device Template
« Reply #12 on: December 06, 2008, 07:01:39 pm »
Hari,
I sorry what I meant with service was something to fix on the linuxmce.org site, where the codes are fetched from, or something on the local script it self. if this last is the case is there some parameters o values that I have to change? or is a complete rewrite of the script?
I ask this again is something I can do to help. I think this is a very important feature of the system and is affecting all users that wants to add new devises. Is there is a walkaround for this problem?

thank you for your great job
Cesar



cesarscav

  • Veteran
  • ***
  • Posts: 55
    • View Profile
Re: Device Template
« Reply #13 on: December 08, 2008, 09:48:23 pm »
Hari,
I'm still unavailable to retrieve  GSD or IR codes for my AV devices.
Did you had a chance to look at it?
Again if there is something I can assist in this, let me know.
Thanks.
Cesar

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4437
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Device Template
« Reply #14 on: December 09, 2008, 10:48:10 am »
Hari,
I'm still unavailable to retrieve  GSD or IR codes for my AV devices.
Did you had a chance to look at it?
Again if there is something I can assist in this, let me know.
Thanks.
Cesar


Hi Cesar,

Hari's a busy guy right now so I expect he's a little 'snowed under' as they say. However if you want to have a quick check of where he is on this look for him on irc channel #linuxmce-devel

All the best

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk