Author Topic: LIRC with rebuilt kernel- working!  (Read 2311 times)

indulis

  • Veteran
  • ***
  • Posts: 147
    • View Profile
LIRC with rebuilt kernel- working!
« on: November 23, 2008, 04:11:17 pm »
Hi,

I've put the steps required to get LIRC to work with a new 2.6.27 kernel in the Wiki.
http://wiki.linuxmce.org/index.php/Upgrading_the_Kernel#LIRC_IR_control

The instructions only build one device module for a particular IR receiver.  This is because some modules won't build.

The only thing left to do is to figure out which modules won't build, and leave them out of the configure step.

Enjoy!

PS my system has been amazingly stable on the new kernel, even compared to the previous version, *and* my tuners are rock solid instead of dropping out and requiring reboots to reacquire them

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: LIRC with rebuilt kernel- working!
« Reply #1 on: November 23, 2008, 11:29:40 pm »
The LIRC included with LMCE is patched to add features and cannot be replaced just like that.
"Change is inevitable. Progress is optional."
-- Anonymous


darrenmason

  • Addicted
  • *
  • Posts: 529
    • View Profile
Re: LIRC with rebuilt kernel- working!
« Reply #2 on: November 24, 2008, 12:10:50 am »
Zaerc,

Do you know what the patch is for? I didn't think there were any changes.
I have also rebuilt or installed different precompiled versions of lirc in the past - with nothing breaking that I can recall.

If someone is changing the list of configured devices that gets built - can they please add iguanaIR

Thanks
Darren

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: LIRC with rebuilt kernel- working!
« Reply #3 on: November 24, 2008, 01:24:13 am »
The patch that pluto applied for lirc is necessary for Pronto code conversion.

-Thom

indulis

  • Veteran
  • ***
  • Posts: 147
    • View Profile
Re: LIRC with rebuilt kernel- working!
« Reply #4 on: November 24, 2008, 09:24:59 am »
Well it was better to replace it than have *no* LIRC  ;)

OK is there a way to recompile the "LMCE-ized" LIRC?  Anything else that is likely to go off the rails by putting in a newer and un-patched LIRC?

As 7.10 has been out for a while, I'm wondering why the pluto patch has not made its way back into the LIRC code?  Or is it a recent patch?

I'm happy to document the LMCE way to get LIRC working if someone can give me a pointer as to where to start.
« Last Edit: November 24, 2008, 09:45:09 am by indulis »

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: LIRC with rebuilt kernel- working!
« Reply #5 on: November 25, 2008, 01:00:37 am »
Well it was better to replace it than have *no* LIRC  ;)

OK is there a way to recompile the "LMCE-ized" LIRC?  Anything else that is likely to go off the rails by putting in a newer and un-patched LIRC?

As 7.10 has been out for a while, I'm wondering why the pluto patch has not made its way back into the LIRC code?  Or is it a recent patch?

I'm happy to document the LMCE way to get LIRC working if someone can give me a pointer as to where to start.
From what I heard the patches were made available and rejected on their mailing list.

I have joined them and patched intrepid's lirc with it, see: http://trac.linuxmce.org/trac.cgi/browser/branches/LinuxMCE-0810/ubuntu/lirc-0.8.3%2Blmce

...
If someone is changing the list of configured devices that gets built - can they please add iguanaIR
...

Just let me know what needs to be changed and I'll try.
"Change is inevitable. Progress is optional."
-- Anonymous


darrenmason

  • Addicted
  • *
  • Posts: 529
    • View Profile
Re: LIRC with rebuilt kernel- working!
« Reply #6 on: November 25, 2008, 01:27:12 am »

...
If someone is changing the list of configured devices that gets built - can they please add iguanaIR
...

Just let me know what needs to be changed and I'll try.

Just a compile flag I believe to include the driver.

fastie81

  • Veteran
  • ***
  • Posts: 136
  • SSDD
    • View Profile
Re: LIRC with rebuilt kernel- working!
« Reply #7 on: December 15, 2008, 12:58:19 am »
Hi guys

I am also trying to get my Lirc working, I have installed the new 0810 Alpha.
Now On mythbuntu I needed to do a few patches to get my lirc working.. So with alpha beeing on 0810 I was thinking it would work if I do the same.. bit it does not look like it does.. The steps I do and patches I apply is on my site. Would this be able to be added to the lirc or can some on that knows lmce have a look and tell me where I go wrong?
I am still new with linuxmce but think I have enough linux skills..
Thanks
C

PS: here is my site with my step.. Still a draft.
http://sites.google.com/site/it1stop/Home/linux/mythbuntu---linuxmce/lirc-remote

gumis

  • Regular Poster
  • **
  • Posts: 21
    • View Profile
Re: LIRC with rebuilt kernel- working!
« Reply #8 on: December 16, 2008, 07:48:02 pm »
Zaerc: I don't know if you happend to see one of my posts on the forum here http://forum.linuxmce.org/index.php?topic=6932.0 about multiple lirc* devices in /dev/ directory when used with SoundGraph IR/LCD 0038 hardware?

Would it be possible to patch lirc to use only one instance of it - /dev/lirc0 for both: IR and LCD? Or is it something to be included in New Device Template and then just a matter of modifying LIRC_DCE? As far as I know that's how it worked in previous versions, it's only 0038 model which creates this problem...

Regards
[core/hybrid]
os: LinuxMCE
mobo: Asus P5Q/P45, 8.1 HD Intel Audio, 1GB NIC
proc: Intel-D 3GHz, LGA775
ram: 4GB OCZ
hdd: 1x160GB SATA and 2x500GB SATA
gfx: MSI GF9400GT,VGA/DVI/HDMI,512MB RAM
case: Antec Fusion MAX with iMON RC, LCD and iMON knob

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: LIRC with rebuilt kernel- working!
« Reply #9 on: December 17, 2008, 01:44:09 am »
Zaerc: I don't know if you happend to see one of my posts on the forum here http://forum.linuxmce.org/index.php?topic=6932.0 about multiple lirc* devices in /dev/ directory when used with SoundGraph IR/LCD 0038 hardware?

Would it be possible to patch lirc to use only one instance of it - /dev/lirc0 for both: IR and LCD? Or is it something to be included in New Device Template and then just a matter of modifying LIRC_DCE? As far as I know that's how it worked in previous versions, it's only 0038 model which creates this problem...

Regards

To be perfectly honest, I don't know as I don't own that hardware and in fact I don't use IR at all myself.  The sources for the version(s) of LIRC that we use are available from our SVN.  If you (or anybody else) comes up with a patch agains that I'll be happy to apply it but for the time being I probably won't be putting in a lot of time and effort myself as there are plenty of other things that still need fixing.  :-\


"Change is inevitable. Progress is optional."
-- Anonymous


gumis

  • Regular Poster
  • **
  • Posts: 21
    • View Profile
Re: LIRC with rebuilt kernel- working!
« Reply #10 on: December 18, 2008, 04:44:37 pm »
I'll look into patching LIRC_DCE but first I need to find out how to build it from source.

[core/hybrid]
os: LinuxMCE
mobo: Asus P5Q/P45, 8.1 HD Intel Audio, 1GB NIC
proc: Intel-D 3GHz, LGA775
ram: 4GB OCZ
hdd: 1x160GB SATA and 2x500GB SATA
gfx: MSI GF9400GT,VGA/DVI/HDMI,512MB RAM
case: Antec Fusion MAX with iMON RC, LCD and iMON knob

indulis

  • Veteran
  • ***
  • Posts: 147
    • View Profile
Re: LIRC with rebuilt kernel- working!
« Reply #11 on: December 19, 2008, 04:07:50 am »
Gumis- think you should be able to use the steps that I outlined above, basically configure, make, then checkinstall.  Checkinstall builds a .deb package which you can then use dpkg -i to install.  You will have to change the configure steps to include your IR device (try configure --help I think, not at system right now).

fastie81

  • Veteran
  • ***
  • Posts: 136
  • SSDD
    • View Profile
Re: LIRC with rebuilt kernel- working!
« Reply #12 on: January 15, 2009, 10:30:11 pm »
Hi gumis

Have you tried to recomplie lirc yet? Can I help?

For anyone ells
I know 0.8.4a has been released, and it looks like it is not going to be added in the repo of ubuntu 8.10, My question here is are LinuxMCe going over to 0.8.4a or staying on default 0.8.3 as with the kubuntu release. and if that is the case I got steps how to get the lirc to work in 8.10, how diffrent is that from the LinuxMCE pluto install ? Will my steps that I am doing in ubuntu 8.10 work with the alpha release? just want to see if we can add the support of the Soundgrafe 0038 version to linuxmce.
Chris



gumis

  • Regular Poster
  • **
  • Posts: 21
    • View Profile
Re: LIRC with rebuilt kernel- working!
« Reply #13 on: June 14, 2009, 10:11:52 pm »

I've managed to get my iMon 0038 working on 7.10 by updating Lirc to 0.8.4a (and 0.8.5 as well) and re-compiling LIRC_DCE with additional options. It's not the best solution but it worked fine for me.
What I did is basically hard coded commands to execute lirc in LIRC_DCE. By default LIRC_DCE executes this command to start lircd:
Code: [Select]
/usr/local/sbin/lircd --driver=default --device=/dev/lirc0 /etc/lirc/lircd.conf

and because iMon 0038 creates two devices: /dev/lirc0 and /dev/lirc1 I've decided to change it to:
Code: [Select]
/usr/local/sbin/lircd --driver=default --device=/dev/lirc0 --pidfile=/var/run/lirc0.pid --listen=8765 /etc/lirc/lircd.conf
/usr/local/sbin/lircd --driver=default --device=/dev/lirc1 --pidfile=/var/run/lirc1.pid --output=/dev/lircd --connect=localhost:8765 /etc/lirc/lircd.conf


I need to find a better way of solving this problem...
[core/hybrid]
os: LinuxMCE
mobo: Asus P5Q/P45, 8.1 HD Intel Audio, 1GB NIC
proc: Intel-D 3GHz, LGA775
ram: 4GB OCZ
hdd: 1x160GB SATA and 2x500GB SATA
gfx: MSI GF9400GT,VGA/DVI/HDMI,512MB RAM
case: Antec Fusion MAX with iMON RC, LCD and iMON knob