Author Topic: NVidia VDPAU API  (Read 3906 times)

jerunamuck

  • Making baby steps
  • Posts: 2
    • View Profile
NVidia VDPAU API
« on: November 16, 2008, 12:33:31 am »
Is support for nVidia VDPAU API scheduled for the next release of linuxMCE core functionality or is this up to the individual media players (v4l, totem,...)
newbielink:http://www.nvidia.com/object/linux_display_ia32_180.06.html [nonactive]

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: NVidia VDPAU API
« Reply #1 on: November 16, 2008, 12:58:34 am »
Dear god, this just HAPPENED and you're already asking us about it?

answer is, we don't know if we'll have time to do it this release cycle. We still need to figure out what to do to support it.

-Thom

chriss

  • Veteran
  • ***
  • Posts: 140
    • View Profile
Re: NVidia VDPAU API
« Reply #2 on: November 16, 2008, 11:24:13 am »
If I remember the announcements of this stuff correctly, nvidia provided a patch for MPlayer to support this extensions. However, nvidia considered the patch to be beta... Probably it is best to just wait for the single media player projects to support the new driver and integrate their new versions into LMCE

just my 2c,
Chriss

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4443
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: NVidia VDPAU API
« Reply #3 on: November 16, 2008, 01:15:48 pm »
Is support for nVidia VDPAU API scheduled for the next release of linuxMCE core functionality or is this up to the individual media players (v4l, totem,...)
http://www.nvidia.com/object/linux_display_ia32_180.06.html

Well as Thom says this has only just been announced... so you'll need to be a little more patient ;-)

Of course there was also a similar announcement from AMD/ATI too ; http://www.phoronix.com/scan.php?page=article&item=amd_xvmc_xvba&num=1

Clearly both of these developments are great news and both companies should be applauded for getting this capability into their Linux drivers (even if a little late!).

All the best

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

jerunamuck

  • Making baby steps
  • Posts: 2
    • View Profile
Re: NVidia VDPAU API
« Reply #4 on: November 17, 2008, 02:13:24 pm »
thanks guys.  Not this release, probably next.

sorry for the blind side, CFH asked me and I didn't know where in the pipe this was.
chriss, thanks for the tip on the patch, i"ll look for that.

cancerkazoo

  • Making baby steps
  • Posts: 2
    • View Profile
Re: NVidia VDPAU API
« Reply #5 on: November 25, 2008, 01:53:32 am »
Is there a program like envyng that can detect ATI/Nvidia cards and then automatically download the correct drivers while in setup? maybe in a LinuxMCE repository?

so even if they cannot be included we could point to a source with the new drivers when they are ready.

chrisbirkinshaw

  • Guru
  • ****
  • Posts: 431
    • View Profile
Re: NVidia VDPAU API
« Reply #6 on: December 20, 2008, 03:00:58 pm »

Of course there was also a similar announcement from AMD/ATI too ; http://www.phoronix.com/scan.php?page=article&item=amd_xvmc_xvba&num=1


Looks like this will be supported in the EEE BOX.

http://www.mythtv.org/wiki/index.php/VDPAU

valent

  • Guru
  • ****
  • Posts: 380
    • View Profile
    • /kernel_reloaded/
Re: NVidia VDPAU API
« Reply #7 on: March 10, 2009, 09:07:04 am »
From what I have read it is trivial to enable VDPAU in MythTV and mplayer. MythTV supports VDPAU only thing needed during the compile is --use-vdpau option.

MPlayer needs to be patched and of you go :)

I don't see why it wouldn't go in LinuxMCE ASAP because it gives s real benefit to users of Nvidia cards that support VDPAU. Is there a way I can help this gets implemented? I'm not a developer but if somebody gives me some tasks I can handle I would like to help.
LinuxMCE - If it was easy, everybody would be doing it!!
My setup - http://wiki.linuxmce.org/index.php/User:Valent