Author Topic: 7.10 Install Asrock 775Twins-HDTV with OnBoard NIC - slow to restart NIC  (Read 736 times)

daniel.welch

  • Newbie
  • *
  • Posts: 12
    • View Profile
775Twins-HDTV One of these: http://www.asrock.com/mb/overview.asp?Model=775Twins-HDTV&s=775

Anyway during the install after several minutes going from the CD It is scrolling through packages and then comes the curnch point.

It restarts networking.
LAN     - Realtek PHY RTL8201CL
- Speed: 10/100 Ethernet
- Supports Wake-On-LAN

Ok so here i am thinking - holy - its restarted the network, then continued installing before the lan is active?
I decided to check this when just installing kubuntu 7.10
I restarted the networking
/etc/init.d/networking restart

it took ages - but actually came up clean and the lan was available.

So, I hacked the /etc/init.d/networking script by placing a sleep 5 in there, and it works ok.

I then installed MCE for the second go, and it seemed to work, but looks like it might have lost a few packages on the way.

Can someone confirm something:

a) the script does restart networking and if so, that before proceeding, it confirms the network is available again?
b) Any suggestions, since my 5 second delay is ok for kubuntu, but not effective enough for the mceinstall script

Dont ask for logs, I have myth on their currently - cos I am testing, but would like to have MCE, but this is a showstopper as the install breaks  :'(

The part that chokes is something about "MySQL not being installed"

Is it possible to somehow make it pause (for longer) when doing the install script as soon as it does the network restart
What do i need to hack

PS: Ignore the bit about the video - I have a nvidia 6800GT installed.





daniel.welch

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: 7.10 Install Asrock 775Twins-HDTV with OnBoard NIC - slow to restart NIC
« Reply #1 on: December 03, 2008, 04:00:38 pm »
Do any of you developer guys have an idea on how I can slow down the network restart? or resume after a crash of the install

Is there a way to resume the install from where something broke?/choked is there a more manual alternative to clicking on the installer - Im guessing there is, but if someone has gone through something like this I would be grateful....