Author Topic: USB-UIRT randomly stops working  (Read 643 times)

lmwashere

  • Veteran
  • ***
  • Posts: 79
    • View Profile
USB-UIRT randomly stops working
« on: October 03, 2009, 03:12:05 am »
I am having an issue with my USB-UIRT where it just randomly stops working. Sometimes a reboot or reload will fix it and sometimes it will not. Sometimes unplugging and then replugging it coupled with a reload of the router will fix it, and sometimes it won't. Sometimes I am just SOL until it decides that it feels like working again. If I plug it into my windows laptop, and use lrnhelper it works fine.

The really perplexing thing is that there doesn't seem to be a trigger for it to stop working, at least not that I can find.

Originally I was running 7.10 and began having the issue. I reinstalled LMCE a couple times but was unable to fix the intermittent deaths. Eventually I was able to get a good 8.10 install, however the USB-UIRT continued to flake out. During an extensive online search I found that some people were having similar issues in the MythTV forums. Most of that buzz centers around EMI from having the USB-UIRT cable routed through other cabling. To eliminate this as a possible cause I plugged the USB-UIRT into the front of my LMCE box and just laid the rest of it out in the floor. No Joy. I also unplugged the blaster cable and tried using it without that. No Joy.

Eventually I was unable to get the USB-UIRT to work at all, even when I plugged it into my laptop and used lrnhelper. I emailed Jon and he switched the unit out for me. While awaiting my shiny new transmitter's arrival I did a fresh install of LMCE 8.10. When the transmitter arrived I plugged it in and it worked perfectly..... for about a day. Then it got flaky again. I retried the steps I mentioned above but to no avail. The only clue that I have is that when I unplugged it and plugged it back in, it said that it failed to get IVTV drivers. The next time I did that though I did not get that message. It said software installed successfully. Now when I try that it just says that it re-activated the existing USB-UIRT 0038. Then it wants to re-load the router and I get the message that it failed to start.

I am going to try a fresh install with the svn scripts, but I am not holding out much hope. If anyone has any ideas of what else to do to make this thing work I would be extremely appreciative. I think I may try to pick up some ferrite for the USB-UIRT cable too and see if that helps.