Author Topic: Hangs during UPnP  (Read 939 times)

randomfeelings

  • Regular Poster
  • **
  • Posts: 22
    • View Profile
Hangs during UPnP
« on: October 15, 2008, 12:15:38 am »
My fresh installing is hanging after the line 'Restarting UPnP Media Server fuppesd'

Prior to this: Installed i386 version from DVD. Went fine, then popped DVD out and asked to reboot. Then hit the problem on first bootup.

Any ideas? Do I even need UPnP, can it be disabled I wonder?

(I expect I'll get laughed at for suggesting it might be disabled as thinking about it it's probably quite important here! Am more used to routers and switches in corporate networks!)
« Last Edit: October 15, 2008, 12:23:51 am by randomfeelings »

randomfeelings

  • Regular Poster
  • **
  • Posts: 22
    • View Profile
Re: Hangs during UPnP
« Reply #1 on: October 15, 2008, 12:39:28 am »
Hmmm, seem to have solved it by disconnecting the bluetooth adapter (Belkin)... thought this was compatible having seen some other posts... perhaps I'm doing something wrong, or should have left that bit until later?

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Hangs during UPnP
« Reply #2 on: October 15, 2008, 06:18:55 am »
randomfeelings - the upnp message is normal, you just don't normally see if for very long as X is supposed to be starting at that point.

Don't know if the bluetooth adaptor really had anything to do with it ... it sounds like X couldn't start. Often when this happens you see the screen periodically blank and come back, each time X tries.

If it is starting now, then perhaps you are fine and can re-add the bluetooth adaptor safely. But if this happens again, you should carefully read through the /var/log/Xorg.0.log file as this will document where X is failing...

randomfeelings

  • Regular Poster
  • **
  • Posts: 22
    • View Profile
Re: Hangs during UPnP
« Reply #3 on: October 15, 2008, 11:01:47 am »
Thanks for this Colin.

Also, now I notice that the wizard has started but isn't playing properly - cannot see 'her', and yet I can see the soft keyboard, and hear bits of what she's saying. The mouse is also moving unevenly. Should I assume that my graphics card is not up to the task?

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Hangs during UPnP
« Reply #4 on: October 15, 2008, 03:32:08 pm »
I have no idea what your graphics card it - personally I would reinstall from scratch from the DVD (i386), choose UI2 with overlay only, and follow the wiki on Display Drivers to update your drivers to the latest version  before going through the AV wizard

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Hangs during UPnP
« Reply #5 on: October 15, 2008, 04:50:20 pm »
I'd say stick to UI1 untill you have verified that the Video tab in the launch manager says that "nvidia" (or "fglrx" depending on your hardware) is the driver.
"Change is inevitable. Progress is optional."
-- Anonymous


randomfeelings

  • Regular Poster
  • **
  • Posts: 22
    • View Profile
Re: Hangs during UPnP
« Reply #6 on: October 15, 2008, 08:13:52 pm »
Just as a note on the bluetooth causing the hang - found this fix

echo "Belkin F8T012 Compatibility Blacklist" >> /etc/modprobe.d/blacklist
echo "blacklist pegasus" >> /etc/modprobe.d/blacklist