Author Topic: Permanent settings for alsamixer -alsactl store is not enough ?  (Read 1428 times)

bulek

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 883
  • Living with LMCE
    • View Profile
Permanent settings for alsamixer -alsactl store is not enough ?
« on: October 07, 2008, 02:02:00 pm »
Hi,

I'd like to do settings in alsamixer that will be permanent. I try to set them up with alsamixer and then do alsactl store, but this obviously isn't enough,

cause volume of other channels are muted on every reboot... (I'd love to get same sound on other outputs too - to send it to touchscreen internal speakers beside sending output to amplifier)...

Is anything else needed to be done to make volume on certain channels permanent ?

Regards,

Bulek.
Thanks in advance,

regards,

Bulek.

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Permanent settings for alsamixer -alsactl store is not enough ?
« Reply #1 on: October 07, 2008, 03:10:31 pm »
Bulek - I have no idea what I'm talking about here, but I just read the alsactl man page entry. It occurs to me that the store command writes out the config to a file. But nothing in the man page implies that this config is then picked up each time on reboot automatically....

It maybe inconvenient, but perhaps the point is that you need to create a script to run on reboot that uses the alsactl restore command to load that file back in?

chrisbirkinshaw

  • Guru
  • ****
  • Posts: 431
    • View Profile
Re: Permanent settings for alsamixer -alsactl store is not enough ?
« Reply #2 on: October 12, 2008, 02:07:33 pm »
Normally the alsa init script should do this. Maybe it's been changed for linuxmce.

What I see is that certain settings are reloaded and some are not. For example I set my PCM to 93% and digital output to ADAT. When I reboot the output mode is ADAT but the PCM is 80%. Perhaps after alsactl restore is run amixer is called to set the PCM to a default value.

OT: Volume control doesn't work with my card from the LMCE GUI. Maybe it is looking for a control called Master? Can you tell me what yours is called?

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Permanent settings for alsamixer -alsactl store is not enough ?
« Reply #3 on: October 12, 2008, 10:11:01 pm »
Chris - if you are using PCM, presumably an SPDIF connector then that is correct, there is no volume control over that transport you have to control volume through your amp.

chrisbirkinshaw

  • Guru
  • ****
  • Posts: 431
    • View Profile
Re: Permanent settings for alsamixer -alsactl store is not enough ?
« Reply #4 on: October 13, 2008, 11:50:47 am »
Actually, on my soundcard all outputs are controlled by one control - PCM. (Echo Audio Gina 3G)

And in my kitchen I use the speaker built into my MD, for which the control is called "Master Mono"...