Author Topic: Storage device (Terrastation) freezing/locked up  (Read 648 times)

jeangot

  • Guru
  • ****
  • Posts: 233
    • View Profile
Storage device (Terrastation) freezing/locked up
« on: January 07, 2009, 03:57:01 am »
Hello,

I have a Buffalo Terrastation mounted in LMCE, and accessible at /mnt/devices/67 on the core.

Since a few weeks, after a couple of days LMCE can no longer access any files on that share

cd /mnt/devices/67
done on the core will just hang for hours (until I press control c)

Yet my Terrastation is still accessible from windows computers in the same network, so it is not frozen.
Reboot of terrastation alone does not help, I have to reboot the terrastation and then reboot my core for it to work again, and it only works for a few days again, yet it was working for months without a problem.

So I am wondering how these shares are mounted and unmounted in LMCE, as I can find nothing in fstab, and even the output of "mount" does not reveal anything usefull.

Once I know how to unmount and remount this share without rebooting LMCE, I could hopefully troubleshoot some more, maybe find pertinent logs and search for similar issues in Google.

I tried to disable the share in the pluto-admin, then reload, then enable, then reload, but that did not temporarily fix the issue.

Thank you!

Jean

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5505
  • DOES work for LinuxMCE.
    • View Profile
Re: Storage device (Terrastation) freezing/locked up
« Reply #1 on: January 07, 2009, 04:14:11 am »
Shares in LMCE are managed by autofs, with what is probably the most intricate automounter script in existance.

Devices are mounted when needed, and after 15 seconds of inactivity, are unmounted.

Look in /etc/auto.plutoStorageDevices to start.

-Thom

jeangot

  • Guru
  • ****
  • Posts: 233
    • View Profile
Re: Storage device (Terrastation) freezing/locked up
« Reply #2 on: January 07, 2009, 05:36:33 am »
Thom,

thanks, I appreciate the pointers.

Jean