Author Topic: Should UpdateMedia use up lots of CPU?  (Read 520 times)

indulis

  • Veteran
  • ***
  • Posts: 147
    • View Profile
Should UpdateMedia use up lots of CPU?
« on: October 02, 2008, 12:28:16 pm »
This seems to be running a LOT on my system.

I think it may be because I defined a RAID-1 partition (md4) by booting into standalone Linux and manually creating it.  Then booting LinuxMCE it had problems mounting it (I put a wrong option into /etc/fstab).  I am mounting the partition over /home.  It is JFS.

Think LinuxMCE deteced the partition at first boot and assigned it a device number (before I ficed the mount problem).  Now it is mounted properly as /home.

Could it be because LMCE is updating files in /home, which then trigger a rescan because it is also a disk device?

I am away from home right now so can't give more details.

bulek

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 884
  • Living with LMCE
    • View Profile
Re: Should UpdateMedia use up lots of CPU?
« Reply #1 on: October 02, 2008, 01:11:01 pm »
This seems to be running a LOT on my system.

I think it may be because I defined a RAID-1 partition (md4) by booting into standalone Linux and manually creating it.  Then booting LinuxMCE it had problems mounting it (I put a wrong option into /etc/fstab).  I am mounting the partition over /home.  It is JFS.

Think LinuxMCE deteced the partition at first boot and assigned it a device number (before I ficed the mount problem).  Now it is mounted properly as /home.

Could it be because LMCE is updating files in /home, which then trigger a rescan because it is also a disk device?

I am away from home right now so can't give more details.
I spot something similar, altought didn't have time to give it some attention...

UpdateMedia takes high percentage of CPU from time to time - although I'm not making any substantial changes in media files...

Regards,

Bulek.
Thanks in advance,

regards,

Bulek.