Author Topic: shuttle k45 intel  (Read 832 times)

chuckfox

  • Newbie
  • *
  • Posts: 5
    • View Profile
shuttle k45 intel
« on: September 30, 2008, 06:37:10 am »
Anyone had any luck getting this box to pxe boot with the on board lan?  I've tried the steps listed in the WIKI, but can't seem to get it to work.

chuckfox

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: shuttle k45 intel
« Reply #1 on: October 12, 2008, 07:05:37 am »
No takers?

This box has Marvell 88E8056 for it's onboard lan.  Using the instructions for 'Other Network cards' listed on the WIKI site, I have gotten as far as my hybid recognizing the card and building the diskless image for initial boot.  At this point after quick re-load of the router, the media director will kick out a kernel panic error, not recognizing eth0.  I also noticed that on initial boot, it was recognized as having a amd architecture.  I have a intel celron running on the machine and it's definently not amd.  I have also tried to change architecture to i386(the same as my hybrid) using the web admin panel in MCE.  No joy, the difference of architecture is not letting me chroot to the /usr/pluto/diskless/<media director nuber> to create a new initial ram disk.   Any way around this?  I'm a newb to linux but can follow directions.  I'm about to slap a hard drive in the box for my wife to do 'office stuff'.                                           

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: shuttle k45 intel
« Reply #2 on: October 12, 2008, 11:51:48 pm »
Strange! Have you tried telling the core to rebuild the image from the web admin? Certainly, if it thinks it is AMD then it obviously will not work!