Author Topic: "nv" driver not working correctly...  (Read 1757 times)

billlava

  • Newbie
  • *
  • Posts: 6
    • View Profile
"nv" driver not working correctly...
« on: September 27, 2008, 08:29:24 pm »
I thought I had the nvidia drivers correctly installed for my Nvidia Geforce 8800  GT video card, but LinuxMCE keeps telling me that the driver is called "nv" instead of nvidia.  Does anyone know what this means?  How can I get it to work properly with the right drivers?

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4426
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: "nv" driver not working correctly...
« Reply #1 on: September 27, 2008, 09:52:51 pm »
I thought I had the nvidia drivers correctly installed for my Nvidia Geforce 8800  GT video card, but LinuxMCE keeps telling me that the driver is called "nv" instead of nvidia.  Does anyone know what this means?  How can I get it to work properly with the right drivers?

Your 8800 is not getting detected correctly. Look here on the Wiki http://wiki.linuxmce.org/index.php/Display_Drivers#NVidia_Chipsets

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

billlava

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: "nv" driver not working correctly...
« Reply #2 on: September 28, 2008, 11:21:12 pm »
Thanks, I've tried following the instructions there.  I installed the driver (which I think I had previously done) according to the instructions successfully.  Then I restarted into the A/V wizard and tried to up the level of my UI.  Still, the MCE settings said that my driver was "nv" and that it could not generate the UI2 interfaces.  I exited to a terminal and manually edited xorg.conf to say "nvidia" instead of "nv." But then when I tried to go into the A/V wizard it wouldn't even start.  So now things are back to the way they were, and I am still using the lowest quality interface even though I have a decent graphics card.

One thing to note though - This machine is the only one in my "system."  That is to say it is a Media Director too.  I noticed something on that page about having to "upgrade the kernel" on a media director.  Is this what I will have to do?  If so, could someone please provide a little more direction for a novice like me?

rodercot

  • Guest
Re: "nv" driver not working correctly...
« Reply #3 on: September 29, 2008, 01:50:34 pm »
billava,

 Well if it is still saying nv then the driver is not installed correctly. When you follow the instructions and the display drivers are you allowing the Nvidia driver to overwrite the existing xorg.conf file as you should.

 The important part of installing those drivers is the telinit 1 command. Also What architecture are you running as the 32 bit version will not install on a 64 and vice versa.

 How are you connected to you display device. DVI/HDMI, VGA, CMPT etc...

 If you are using the TV-outs of your Video card most of the xorg.conf file is disabled anyhow.

 If you go to the Nvidia site and search for the Linux 32 or 64 bit driver then have a glance at the readme file for that driver there is a lot of info in there to help you with the install of the driver.

 If you do have a corrupt driver a new installation will detect it and overwrite it with your next install.

 It makes no difference if you are running a hybrid the method is the same on that machine.

 On the core/hybrid - boot to a command line and login (ctl-alt-f2)

 then issue a sudo su or sudo -s or what ever root command you are use to using

 cd /home or cd /home/downloads or whatever directory you have setup for putting downloaded files into

 dwnld the latest nvidia driver - as per the wiki - Just change the version numbers I think current is 173.14.12 but check that out at the Nvidia site to be sure.

 Then issue your telinit 1 - let it run through then re login to Linuxmce and issue sudo again (change to your download directory (this may or may not be required)

 Then install your driver using SH NVIDIA etc.. as per the wiki.

 follow the on-screen prompts when it says the driver is installed it will end up back at a command prompt, type reboot and it should reboot and load the orbiter and then you can choose change video settings from the UI1 advanced menu and it will reboot the system and launch the a/v wizard and let you make your changes to UI2 (either mode)

 Just follow the wiki to the T and you should be fine.

 rgds,

 Dave

 

 

Crumble

  • Veteran
  • ***
  • Posts: 146
    • View Profile
Re: "nv" driver not working correctly...
« Reply #4 on: September 29, 2008, 03:38:33 pm »
just thought i should post that i had problems with telinit 1 and the nvidia driver compiling a new kernel for me.  I used CTRL+ALT+BKSPACE to killx and had no problems that way.  GL.


Crumble

rodercot

  • Guest
Re: "nv" driver not working correctly...
« Reply #5 on: September 29, 2008, 04:46:09 pm »
just thought i should post that i had problems with telinit 1 and the nvidia driver compiling a new kernel for me.  I used CTRL+ALT+BKSPACE to killx and had no problems that way.  GL.


Crumble

 Crumble,

 IT complains EVERY time you try and install that is why it searches for one and then installs with your existing.  It states this in the wiki display driver section.

 I have installed the driver this exact way more than 30 times and have never had a single issue.

 Dave

indulis

  • Veteran
  • ***
  • Posts: 147
    • View Profile
Re: "nv" driver not working correctly...
« Reply #6 on: October 03, 2008, 04:05:56 am »
Alternative approach to make sure you can do the nvidia install

  • Wait until the "Loading Grub" message appears during boot.  Press ESC in the 2 seconds allowed before it boots.
  • Cursor down to 1st line
  • press "e" key to edit
  • Select the line that starts with "kernel"
  • Press e to edit.  You should now be at the end of the line
  • type "single" (without the quotes).
  • press enter
  • press b to boot

You have now booted into single user mode, no Pluto stuff running, no X.  Guaranteed!  You can now do all of the nvidia driver install stuff.

Before you do this, do your download of the latest nvidia drivers because you don't have a web browser in single user.  You should also have printed out or written down the steps you need to take.

When I get home I am going to find the shell script that keeps rewriting the xorg.conf AND DISABLE THIS FUNCTION.
« Last Edit: October 03, 2008, 04:09:47 am by indulis »

rodercot

  • Guest
Re: "nv" driver not working correctly...
« Reply #7 on: October 03, 2008, 10:26:52 am »
indilis,

 Will the Nvidia install see the existing xorg file with this method and overwrite it. I CHOOSE to overwrite the default xorg with the install of the driver as it then sets up 95% of the time the drivers new xorg file with the proper display and video card in the system. 

 Dave

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: "nv" driver not working correctly...
« Reply #8 on: October 03, 2008, 04:53:31 pm »
Alternative approach to make sure you can do the nvidia install

  • Wait until the "Loading Grub" message appears during boot.  Press ESC in the 2 seconds allowed before it boots.
  • Cursor down to 1st line
  • press "e" key to edit
  • Select the line that starts with "kernel"
  • Press e to edit.  You should now be at the end of the line
  • type "single" (without the quotes).
  • press enter
  • press b to boot

You have now booted into single user mode, no Pluto stuff running, no X.  Guaranteed!  You can now do all of the nvidia driver install stuff.

Before you do this, do your download of the latest nvidia drivers because you don't have a web browser in single user.  You should also have printed out or written down the steps you need to take.

When I get home I am going to find the shell script that keeps rewriting the xorg.conf AND DISABLE THIS FUNCTION.

Either that, or you can select the target with "(recovery mode)" in the title, which does just about the exact same thing, as described here: http://wiki.linuxmce.org/index.php/Display_Drivers#Installation.

And, ummm... we already found that script: http://wiki.linuxmce.org/index.php/Display_Drivers#LinuxMCE_keeps_reconfiguring_my_display_settings.
"Change is inevitable. Progress is optional."
-- Anonymous