Author Topic: D945GCLF2 S-video port  (Read 7051 times)

amirul

  • Regular Poster
  • **
  • Posts: 27
    • View Profile
D945GCLF2 S-video port
« on: September 23, 2008, 04:21:09 pm »
Just discovered the Dual-core Atom board has S-Video. Is it usable? Maybe I'll plug it into a TV and see...

zaun

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: D945GCLF2 S-video port
« Reply #1 on: November 16, 2008, 06:14:49 pm »
hi

i am trying to run my mce on this board with a tv attached via s-video.
i have no problems running a console, but as soon as x is started the screen stays black.

when i boot puppy-linux, sidux or a bart-pe windows everything is fine

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: D945GCLF2 S-video port
« Reply #2 on: November 16, 2008, 06:22:54 pm »
hi

i am trying to run my mce on this board with a tv attached via s-video.
i have no problems running a console, but as soon as x is started the screen stays black.

when i boot puppy-linux, sidux or a bart-pe windows everything is fine


Install the latest driver if needed and edit xorg.conf: http://wiki.linuxmce.org/index.php/Display_Drivers
"Change is inevitable. Progress is optional."
-- Anonymous


zaun

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: D945GCLF2 S-video port
« Reply #3 on: November 16, 2008, 11:01:28 pm »
hi,

i downloaded http://packages.ubuntu.com/gutsy/i386/xserver-xorg-video-intel/download and installed it with dpkg -i.
no changes after reboot :(

selected driver in xorg.conf is "intel".

zaun

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: D945GCLF2 S-video port
« Reply #4 on: November 17, 2008, 10:20:59 pm »
i changed the driver setting from 'intel' to 'i810' and now xserver works fine. at least as long as the linuxmce-menu isnt loaded. kde-desktop works, but mce-menu, mce-konfiguration-wizard and av-wizard are not working properly. all i get is flickering. changing resolution and stuff like that didnt help.

so far...

niz23

  • Guru
  • ****
  • Posts: 361
    • View Profile
Re: D945GCLF2 S-video port
« Reply #5 on: November 17, 2008, 11:06:25 pm »
zaun.
i changed the driver setting from 'intel' to 'i810' and now xserver works fine. at least as long as the linuxmce-menu isnt loaded. kde-desktop works, but mce-menu, mce-konfiguration-wizard and av-wizard are not working properly. all i get is flickering. changing resolution and stuff like that didnt help.

so far...

Normal Intel driver should support this card. Its the same one used on other Atom boards too.
I have a EEEbox which work fine with the driver shipped in 0710.

To use s-video you probably need set some config parameters in xorg. Have no clue which ones. Its a guess.
what happen if you choose s-video in AVWizard?
What do xorg log files say?

/niz23

zaun

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: D945GCLF2 S-video port
« Reply #6 on: November 18, 2008, 11:07:28 pm »
pressing 5 (or any other number ^^) has little effect. av-wizards restarts in new resolution and the picture is flickering as before (u can guess what should be on the screen).
i tried to make a clean xorg.conf by deleting it and run "dpkg-reconfigure xserver-xorg". but this didnt change a thing.

my guess is that the mce-menu/wizard uses a feature, that the normal kde-desktop doesnt use. any tip? =)

niz23

  • Guru
  • ****
  • Posts: 361
    • View Profile
Re: D945GCLF2 S-video port
« Reply #7 on: November 19, 2008, 08:01:39 am »
zaun.
pressing 5 (or any other number ^^) has little effect. av-wizards restarts in new resolution and the picture is flickering as before (u can guess what should be on the screen).
i tried to make a clean xorg.conf by deleting it and run "dpkg-reconfigure xserver-xorg". but this didnt change a thing.

my guess is that the mce-menu/wizard uses a feature, that the normal kde-desktop doesnt use. any tip? =)

What do your xorg log files tell...
Also. Have you tried with a normal vga monitor? does that work?
It might be a refreshrate/resolution problem that the unit you have attached through s-video cannot handle.

/niz23

mikeofaustin

  • Regular Poster
  • **
  • Posts: 20
    • View Profile
Re: D945GCLF2 S-video port
« Reply #8 on: November 24, 2008, 04:50:25 am »
I logged in just to reply to this thread. 

... I've been trying to get this same board working with the x desktop... just plane work.  THEN install myth.  But I can't even get to the desktop.

I've started another thread under linuxquestions.org under hardware.   I believe the problem resides in the fact that the ch7021 (tv out chip) and the 945G (graphics chip) are not setup properly to communicate with each other. I've been working on this solid for 2 days now. 
The VGA out works just fine.  It's the s-video that's broken.  When the linux drivers take over, the s-video is broken.  Everything up until that point, works great.

Here's the thread.

http://www.linuxquestions.org/questions/linux-hardware-18/945g-s-video-out.-x-vsync-refresh-rate-error-let-me-buy-you-lunch-685454/

mikeofaustin

  • Regular Poster
  • **
  • Posts: 20
    • View Profile
Re: D945GCLF2 S-video port
« Reply #9 on: November 24, 2008, 09:17:15 pm »
I've verified that older i810 drivers will cause the x window desktop to start, but only in vesa mode (?), as there is no hardware acceleration. It also loses sync when trying to play video of anykind.  Upon installing the i915, everthing is broken. Can't even get into X windows.   This can be easily produced by using an 8.04 or 8.10 live CD. It boots right up until X windows starts, then fails.   

I've send a support request, they send me a list of cookie cutter responses, and I then chose the 'escalate my issue' option.  It's now sitting with intel.  Hopefully, they'll fix it, or remove the 'works with native drivers' off of there product page for this motherboard.

  I hope this is fixed, because I was going to use this as my media center, next to my TV.  So, in my mind, and I say this while stamping my foot on the floor, "This product is not compatible with linux".  Freakin period. >:( >:( >:( >:( >:( >:( >:(

-M
« Last Edit: November 24, 2008, 09:19:50 pm by mikeofaustin »