Author Topic: how to make raid1 for /home directory ?  (Read 947 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
how to make raid1 for /home directory ?
« on: February 09, 2006, 11:16:32 pm »
Hi,

I cannot setup Raid1 as supplement for few more important directories in /home.

I followed this procedure :
Code: newbielink:javascript:void(0); [nonactive]
mdadm --zero-superblock /dev/sda1
mdadm --zero-superblock /dev/sdb1

mdadm --create
/dev/md0 --auto --verbose  --chunk=4 --level=1 --raid-devices=2 /dev/sda1
/dev/sdb1

mkfs.ext3 /dev/md0

echo "DEVICES /dev/sda1 /dev/sdb1" > /etc/mdadm/mdadm.conf
mdadm --brief --detail --verbose /dev/md0 >> /etc/mdadm/mdadm.conf



then added this entry into fstab :
Code: newbielink:javascript:void(0); [nonactive]
/dev/md0       /raid1           ext3    defaults,user_xattr 0       2



then added two kernel modules to load : raid1, sd_mod

but after reboot - it stops in console on fsck saying :
fsck.ext3: Invalid argument while trying to open /dev/md0
Code: newbielink:javascript:void(0); [nonactive]

/dev/md0:
The superblock could not be read or does not descibe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt. and you might try running e2fsck with an alternate
superblock:
 e2fsck -b 8193 <device>


Also when I try : mount /raid1 it gets same error.
But if I do this :
 
Code: newbielink:javascript:void(0); [nonactive]
mdadm --create
/dev/md0 --auto --verbose  --chunk=4 --level=1 --raid-devices=2 /dev/sda1
/dev/sdb1


then mount /raid1 works.... I just cannot get raid1 to start by it self...

any advice ?

Thanks in advance,

regards,

Rob.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
how to make raid1 for /home directory ?
« Reply #1 on: March 01, 2006, 11:27:32 am »
You are getting that error because the raid devices where not enabled at boot. I fixed that in our svn and the problem should go away as soon as you update your sysv-rc package.