Author Topic: Adding a PC as a device like masking as an A/V device  (Read 493 times)

rodercot

  • Guest
Adding a PC as a device like masking as an A/V device
« on: September 02, 2008, 03:36:37 pm »
 
 Et All,

 Well I got my 8.04 machine up running and configured. it seems to be working great other than scrolloing issues (known Nvidia driver problems)

 Anyhow I have installed some software on this machine to playback HD files at full res from the server that I cannot do in LMCE currently and I want to add the machine to the living room system as a A/V device basically. It is controlled via Lirc of course and uses the MCE Remote and its own transceiver.

 There is only a couple things I am wondering - when I put this machine on the internal lan, the core will detect it of course and ask if I want to use it and if I say no it will stick it unknown devices. If I set it up via an A/V device Like a DVD player for instance - how do I handle the ip address etc and do I tell the core to use it when it asks.

 rgds,

 Dave

rodercot

  • Guest
Re: Adding a PC as a device like masking as an A/V device
« Reply #1 on: September 03, 2008, 12:45:00 pm »

 So I got this working. Initially I set it up as a Computer - AV device of which there are Device Template but no matter what I did I could not get a scenario to show on the UI for it. I had the input set to DVD only which is the normal cause I assume.

 Anyhow, I booted the machine and let LMCE detect it then I chose to ignore it all the time. Then I added a new device to the system - Silverstone - LC16M - DVD player. Then I learned in the codes for the MCE remote for this device. controlled it via USBUirt embedded transmit via IR of course.

 Renamed the Media Sceanrio - which I have done with all my devices on the UI to get rid of the clutter of the two lines of test in the UI - Media section.

 Setup my pwr on and off for XBMC via IRexec script for start and kill on the new device. So now I just click on xbmcHD on the media - UI menu and LMCE switches to the new pc on the designated pipes and voila I have FS 1080p .mkv and .ts HD playback.

 This is a temp fix for HD playback for me until I can get those files playing properly within LMCE.

 rgds,

 Dave