Author Topic: Wiki- can't create thumbnails today  (Read 3588 times)


  • Veteran
  • ***
  • Posts: 147
    • View Profile
Wiki- can't create thumbnails today
« on: September 27, 2008, 12:29:11 pm »

Couldn't find a bug report or feedback link in the Wiki.  I uploaded an image of a computer case (am reorganising the recommended hardware into main pages and templates for the common sections, so that we don't have 3 different spots with the same recommendations for a product).  Now when I try to embed an image thumbnail I get this in the image box
/usr/bin/convert: No such file or directory

Suspect imagemagick has not been reinstalled, or has not been linked to /usr/bin which is where mediawiki expects to find it

The wiki page is Template:Mid-size HT style cases

The image it is trying to convert is definiteyl there, cos if I remove the |thumb| section from the image link it comes up in glorious widescreen technicolor.

« Last Edit: September 27, 2008, 12:42:17 pm by indulis »


  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2428
    • View Profile
    • ago control
Re: Wiki- can't create thumbnails today
« Reply #1 on: September 27, 2008, 02:49:35 pm »
fixed. convert is now installed. We had to move the wiki to another server.

Btw, we had to revert to the latest backup, unfortunately your changes from yesterday are gone. I'm very sorry for that.

best regards,
rock your home - home automation


  • Veteran
  • ***
  • Posts: 147
    • View Profile
Re: Wiki- can't create thumbnails today
« Reply #2 on: October 02, 2008, 05:29:19 pm »
Oh well- it was an hour or two fixing up the Newbie Packs so that they all used a single template for recommended case and DVD sections, and updating the case sections and video card sections (at least the video section stayed but my nice comparison table vanished).  At least I saved the recommended case edits outside of the Wiki so can reapply them.

Anyway- has anyone looked at how people report problems with the Wiki?  It'd be nice to have a pointer to either a forum, or an email address, or to use Matis or whatever.  One of my pet hates is a web site that doesn't allow you to report a problem easily!
That and cold morgue-like blue fluoro lights.  And people who throw butts on the ground.



  • Guru
  • ****
  • Posts: 187
    • View Profile
Wiki- can't upload images today
« Reply #3 on: October 23, 2008, 05:17:18 pm »
I'm wondering if this issue is related to the wiki move.

I've been trying to upload an updated image of my system diagram to the wiki.  That's this file here:

It is a .png that is 30 KB.  I get this error:

"The file you uploaded seems to be empty. This might be due to a typo in the file name. Please check whether you really want to upload this file."

I can view the file just fine in windows, so I suspect that the error is not in fact that the file is "empty".  I also tried uploading a random 30 KB .jpg that I downloaded from the internet just as a test, and I received the same error.

The wikimedia Uploading_Files topic has a Q&A on this error here:

Here is what it says:

Q: Why do I get the message: "The file you uploaded seems to be empty. This might be due to a typo in the file name. Please check whether you really want to upload this file."

    * One reason for this is that something below mediawiki such as PHP or the web server is limiting the size of http requests. See the next question.
    * Try checking the ignore any warnings at the upload file page.
    * Check also if the php config upload_tmp_dir is set.
    * Check that the /tmp dir is not full (happened to me!)

I tried checking the "ignore any warnings" box as suggested with the same result.

It appears that there haven't been any file uploads since September 22nd.  See this page:

Any suggestions would be appreciated.  Maybe someone else could confirm whether they can upload images to the wiki right now.