Author Topic: mythfilldatabase problem (ulimit)  (Read 873 times)

Esperanto

  • Guru
  • ****
  • Posts: 210
    • View Profile
mythfilldatabase problem (ulimit)
« on: August 30, 2008, 12:07:43 pm »
I have a problem getting the myth database filled automaticly (running it manually seemed to work fine)

I am using the dutch grabber located at http://code.google.com/p/tvgrabnlpy/ (tv_grab_nl_py-r78.py)

In the /var/log/mythtv/mythfilldatabase.log I get the following error:
/usr/pluto/bin/Config_Ops.sh: line 207: ulimit: open files: cannot modify limit: Operation not permitted

Surrounded by the nottion that  it will wait 120 seconds:

We do not want to start until it has been
2 minutes since the MythTV channel download.
Waiting 120 seconds before starting..
We do not want to start until it has been
2 minutes since the MythTV channel download.
/usr/pluto/bin/MythTvDailyFillDB.sh start Fri Aug 29 16:06:56 CEST 2008
/usr/pluto/bin/Config_Ops.sh: line 207: ulimit: open files: cannot modify limit: Operation not permitted
Waiting 120 seconds before starting..
We do not want to start until it has been
2 minutes since the MythTV channel download.
Waiting 120 seconds before starting..
We do not want to start until it has been
2 minutes since the MythTV channel download.

Anyone knows how to fix this?

thx!

Esperanto

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: mythfilldatabase problem (ulimit)
« Reply #1 on: October 01, 2008, 07:38:18 pm »
I still have not got this working properly. It seems that there are multiple causes. First there is an eternal loop in the script /usr/pluto/bin/Config_Ops.sh in the function WaitUntilMythTvInitialRunXMinutesOld. So I commented that function in /usr/pluto/bin/MythTvDailyFillDB.sh (line 18):

# WaitUntilMythTvInitialRunXMinutesOld 2

I also had to do a:

chmod -R 777 /root/.xmltv/

(because mythtv keeps using the configs in the root dir)

it looks then now at least it looks like tthe database gets filled.

indulis

  • Veteran
  • ***
  • Posts: 147
    • View Profile
Re: mythfilldatabase problem (ulimit)
« Reply #2 on: January 11, 2009, 05:51:27 am »
You can also do

Code: [Select]
date +%s > /tmp/MythTvInitialFillDBRun
This will get you out of the endless loop.  I should submit a bug report as this code is definitely buggy in terms of checking to make sure the file exists before trying to wait 2 minutes.  It is probably OK on the 1st run as the file has actually been created during the install process, but when /tmp gets cleared out (at reboot I think) then the file vanishes and next boot you get the infinite loop.

The other issue is that the mythfilldatabase job runs as root (which you found out).  This causes problems with the "shepherd" grabber often used in Australia.  I have just set the
mythfilldatabase arguments to say
Code: [Select]
--graboptions '--version'which effectively disables the mythfilldatabase being run from inside mythtv (I hope).

You can't delete the mythfilldatabase job from the Setup menus inside Mythtv frontend because LMCE (bless its little cotton socks) will just put it back in next time the Orbiter is regened- as far as I can tell this is when it resets all of the Mythtv settings.  Too bad if you tuned some of them for your own needs (e.g. deinterlace method).
« Last Edit: January 12, 2009, 04:45:22 am by indulis »

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: mythfilldatabase problem (ulimit)
« Reply #3 on: November 25, 2009, 10:03:41 pm »
Hi,
You can also do

Code: [Select]
date +%s > /tmp/MythTvInitialFillDBRun
This will get you out of the endless loop.  I should submit a bug report as this code is definitely buggy in terms of checking to make sure the file exists before trying to wait 2 minutes.  It is probably OK on the 1st run as the file has actually been created during the install process, but when /tmp gets cleared out (at reboot I think) then the file vanishes and next boot you get the infinite loop.

This problem is still there, after each boot the file is missing.

Viking