Author Topic: Your CPU does not support long mode. Use a 32 bit distribution.  (Read 6750 times)

jimmejames

  • Guru
  • ****
  • Posts: 183
    • View Profile
I just started getting the above error when trying to boot a media director.

This is for the same setup as I've posted on before (Asus_M3A78-EM with AMD 64bit 4200+) using the 64bit DVD installation.  I was trying to get my N810 working with the above setup and ended up deleting the installation information for the 32bit computer- oops.

So, this computer had been working with this setup and then I deleted it.  For whatever reason, now when I try to PXE boot into it, I can get an ip address from the server and it begins the data transfer, but then kicks out with the above error.

I have another 64bit computer that I was able to get everything installed using....

I am unable to disable ACPI completely, it just says there are different modes that I can change it to.  It was working, now it's not, not sure why.

Any ideas?

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Your CPU does not support long mode. Use a 32 bit distribution.
« Reply #1 on: August 27, 2008, 04:23:04 pm »
...
It was working, now it's not, not sure why.
...

And here's exactly why:

...
I was trying to get my N810 working with the above setup and ended up deleting the installation information for the 32bit computer- oops.
...

You might get away with restoring the files you deleted (good luck with that) or simply reinstall.
"Change is inevitable. Progress is optional."
-- Anonymous


jimmejames

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: Your CPU does not support long mode. Use a 32 bit distribution.
« Reply #2 on: August 28, 2008, 12:52:01 am »
No, I didn't delete the "installation" files, I deleted the device from the media directors page.  My previous post was ambiguous at best, and probably just confusing.

Do you know why if all I did was delete the media director without changing any other files, that on the next restart it wouldn't announce itself to the core, get a new ip address and reinstall as a new media director instead of what it does with the 32bit long mode?


Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Your CPU does not support long mode. Use a 32 bit distribution.
« Reply #3 on: August 28, 2008, 01:07:50 pm »
In that case, try adding a MD manually form the web-admin's "Wizard | Media Directors" page, and set the "Architecture" to "i386".  Did you recreate the initial ramdisk for diskless MDs or something?
"Change is inevitable. Progress is optional."
-- Anonymous


jimmejames

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: Your CPU does not support long mode. Use a 32 bit distribution.
« Reply #4 on: August 28, 2008, 04:19:33 pm »
Thanks for the help- that would have been a good thing to try.  As it is, we're having guests over tonight and I wanted to show it off so I canned the system last night and did a full reinstall.  Pretty cool that you can go from a zeroed harddrive to having home automation in 30 minutes or so.  Afterwards, the i386 system booted and configured without a hitch.  Incidentally, I stopped by a Kaleidescape dealer the other day just to see what they had to offer.... ended up walking out feeling pretty good that to get the basic system that I'm running at home would cost somewhere on the order of $100k from Kaleidescape.  Cha-ching.

They may have one up on this project though- the guy I spoke with said that they could flush toilets using Crestron...

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Your CPU does not support long mode. Use a 32 bit distribution.
« Reply #5 on: August 28, 2008, 06:01:21 pm »
Well, with the right hardware and some configuration, lmce can flush toilets too... even without using crestron (or the price tag for that manner).  :D
"Change is inevitable. Progress is optional."
-- Anonymous


totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4463
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Your CPU does not support long mode. Use a 32 bit distribution.
« Reply #6 on: August 28, 2008, 09:19:59 pm »
Thanks for the help- that would have been a good thing to try.  As it is, we're having guests over tonight and I wanted to show it off so I canned the system last night and did a full reinstall.  Pretty cool that you can go from a zeroed harddrive to having home automation in 30 minutes or so.  Afterwards, the i386 system booted and configured without a hitch.  Incidentally, I stopped by a Kaleidescape dealer the other day just to see what they had to offer.... ended up walking out feeling pretty good that to get the basic system that I'm running at home would cost somewhere on the order of $100k from Kaleidescape.  Cha-ching.

They may have one up on this project though- the guy I spoke with said that they could flush toilets using Crestron...

Well several Crestron customers we have recently spoken with seem to want to flush their systems down the toilet! But I am sure they are worth every penny ;-)

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-7C

Contact me for Smart Home consulting advice here;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3020
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Your CPU does not support long mode. Use a 32 bit distribution.
« Reply #7 on: August 29, 2008, 12:30:52 am »
If anyone is in need of a LinuxMCE controlled toilet, a GC-100 and this http://www.gerberonline.com/Catalog.aspx?categoryID=104, should work just fine.

With some sensors, it should do it automatically, or do it based on time in the toilet.

Should be an autoscenario for rooms of type Toilet.

rgds
Oliver

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: Your CPU does not support long mode. Use a 32 bit distribution.
« Reply #8 on: August 29, 2008, 03:33:24 am »
DUDE! GOOD FIND! :)

-Thom