Author Topic: Development environment setup  (Read 1115 times)

Domodude

  • Guest
Development environment setup
« on: August 24, 2008, 11:34:28 am »
Hi all,
I followed the wiki http://wiki.linuxmce.org/index.php/Setting_Up_A_Development_Environment to compile from source. I used to have some trouble compiling but I think it's going well now.
There is one line in the wiki that is a bit confusing:
cp /usr/pluto/lib/* /src/lib/ -R
Does this mean that I should make a directory /src/lib and do the copy, or should this line really read:
cp /usr/pluto/lib/* src/lib/ -R
so that the /usr/pluto/lib stuff ends up in the charon-media tree?
Cheers,
Mark

niz23

  • Guru
  • ****
  • Posts: 361
    • View Profile
Re: Development environment setup
« Reply #1 on: August 24, 2008, 01:03:40 pm »
Domodude,
Hi all,
I followed the wiki http://wiki.linuxmce.org/index.php/Setting_Up_A_Development_Environment to compile from source. I used to have some trouble compiling but I think it's going well now.
There is one line in the wiki that is a bit confusing:
cp /usr/pluto/lib/* /src/lib/ -R
Does this mean that I should make a directory /src/lib and do the copy, or should this line really read:
cp /usr/pluto/lib/* src/lib/ -R
so that the /usr/pluto/lib stuff ends up in the charon-media tree?
Cheers,
Mark


You should copy the libs to src/lib (create the lib dir first).
Also. Do you want to build stuff for the future lmce releases or for 0710?
For 0710 you should checkout LinucMCE-0710 instead of charon-merge.

svn co http://svn.linuxmce.org/pluto/branches/LinuxMCE-0710

There is no configure script available for 0710.
So you need to do whats on this page.
http://wiki.linuxmce.org/index.php/Building_From_Source

Do the find stuff.
Then make.

Have learnt the hard way myself over the past week.

/niz23

samir

  • Regular Poster
  • **
  • Posts: 20
    • View Profile
Re: Development environment setup
« Reply #2 on: April 19, 2009, 09:44:21 am »
Hi ,
I am having some problem here . I saw a lib directory already in trunk/src after I downloaded svn.Now when I try to copy the lib files of usr/pluto/lib  it gives me this error
linuxmce@dcerouter:~/trunk$ cp all  /usr/pluto/lib/* /src/lib/ -R
cp: target `/src/lib/' is not a directory: No such file or directory

but when I check inside the src/lib i see the directory "lib",
Please help me out .

Thanks,
sameer

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Development environment setup
« Reply #3 on: April 19, 2009, 03:33:09 pm »
i would suggest that you set up a 0810 dev env as 0710 is now well and truely closed... nothing further will be added to that branch... 810 is in alpha and will go beta soon.