Author Topic: rs232 tv control  (Read 2462 times)

Todd

  • Regular Poster
  • **
  • Posts: 35
    • View Profile
rs232 tv control
« on: August 16, 2008, 05:31:24 am »
I have a pioneer 1140hd tv.  It was not automatically detected at installation.  I went under the admin website and under wizards, av equipment I added the closest tv template I could find (elite tvs).  I have plugged the serial cable into com port 1.  I have selected /dev/ttys0 in the av equipment.  I have a hybrid/core.  I know the serial cable and pioneer tv work, because I used tera term from a laptop and sent it the power off command and power on command and they both worked.  In a/v properties I have attempted to enter the command to turn off the tv in the off box and hit "test" button with no success.  It says it sent the command to device #19.  The command to turn off the TV is hex 02 **POF hex 03.  My problem may be that I do not know the correct syntax to make it send this command.  What is the correct way to put the hex number 02 plus the **POF plus the ending hex number 03 into the off box?

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: rs232 tv control
« Reply #1 on: August 16, 2008, 05:59:51 am »
Todd - I think the test button is a bit dodgy! So don't rely on it.

Have you created a device for your TV? (don't edit the template, actually create a new device from the template in the wizards menu Wizard->Devices->AV Equipment - this can be confusing)

In your devices tree you should see the TV as a child device of your "The core/hybrid" object. I believe this defines the "Controlled by" relationship so is important.

You then need to setup at least one "pipe" that links the output of your core to the input of your TV. Either video or audio pipe, or both ideally. This tell LMCE which devices to route the various commands to.

The other tip I have is, the template is just data for the device, the device itself is the Generic Serial Device (GSD) which is software that will be installed automatically as part of you creating the device in the wizard. However, I noticed that although it said it had installed, the core was not able to find the binary (and thus not start the device) until after I had rebooted, reloading the router was not enough.

So I suggest you create a device from the template using the wizard menu, ensure that it is controlled by the core/hybrid, setup audio and video pipes from the output of your core to the input of your tv (using the connection wizard is pretty easy from the av equipment menu), then reboot and confirm that the device is starting...

rwilson131

  • Veteran
  • ***
  • Posts: 118
    • View Profile
Re: rs232 tv control
« Reply #2 on: August 16, 2008, 06:09:17 am »
Make sure the follow package is installed:

Code: [Select]
apt-get install pluto-generic-serial-device
Take a look at this page.

http://wiki.linuxmce.org/index.php/LG_42LB5D

It walks you through making a TV Template.  Your Manual should have the correct syntax in the back somewhere, and if not just google it.

Thanks,
Rob

Todd

  • Regular Poster
  • **
  • Posts: 35
    • View Profile
Re: rs232 tv control
« Reply #3 on: August 16, 2008, 02:25:14 pm »
Thanks everyone, I will try it today.

Todd

  • Regular Poster
  • **
  • Posts: 35
    • View Profile
Re: rs232 tv control
« Reply #4 on: August 17, 2008, 04:25:38 am »
I followed all of your advice and my TV is now controlled by LinuxMCE!!!!  Thanks again for your help.  If anyone is interested, the correct syntax for turning off the tv is <$"\x02**POF\x03"$> (the \x followed by the two digit hex number puts it in the string)

I have checked to share my template, but I thought I read where that feature is not working and maybe you have to submit it manually.  Do we have to submit them manually? If so how?