Author Topic: Media Director tftpboot problem  (Read 3291 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Media Director tftpboot problem
« on: January 26, 2006, 03:40:24 pm »
I have successfully instaled a Pluto core via 'installation-cd.2.0.0.35.iso'.  I can also add a WinXP Orbitor.  My next step was to test a Media Director boot via PXE but this fails in two places.  When the MD is pulling vmlinuz-2.6.13.2-vanilla-pluto-1-686 it halts an displays a 'Could not find ramdisk image :x.x.x.x/initrd.img-2.6.13.2-vanilla-pluto-1-686.  I found I could type a boot:  x.x.x.x/vmlinuz-2.6.13.2-vanilla-pluto-1-686 after this failure and it would decompress but I would get a Kernel panic - not syncing:  VFS: Unable to mount root fs on unknown-block(8,1).

I also get an error while clicking on 'Setup Diskless Media Director':
sudo -u root /usr/pluto/bin/Diskless_Setup.shGetting list of Media Directors
Processing moon 1 (Test PC; 00:50:DA:75:31:55; 31)
* Allocated IP '192.168.10.71'
* Diskless filesystem
/usr/pluto/diskless/192.168.10.71/tmp /usr/pluto/diskless/192.168.10.71
Reading Package Lists... 0%Reading Package Lists... 100%Reading Package Lists... Done
Building Dependency Tree... 0%Building Dependency Tree... 0%Building Dependency Tree... 50%Building Dependency Tree... 50%Building Dependency Tree... 74%Building Dependency Tree      
Reading extended state information... 0%Reading extended state information... 0%Reading extended state information... 39%Reading extended state information      
Initializing package states... 0% Initializing package states... 37%Initializing package states... Done
Reading task descriptions... 0%    Reading task descriptions... 2%Reading task descriptions... Done
0% [Working]            50% [Working]             /usr/pluto/diskless/192.168.10.71
1   01/26/06 09:13:51   /usr/pluto/bin/Create_DisklessMD_FS.sh (server)   Installing kernel '/usr/pluto/deb-cache/dists/sarge/main/binary-i386/kernel-image-2.6.13.2-vanilla-pluto-1-686_2.6.13.2_i386.deb' on '192.168.10.71'
3   01/26/06 09:13:58   /usr/pluto/bin/Create_DisklessMD_FS.sh (server)   Failed to install kernel '2.6.13.2-vanilla-pluto-1-686' on '192.168.10.71'
* Setting up /tftpboot/pxelinux.cfg/01-00-50-da-75-31-55
* Setting local files
 fstab hosts interfaces DNS hostname MythTV_DB_Settings MySQL_access Install Timezone syslog apt debconf

* Adding root to exports
* Adding to hosts
1   01/26/06 09:14:01   /usr/pluto/bin/Update_StartupScrips.sh (server)   Updating startup scripts
Finished setting up network boot for media directors.
If new media director(s) were added, do a quick reload router.
sudo -u root /usr/pluto/bin/DHCP_config.sh25463 Thu Jan 26 09:14:01 EST 2006 WaitLock 'PlutoDHCP' (PlutoDHCP_config)
25463 Thu Jan 26 09:14:01 EST 2006 WaitLock 'PlutoDHCP' (PlutoDHCP_config) success
Stopping DHCP server: dhcpd3.
Starting DHCP server: dhcpd3.
25463 Thu Jan 26 09:14:06 EST 2006 Unlock 'PlutoDHCP' (PlutoDHCP_config)
25463 Thu Jan 26 09:14:06 EST 2006 Unlock 'PlutoDHCP' (PlutoDHCP_config) success


Do I need to edit the pxelinux.cfg file or is there something else going on?

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Media Director tftpboot problem
« Reply #1 on: January 29, 2006, 03:56:22 am »
I am also getting this problem...sorry can't help but I wanted to add my voice to the problem (Failed to install kernel '2.6.13.2-vanilla-pluto-1-686' on '192.168.80.252').

I did discover that my /home area where the diskless files systems are stored (I think) was full but I fixed that and still get the problem.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Media Director tftpboot problem
« Reply #2 on: January 29, 2006, 03:56:59 am »
I am also getting this problem...sorry can't help but I wanted to add my voice to the problem (Failed to install kernel '2.6.13.2-vanilla-pluto-1-686' on '192.168.80.252').

I did discover that my /home area where the diskless files systems are stored (I think) was full but I fixed that and still get the problem.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Media Director tftpboot problem
« Reply #3 on: January 29, 2006, 10:15:06 am »
hade the same problem that /home was to small
( newbielink:http://plutohome.com/support/phpbb2/viewtopic.php?t=563 [nonactive])

have you rebuild your MD efter you made /home bigger?

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Media Director tftpboot problem
« Reply #4 on: January 30, 2006, 01:35:13 am »
Yep, it then said that the kernel already existed.

But I still can't get the MD to network boot. I had to make a boot disk to do net boot (used newbielink:http://rom-o-matic.net/ [nonactive]), I see the MD requesting IP from core, I see a tftp ip address and gateway (the same as the core 192.168.80.1), I see the core seeing the DHCP request but the MD never receieves a file (or futher boot instructions) so it just keeps looping.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Media Director tftpboot problem
« Reply #5 on: February 01, 2006, 12:34:11 am »
Does anyone else have any suggestions on what could be wrong or where to look. Is there a log?

Thanks

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Re: Media Director tftpboot problem
« Reply #6 on: February 01, 2006, 10:07:28 am »
Quote from: "PhatOne"
My next step was to test a Media Director boot via PXE but this fails in two places.  When the MD is pulling vmlinuz-2.6.13.2-vanilla-pluto-1-686 it halts an displays a 'Could not find ramdisk image :x.x.x.x/initrd.img-2.6.13.2-vanilla-pluto-1-686.

I also get an error while clicking on 'Setup Diskless Media Director':
1   01/26/06 09:13:51   /usr/pluto/bin/Create_DisklessMD_FS.sh (server)   Installing kernel '/usr/pluto/deb-cache/dists/sarge/main/binary-i386/kernel-image-2.6.13.2-vanilla-pluto-1-686_2.6.13.2_i386.deb' on '192.168.10.71'
3   01/26/06 09:13:58   /usr/pluto/bin/Create_DisklessMD_FS.sh (server)   Failed to install kernel '2.6.13.2-vanilla-pluto-1-686' on '192.168.10.71'

The kernel package seems to fail creating the initrd.

You can try to edit /usr/pluto/bin/Create_Diskless_FS.sh and on the line just above "Failed to install kernel" replace "&>/dev/null" with "2>&1" to get all the messages (I made this change in SVN).

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Media Director tftpboot problem
« Reply #7 on: February 01, 2006, 09:59:12 pm »
I edited the Create_DisklessMD_FS.sh without any additionl output.

Is it possible to run:
./Create_DisklessMD_FS.sh <IP> <MAC> <Device> <Activation Code>

I assume <Device> is ID or Device Template #.  I am not sure what <Activation Code> is.

dcerouter_3742:/usr/pluto/bin$ ./Create_DisklessMD_FS.sh 192.168.80.2 01:00:50:da:75:31:55 <?> <?>

I will also reload with a larger /home per paflo's suggestion.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Media Director tftpboot problem
« Reply #8 on: February 02, 2006, 10:00:45 am »
"Device" is the device number, and "Activation Code" is always 1111 on recent installations.

Also, your MAC address looks weird. That "01:" probably shouldn't be there.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Media Director tftpboot problem
« Reply #9 on: February 02, 2006, 11:32:23 am »
For my problem, what should I look at.

The MD is requesting IP and getting IP but does not boot....what could be the reasons and where should I look to debug

Thanks

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Media Director tftpboot problem
« Reply #10 on: February 21, 2006, 10:00:14 pm »
Same problem, I got an error saying Could not find ramdisk image

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Media Director tftpboot problem
« Reply #11 on: February 22, 2006, 12:45:37 am »
I fixed it for me, hopefully it will work for you guys.

When you add the device, make sure that Infrared Receivers is set to Null, and that of course you have the right MAC Address.

hope that helps