Author Topic: internet unreachable by core/hybrid  (Read 2830 times)

zirconiums

  • Newbie
  • *
  • Posts: 6
    • View Profile
internet unreachable by core/hybrid
« on: August 07, 2008, 07:28:57 am »
INTRODUCTION
=========
Howdy folks! -- I'm in about 3 months since my real interest in LinuxMCE; lots of research reading all your comments and watching the video over and over before I committed to get started. It's had its rough spots so far including multiple incompatible capture cards and IR remotes and gyro remote, getting a couple VAIO jukes over e-bay, and adding an additional SATA TB drive (I'll be writing an article on that later). I'm still hopeful that it'll all turn out in the end. I'm hopeful about getting it working and then helping friends do theirs; also hopeful for an iPhone 3G orbiter! This is my first post here. But enough of the introduction...


PROBLEM
======
Despite my best efforts, I cannot for the life of me get the core/hybrid itself to connect to the internet. The givens:

--2 NICs (one external, one internal);
--DHCP at DSL router is ON. I allow wireless connections to the external network,
--DHCP-enabled DSL router goes straight to the external NIC on MCE and provides a 192.168.0.x IP to eth0;
--DHCP at LinuxMCE is ON. Devices hardwired to the internal hub get their 192.168.80.x from eth1 (192.168.80.1);
--internal network does great; I attach my Ubuntu Hardy lappy to an internal hub and I can get to the Net fine.
--external network does great; I attach my WinXP lappy over wireless and reach the Net fine.

!! But, no Internet directly from the core/hybrid.

--on install eth1 was external and eth0 was internal, I used the UI to switch these and their cables.

I reverified all network settings from KDE and it makes me wonder if I have to do some kind of core/hybrid configuration so that its own apps do some kind of BIND TO ALL NICs or something?

Thanks in advance for your comments (and salutations).


P.S. Modified: my NICs:
linuxmce@dcerouter:~$ lspci | grep -i ethernet
02:00.0 Ethernet controller: Attansic Technology Corp. L1 Gigabit Ethernet Adapter (rev b0)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)

P.P.S. Modifed: answers to first round of responses:
basic network troubleshooting (from core/hybrid to internet):
-- bought a new ethernet cable for core/hybrid to dsl router. didn't fix it.
-- switching the internal/external cables at the core only made everything stop working. switched back.
-- ping to google is good...
linuxmce@dcerouter:~$ ping google.com
PING google.com (72.14.207.99) 56(84) bytes of data.
64 bytes from google.com (72.14.207.99): icmp_seq=1 ttl=255 time=151 ms
64 bytes from google.com (72.14.207.99): icmp_seq=2 ttl=255 time=151 ms
64 bytes from google.com (72.14.207.99): icmp_seq=3 ttl=255 time=148 ms
64 bytes from google.com (72.14.207.99): icmp_seq=4 ttl=255 time=148 ms
64 bytes from google.com (72.14.207.99): icmp_seq=5 ttl=255 time=163 ms

!! Aha! But ping to cnn is not so good...
linuxmce@dcerouter:/$ ping cnn.com
PING cnn.com (64.236.16.20) 56(84) bytes of data.
--- cnn.com ping statistics ---
12 packets transmitted, 0 received, 100% packet loss, time 11000ms

Konqueror browser shows google.com, but chokes on cnn.com. cnn.com shows looking up address, then connecting to server, but never gets there. I think I'm very close now. Aha! sudo /etc/init.d/networking restart yielded the following:
DHCPRELEASE on eth0 to 192.168.0.1 port 67
There is already a pid file /var/run/dhclient.eth0.pid with pid 134519120
I can get to cnn.com now, but not other addresses. Weird!
I can reach linuxmce.org, but not others. I don't get it.


SOLUTION
========
See below for the process to reach this solution, but I had to "hard code" the ip address:
-- From the orbiter, advanced>kde desktop.
-- Then from the "K" menu at lower left, choose System Settings.
-- In kubuntu>system settings>network settings.
-- switch to administrator mode (at bottom) and enter your linuxmce password from installation.
-- Select the eth0 from the list and click [configure interface].
-- Switch from Automatic to Manual and OK.
-- Under the Domain Name Server list, moved the main DSL modem's address (in my environment 192.168.0.1) to the second position in the list. The first position shows the ISP's primary nameserver.
« Last Edit: August 13, 2008, 06:38:45 am by zirconiums »

rodercot

  • Guest
Re: internet unreachable by core/hybrid
« Reply #1 on: August 07, 2008, 11:31:35 am »
A couple things which you have likely done but what the hey.

 Outside access is turned on - webadmin - security - outside access.

 add port 22 in the firewall settings - webadmin - advanced - network - firewall settings.

 Can you also post which driver is driving your external nic. but if you are seeing internet on your internal lan it sounds like that nic is working.

 Have you tried to disable the firewall on the core to test and Which router are you using.

 The first two items I would not think have anything to do with you access at the core but I have seen weider things happen thus far.

 
 Dave

Domodude

  • Guest
Re: internet unreachable by core/hybrid
« Reply #2 on: August 07, 2008, 11:34:01 am »
Hi,
If you go to a shell on the core, what does ifconfig tell you about your network?

Also, if it does not work, try these:
* swap the internal and external cable on the core, and do a /etc/init.d/networking restart (!)
* replace the cat5 cable between your router and the core

Hope that helps,
let us know
Mark

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: internet unreachable by core/hybrid
« Reply #3 on: August 07, 2008, 02:55:02 pm »
Have you done any basic network troubleshooting first, like pinging?

From a shell on your core (not on your internal or externally connected PCs)

Ping google.com

Does it resolve to an IP address? Yes - then your core is able to access your router for DNS, so that's good! No - troubleshoot the interactions between core and router, as if DNS isn't getting through, then....

Does it actually ping after resolving? No - try traceroute and see where it stops...

Take a look at the routes on the core as well - but assuming if your internal devices are getting through then this should be fine.

Oh, also check that arp is working between core and router - if it is trying to ARP the DNS server on your router and it can't convert IP to MAC then it won't be able to get any further even though it can router perfectly fine (although that would seem to affect your internal network as well... worth checking)

zirconiums

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: internet unreachable by core/hybrid
« Reply #4 on: August 10, 2008, 07:40:48 am »
Dave and Mark -- Thanks very much for your input. I tried some of this and believe I have a better idea now. My lack of knowledge of ubuntu networking and conf files is the biggest stumbling block right now.

My recent progress:

basic network troubleshooting (from core/hybrid to internet):
-- bought a new ethernet cable for core/hybrid to dsl router. didn't fix it.
-- switching the internal/external cables at the core only made everything stop working. switched back.
-- ping to google is good...
linuxmce@dcerouter:~$ ping google.com
PING google.com (72.14.207.99) 56(84) bytes of data.
64 bytes from google.com (72.14.207.99): icmp_seq=1 ttl=255 time=151 ms
64 bytes from google.com (72.14.207.99): icmp_seq=2 ttl=255 time=151 ms
64 bytes from google.com (72.14.207.99): icmp_seq=3 ttl=255 time=148 ms
64 bytes from google.com (72.14.207.99): icmp_seq=4 ttl=255 time=148 ms
64 bytes from google.com (72.14.207.99): icmp_seq=5 ttl=255 time=163 ms


!! Aha! But ping to cnn is not so good...
linuxmce@dcerouter:/$ ping cnn.com
PING cnn.com (64.236.16.20) 56(84) bytes of data.
--- cnn.com ping statistics ---
12 packets transmitted, 0 received, 100% packet loss, time 11000ms

Konqueror browser shows all of google.com, but chokes on cnn.com. cnn.com shows looking up address, then connecting to server, but never gets there. I think I'm very close now. Aha! sudo /etc/init.d/networking restart yielded the following:
DHCPRELEASE on eth0 to 192.168.0.1 port 67
There is already a pid file /var/run/dhclient.eth0.pid with pid 134519120
I can get to cnn.com now, but not other addresses. Weird!
I can reach linuxmce.org, but not others. I don't get it.

arp table shows router mac for eth0 (gateway)
linuxmce@dcerouter:/$ arp -vn -H ether -i eth0 -a
? (192.168.0.1) at XX:XX:XX:XX:XX:XX [ether] on eth0
Entries: 254   Skipped: 253   Found: 1

also:
linuxmce@dcerouter:/$ cat /etc/resolv.conf
search domain.actdsltmp
nameserver 192.168.0.1
nameserver 204.[dsl isp nameserver]

Thanks again for your thoughts.
Mike
« Last Edit: August 10, 2008, 08:20:18 am by zirconiums »

Domodude

  • Guest
Re: internet unreachable by core/hybrid
« Reply #5 on: August 10, 2008, 11:24:28 pm »
Sorry it took a while, but you could try this:

from a shell, type
Code: [Select]
nslookup cnn.comYou SHOULD get the ip address. It should certainly work for google.com, since you can ping it.
If you do not get a good ip address, doublecheck if the DNS address is correct (should be your ISP DNS, or any other that you have access to).

If you have a working windows machine using the same router/ISP connection, check its DNS entry. Use that entry in LMCE, just use a manual configuration to test it all.

HTH,
Mark

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: internet unreachable by core/hybrid
« Reply #6 on: August 11, 2008, 12:16:53 pm »
...
!! Aha! But ping to cnn is not so good...
linuxmce@dcerouter:/$ ping cnn.com
PING cnn.com (64.236.16.20) 56(84) bytes of data.
--- cnn.com ping statistics ---
12 packets transmitted, 0 received, 100% packet loss, time 11000ms
...

Well cnn.com doesn't seem to respond to pings at all, so that is obviously not a good test.
"Change is inevitable. Progress is optional."
-- Anonymous


los93sol

  • Guru
  • ****
  • Posts: 396
    • View Profile
Re: internet unreachable by core/hybrid
« Reply #7 on: August 11, 2008, 03:08:24 pm »
This may seem obvious, but I have this issue with my cable modem connection whenever I switch the box that is connected to it out.  Unplug the cable modem for 30 seconds and plug it back in, mine has to have the connection refreshed whenever the MAC of the device it's connected to changes.  For some reason DHCP on the cable modem gets hosed up and while it will work somewhat DNS gets really flakey and until the connection is refreshed I will continue to see strange issues.  Give it a shot if you haven't already done so.

zirconiums

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: internet unreachable by core/hybrid
« Reply #8 on: August 12, 2008, 07:26:52 am »
Ugh. Thanks to everyone for your ideas. I though I almost had it tonight. I compared a lappy on the external network to the eth0 DNS list on the core/hybrid, and realized that the secondary DNS entry on the core/hybrid was pointing at the secondary DNS for my ISP. Corrected it. I still have the DSL router listed first (192.168.0.1) and the ISP primary DNS listed second.

I also tried the DSL router power-bounce... no change.

Verified the MAC address in the client list on the DSL router's web portal for the core/hybrid. It's correct.

The core's default gateway is the DSL router (192.168.0.1) on eth0. I almost want to manually change it to the actual DSL gateway at the ISP to see what happens, but I know that won't do it.

I wonder if there is some kind of permissions issue for the linuxmce user

I'm almost at my wit's end.  =(

rodercot

  • Guest
Re: internet unreachable by core/hybrid
« Reply #9 on: August 12, 2008, 11:33:19 am »
Can you give us you web-admin network settings. web-admin - advanced - network settings.

 Not sure if you did this but what network cards (codecs) are you using for the system more-so the eth0 nic controller and which driver is that nic using.

 go to shell to the core (or ctl-alt-F2 at the core itself) and use ifconfig look for tx or rx errors or Frame Drops and then ethtool -i eth0 and then ethtool eth0 and post the reports here.

 I change my router address to 192.168.1.1 not sure if it matters and the gateway at the core is the same but the DNS address for me never seem to propogate properly anyhow. My primary on the core usually is never the primary on the router and vice versa. It updates or should update this everytime the PPOE connection is refreshed and with mine that is usually once or twice per week.

 Not sure if you mentioned this but what router are you using is it a modem/router or a modem wlan out to a router. Sorry if you mentioned this.

 Not many Modem/Routers work right as a router but fine as a modem. I have a couple of Unlocked Speedstars for Bell and both of them have router features. I ended up turning off the router features and using the wlan port out to a Dlink 655 Gb wired and wireless.  But do not go spending extra $$ just yet, let's look at those settings.

 Dave

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: internet unreachable by core/hybrid
« Reply #10 on: August 13, 2008, 01:17:18 am »
If you are getting inconsistent DNS lookups, then that can easily be because one DNS server is working/accessible and the other is not. The way the client chooses which one will determine whether your lookup works. Using NSLOOKUP is a client in its own right, so doesn't necessarily do the same thing as the Linux client and may confuse matters. Try configuring your core with only 1 DNS server (primary) either statically or be reconfiguring the DHCP settings on your DSL router. Make that DNS server your DSL router and test extensively. Then change it to your ISP and do the same thing (perhaps your router's statefulness on UDP packets is dodgey - that would cause the returning DNS answers to be blocked at the router). However, looking at your original problem, it looks to be more than just DNS....

Eliminate DNS using this method first, and doing lots of pings (as Zaerc pointed out, just look for the resolution, not the actual returning packets as most sites block ICMP packets, so ping doesn't work) - if one setting gives you reliable lookups, leave it at that and move onto the connectivity issue...

zirconiums

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: internet unreachable by core/hybrid
« Reply #11 on: August 13, 2008, 05:59:41 am »
Thanks again, Dave. Realizing I missed some of your first recommendations. My results tonight:

webadmin>advanced>network>network settings:
EXTERNAL_IFACE     eth0
EXTERNAL_MAC    00:XX:XX:XX:XX:0B
EXTERNAL_IP    192.168.0.5
EXTERNAL_NETMASK    255.255.255.0
EXTERNAL_DHCP    1
INTERNAL_IFACE    eth1
INTERNAL_MAC    00:XX:XX:XX:XX:24
INTERNAL_IP    192.168.80.1
INTERNAL_NETMASK    255.255.255.0
GATEWAY    192.168.0.1
DNS1    192.168.0.1
DNS2    204.[isp.primary.dns]

no errors listed in ifconfig:
eth0:           RX packets:112757 errors:0 dropped:0 overruns:0 frame:0
          TX packets:91775 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:118480264 (112.9 MB)  TX bytes:11804385 (11.2 MB)

linuxmce@dcerouter:~$ ethtool -i eth0
driver: r8169
version: 2.2LK
firmware-version:
bus-info: 0000:05:00.0

linuxmce@dcerouter:~$ sudo ethtool eth0
[sudo] password for linuxmce:
Settings for eth0:
   Supported ports: [ TP ]
   Supported link modes:   10baseT/Half 10baseT/Full
                           100baseT/Half 100baseT/Full
                           1000baseT/Full
   Supports auto-negotiation: Yes
   Advertised link modes:  10baseT/Half 10baseT/Full
                           100baseT/Half 100baseT/Full
                           1000baseT/Full
   Advertised auto-negotiation: Yes
   Speed: 100Mb/s
   Duplex: Full
   Port: Twisted Pair
   PHYAD: 0
   Transceiver: internal
   Auto-negotiation: on
   Supports Wake-on: pumbg
   Wake-on: g
   Current message level: 0x00000033 (51)
   Link detected: yes

DSL modem is an Actiontec GT701-WG  (FW 3.60.1.0.4.1)

Firewall rules.  netstat -an shows lots of binds from internal to external, so it looks like it's working. Tried disabling the firewall, but no change.
Protocol     Source Port     Destination Port     Destination IP     Rule Type     Limit to IP     
udp    4569 to 0    0       core_input       Delete
udp    5060 to 0    0       core_input       Delete
udp    2000 to 0    0       core_input       Delete
tcp    2000 to 0    0       core_input       Delete
tcp    3877 to 3877    3877    192.168.80.1    port_forward       Delete
tcp    22 to 22    22    192.168.80.1    port_forward       Delete

And late to the fray (thanks to colinjones), I tried removing the ISP as the secondary last night, and everything broke. No more Net connectivity from Internal at all. Will try removing the DSL modem as primary after I post this; will modify with my results shortly.

Thanks again for your support. I am encouraged by your additional recommendations. Be back shortly.

zirconiums

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: internet unreachable by core/hybrid
« Reply #12 on: August 13, 2008, 06:18:31 am »
We're very close now. Removed the DSL modem and forced manual/static on external from the kubuntu system settings>network settings panel. If left on dhcp, the networking restart repopulated the 192.168.0.1 as primary, so I had to switch to static. Now, how can I make this workable?

-- From 192.168.0.9 (external lappy), I still want to ssh in to the server, so don't want to disable dhcp on the dsl modem.
-- going to set "static" assignment of ip to core/router to the mac address.
-- answering my own question, i've re-added the dsl modem to the now static configuration kubuntu for eth0, but as a _secondary_ dns. still works.

WHOOPS. The MAC authentication I remembered in the DSL modem webadmin is for wireless access allow/deny only. I'll have to set up a static routing, but don't know how to do that. Will do a bit of research to see if that is the answer. Is that how to avoid switching the kubuntu ip if the modem assigns a different ip?

Any other closing comments from the group?
« Last Edit: August 13, 2008, 06:38:20 am by zirconiums »

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: internet unreachable by core/hybrid
« Reply #13 on: August 13, 2008, 08:21:55 am »

*hmm*

it's amazing how complicated people try to make setting this up, instead of just following directions....

-Thom

rodercot

  • Guest
Re: internet unreachable by core/hybrid
« Reply #14 on: August 13, 2008, 12:20:28 pm »
Dude,

 You should not be port forwarding port 22. It should be a core input not a port forward.  Also your core should Be seeing TWO DNS addresses from the router/modem not one gateway and one DNS. That is likely your problem. My router sends three all the time when connected to PPOE. I am telling you use that modem as a modem and get a router only - The D-link under 90$ now works out of the box other than some simple setup. But make sure you can shut off the router portion in that modem.

 your port 22 line should be TCP - 22 to 22 no port /no ip / core input  then add. right now you are opening port 22 and then telling it to forward port 22 to the internal lan.

 I have to agree with Thom and why this is so hard to setup up i am not sure. but I was here not too long ago so we'll see ya through this. 

 OOPS I did not see colin post, I would not try and set anything manually. I tried that with mine and no dice. It should be simple though.

 ADSL - Modem/Router - PPOE/or connected all the time (DNS addresses resolved at the modem DHCP clients set on subnet 255.255.255.0 on gateway address 192.168 0 or 1. 1. Dhcp client list in the router, I make this only as many as I need) I have 10 open spots. I force the core to 192.168.1.100 from the router (not really force I just reserve that address to the core's mac address) - Then the core - Get IP address automatically eth0, it does and sets up eth1 at 80.1.

 Have you checked the DHCP client listing in your modem as well. the core will setup a client named Ubuntu upon install but should change to dcerouter upon completion and reboot. Sometimes it does not. 

 Dave
« Last Edit: August 13, 2008, 01:21:18 pm by rodercot »