Author Topic: Hangs up after 2 days!!  (Read 3293 times)

Kernellinux

  • Regular Poster
  • **
  • Posts: 21
    • View Profile
Hangs up after 2 days!!
« on: July 21, 2008, 12:27:06 am »
Everything in my media center works great. But after about 2 days of it being on, even if it isn't doing anything, it hangs up. Any suggestions?


    

ASUS P5N-MX LGA 775 NVIDIA GeForce 7050 Micro ATX Intel Motherboard - Retail
Intel Core 2 Duo E7200 Wolfdale 2.53GHz LGA 775 65W Dual-Core Processor Model BX80571E7200 - Retail
Hauppauge WinTV PVR 350 Video Recorder, TV/FM Tuner Card PCI Interface - Retail

Marper

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: Hangs up after 2 days!!
« Reply #1 on: July 21, 2008, 08:50:14 am »
I pretty much get the same thing happening.  Now I've gone from 2 day to about a week.  Memory peaks out and processor peaks out constantly.  I have a Core with ASUS Mobo and Intel Core 2 Duo and 4 Gb RAM, MD ASUS Slim Barebone similar to yours - 4 Gb RAM, Intel Core 2 Duo with an Nvidea 6200 Vid.  I have played around with the BIOS as follows:

Turned Off Hyperthread - this seemed to make the most significant difference
Turned Off ACPI and any controls that have to due with Temp, CPU Spead or System notification
Turned off ALL none needed Ports - Parallel, Floppy, RS232
Disabled onboard Video - naturally

The system still locks up after about 5 days - DVD's really play bad, many skips or lags.  Menu is really delayed at the MD (when the cursor is over a menu item, there is a 5 to 20 sec. delay).  Navigation at the MD seems to cause the core to hang over 3 days of use. 
Extra HDD in the Core seem to mount and dismount all day every day at least once an hour - making it difficult for all of my pictures on them display a black screen when it dismounts

Had none of the above issues in 0704 -

I can provide further info if someone has any ideas.

seth

  • Guru
  • ****
  • Posts: 485
  • A day w/o LinuxMCE is like a day w/o sunshine!
    • View Profile
Re: Hangs up after 2 days!!
« Reply #2 on: July 21, 2008, 01:55:58 pm »
 :)
I have also been able to eliminate lock-ups by disabling the flickr screensaver. While this is by no means a fix, it will let you run, at least in my case for days w/out a reboot.

Do this by going into the web admin http://dcerouter logging in with your credentials, usually your name for user and password.
Across the top of the page, you will see an entry for "Files & Media"
Under that click on "Screensaver"
Then "Disable flickr script"
Then "Reload Scrensaver"
If you still see the images, do a quick reload of the router from the Advanced LMCE menu.

YMMV but this resolved my issues.

Marper's suggestions may do the same thing, so now you have 2 things to try  :)

Regards,

Seth
".....Because Once you've LinuxMCE'd....."
System stats located at my user page:

http://wiki.linuxmce.org/index.php/User:Seth

Kernellinux

  • Regular Poster
  • **
  • Posts: 21
    • View Profile
Re: Hangs up after 2 days!!
« Reply #3 on: July 23, 2008, 12:13:42 am »
Thank you both. I have disables the flickr screensaver, and my unused ports. I find it hard to believe that such a large community has this kind of elementary problem. Has anyone installed MCE and not had it hang up within a few days?

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Hangs up after 2 days!!
« Reply #4 on: July 24, 2008, 10:31:24 am »
Thank you both. I have disables the flickr screensaver, and my unused ports. I find it hard to believe that such a large community has this kind of elementary problem. Has anyone installed MCE and not had it hang up within a few days?


Of course!

We have numerous Cores/MD's that are up 24-7 both here in our demo, development and test areas and not to mention a substantial number of customer systems.

Here's the current uptime console output from one of the Core's in our Development Rack;

Code: [Select]
dcerouter_83086:/home/builds/23-07-2008# uptime
 09:11:52 up 49 days, 18:23,  1 user,  load average: 0.13, 0.17, 0.20
dcerouter_83086:/home/builds/23-07-2008#

The core's & MD's in our demo area are only shutdown when we upgrade them with a new software release... they are left on 24-7. We do this as a demonstration to customers of the stability and reliability of the system and at the same time it quickly indicates to us if we have stability issues.

So as I have said here many time before in other threads... if you are having stability problems they are in my experience down to either hardware failures/un-supported hardware or software that has been added after installation that has introduced instability.

All the best

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2420
    • View Profile
    • ago control
Re: Hangs up after 2 days!!
« Reply #5 on: July 25, 2008, 01:09:26 am »
Thank you both. I have disables the flickr screensaver, and my unused ports. I find it hard to believe that such a large community has this kind of elementary problem. Has anyone installed MCE and not had it hang up within a few days?
not the community has an elementary problem. It is just your hardware (or assembly) that is crap.

best regards,
Hari
rock your home - http://www.agocontrol.com home automation

Kernellinux

  • Regular Poster
  • **
  • Posts: 21
    • View Profile
Re: Hangs up after 2 days!!
« Reply #6 on: July 28, 2008, 03:42:05 am »
Okay, fair enough however....

I started with a Dell Precision 380. It hung up in about 2 days, so I went online looked at a few different posts and bought a P5N-MX with a nVidia BFG 6200 OC. And the Hauppage 350 Tuner card. When that hung up after 2 days, I went and decided I STILL must have a hardware issue, so I purchased a P5N 32E SLI, from a recommendation from the hardware part of the wiki, and the Asus EN8400GS Silent, (this was EXACTLY from the hardware wiki) Now that has froze up in two days. So in my defence, I'm not unwilling, lazy, or cheap in trying to purchase hardware, perhaps a little misguided. What are your demo servers running?

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Hangs up after 2 days!!
« Reply #7 on: July 28, 2008, 01:31:24 pm »
Okay, fair enough however....

I started with a Dell Precision 380. It hung up in about 2 days, so I went online looked at a few different posts and bought a P5N-MX with a nVidia BFG 6200 OC. And the Hauppage 350 Tuner card. When that hung up after 2 days, I went and decided I STILL must have a hardware issue, so I purchased a P5N 32E SLI, from a recommendation from the hardware part of the wiki, and the Asus EN8400GS Silent, (this was EXACTLY from the hardware wiki) Now that has froze up in two days. So in my defence, I'm not unwilling, lazy, or cheap in trying to purchase hardware, perhaps a little misguided. What are your demo servers running?

Well the system I gave the uptime from is a FIC I965 based hybrid core running a ASUS 7300GT graphics card. We have an FIC i915 based hybrid/core (with a nVidia 7300GT) and a i945GNT (ASUS 7300GT) racked Hybrid and an ASUS AM2/nVidia 7050 in our demo suite.

My home Core is an MSI i945 based machine with a nVidia 7300GS. We have cores based on Gigabyte AMD/AM2 motherboards too

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Hangs up after 2 days!!
« Reply #8 on: July 28, 2008, 02:27:59 pm »
Have you established whether your CPU/Memory is being eaten up as someone else suggested? Perhaps simply run a few top sessions remotely sorting on memory and CPU - when it crashes you should capture any standout processes, or at least confirm that they aren't the issue...

Kernellinux

  • Regular Poster
  • **
  • Posts: 21
    • View Profile
Re: Hangs up after 2 days!!
« Reply #9 on: July 28, 2008, 05:16:32 pm »
ColinJones, I haven't looked at the processes but then again I have NO additional software, I'm strictly running MCE, just for fun I installed it, and without even running MythTV, Music, or Videos I just let the hybrid sit there, and it eventually hung up.

Kernellinux

  • Regular Poster
  • **
  • Posts: 21
    • View Profile
Re: Hangs up after 2 days!!
« Reply #10 on: July 28, 2008, 05:33:56 pm »
One other question is FIC First International Computer?


totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Hangs up after 2 days!!
« Reply #12 on: July 28, 2008, 06:17:15 pm »
One other question is FIC First International Computer?

Yes it is... we source bare standard motherboards from them as well as some custom build hardware.

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Hangs up after 2 days!!
« Reply #13 on: July 28, 2008, 06:22:47 pm »
http://www.newegg.com/Product/ShowImage.aspx?Image=13-130-139-03.jpg%2c13-130-139-04.jpg%2c13-130-139-05.jpg%2c13-130-139-06.jpg%2c13-130-139-08.jpg%2c13-130-139-07.jpg%2c13-130-139-02.jpg&S7ImageFlag=0&WaterMark=1&Item=N82E16813130139&Depa=0&Description=MSI+945+Neo5-F+ATX+Intel+Motherboard

Is this what your running at your home?

Thanks again to everyone for your help!

Its close but mine has an onboard VGA too... I'll dig out the board reference for you when I get home. Its not a very modern motherboard at all... but it works well ;-)

All the best

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

Kernellinux

  • Regular Poster
  • **
  • Posts: 21
    • View Profile
Re: Hangs up after 2 days!!
« Reply #14 on: July 28, 2008, 08:13:54 pm »
I really appreciate everyone's help and support, thank you so much you guys are very kind and generous with your time!