Author Topic: How to enable my Creative Sound Blaster Audigy SE 5.1  (Read 1719 times)

roberto99

  • Veteran
  • ***
  • Posts: 101
  • ...dreams of becoming a LMCExpert
    • View Profile
How to enable my Creative Sound Blaster Audigy SE 5.1
« on: July 12, 2008, 12:49:18 pm »
Hi all

I have installed a Creative Sound Blaster Audigy  SE 5.1 sound card and "the green line out" works when I hook up normal speakers. But when I connect my 5.1 speakers, I still only have sound on the line out (green plug). Where do I have to change settings to get the 5.1 sound? Any pointers? Is it maybe alsamixer but where do I find it?
Thanks
cheers

Roberto
« Last Edit: July 13, 2008, 04:48:47 pm by roberto99 »

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
Re: How to enable my 5.1 soundcard
« Reply #1 on: July 12, 2008, 03:27:53 pm »
Hi Roberto,

Are you doing this on a core, core/hybrid or diskless MD?

If it's a core go to dcerouter prompt and type alsamixer. 

If it's a hyrid or MD get to the GUI system/sound look at those settings but it's easier just to get to the terminal and type alsamixer.

Cheers.
« Last Edit: July 12, 2008, 04:09:39 pm by pigdog »

roberto99

  • Veteran
  • ***
  • Posts: 101
  • ...dreams of becoming a LMCExpert
    • View Profile
Re: How to enable my 5.1 soundcard Creative Sound Blaster Audigy SE 5.1
« Reply #2 on: July 13, 2008, 04:48:05 pm »
I tried to attache a printscreen but I always get "can not access path". Apparently my card got recognized, but in alsamixer in the terminal (left top) there is nothing written for "chip" (is this maybe the real problem?)

On one of the "analog" channels I get the output on the lime plug, but eaven giving volume on the other "analog" channels does not give me anything for the other 2 plugs for the 5.1 sound (orange and black).

Any ideas? Did anyone get a Creative Sound Blaster Audigy  SE 5.1 to work correctly?

Thanks
Roberto

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: How to enable my Creative Sound Blaster Audigy SE 5.1
« Reply #3 on: July 13, 2008, 05:18:04 pm »
I have an Audigy 2 ZS working in my hybrid MD/core and had it set up for multi-channel audio in the MD page in Web Admin and it had recognized the Audigy chip but, like you say, only Stereo output.  So I opted for Digital output and get sound on all speakers but I am not sure if I am getting 6 independent tracks becasue my reciever is not recognizing the Dolby digital or DTS output so the card must be decoding

niz23

  • Guru
  • ****
  • Posts: 361
    • View Profile
Re: How to enable my 5.1 soundcard Creative Sound Blaster Audigy SE 5.1
« Reply #4 on: July 13, 2008, 06:01:18 pm »
Roberto99.
I tried to attache a printscreen but I always get "can not access path". Apparently my card got recognized, but in alsamixer in the terminal (left top) there is nothing written for "chip" (is this maybe the real problem?)

On one of the "analog" channels I get the output on the lime plug, but eaven giving volume on the other "analog" channels does not give me anything for the other 2 plugs for the 5.1 sound (orange and black).

Any ideas? Did anyone get a Creative Sound Blaster Audigy  SE 5.1 to work correctly?

Thanks
Roberto

Have seen this issue on one of my IBM M51 machines.
I had to move the card to another PCI slot and then, magically it worked.

I cannot explain it. It may have to to with how your motherboard manufacturer have implemented the PCI bus on your card.

Just my two cents on the issue.
/niz23

roberto99

  • Veteran
  • ***
  • Posts: 101
  • ...dreams of becoming a LMCExpert
    • View Profile
Re: How to enable my Creative Sound Blaster Audigy SE 5.1
« Reply #5 on: July 13, 2008, 10:00:42 pm »
Hi all and thanks for the help

I managed to get (I think) 4 Channels. So I connected the Side and center (not subwoofer), to the same plug via an adapter. At least I have sound on all speakers now, and I will give up for the moment. Maybe one day I'll buy a speaker system with different connections --> by the way, are all speakers compatible or do I have to make sure in advance? I am thinking about Logitech Z-5500 or Z-5450.

cheers
Roberto

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: How to enable my Creative Sound Blaster Audigy SE 5.1
« Reply #6 on: July 14, 2008, 12:01:07 am »
are you connecting to a digital out - ie SPDIF/TOSLINK, optical or coax? If the source is multichannel encoded with DD or DTS then the chipset should just pass this straight through to the digital out (as well as decode it for multichannel analogue outs).

In alsamixer, can you scroll over to the right and see a IEC958 option? You may need to enable it - actually "unmute" it by pressing 'M' on the keyboard. That should enable the digital stream out. Don't know anything about alsamixer, but I assume that it detects if there is an IEC958 available and only presents it if so. So if you can see it and it is "muted" then that is probably the issue. If it isn't there, then maybe it hasn't detected it? If it is there but unmute does nothing, then I've no idea.....

Col.

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: How to enable my Creative Sound Blaster Audigy SE 5.1
« Reply #7 on: July 22, 2008, 10:54:31 pm »
I followed Colin's advice and now have DD and DTS passthrough working.

I went to the teminal, typed 'alsamixer', used the arrow keys to move to the right and there is a setting called 'IE958 Optical Raw' and 'Audigy Analogue/digital output jack' I unmuted them both and it works.  I don't know if one or the other, or both does it.  but it is now working.

Try that

Thanks Colin!!