Author Topic: Cannot access linuxmce samba shares from XP machines.  (Read 4423 times)

Enigmus

  • Veteran
  • ***
  • Posts: 132
    • View Profile
Re: Cannot access linuxmce samba shares from XP machines.
« Reply #15 on: August 14, 2008, 09:03:43 pm »
Why are you people butchering your setups?!

(1) make sure you have the appropriate network setup, two NIC cards, your core is the center of the network, handling firewall, dhcp, gateway.. make sure your other pc's are on the internal NIC card.

(2) when logging into the dcerouter share, use the username and password you use to log into the web admin

very simple, guys.
stop fucking up your setups.

-Thom


Actually this is a problem for me.  The DCErouter Share does not use the usernames and passwords for Samba Shares by default.  It appears to user Pluto_<Username> and the passwords are unset.  I have to manually set the password with smbpasswd.  When any of the LinuxMCE systems restart I have to reset the passwords.  Does anyone know how to correct this?  I'm using .710 64bit on the core.  Thanks.

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Cannot access linuxmce samba shares from XP machines.
« Reply #16 on: August 15, 2008, 01:04:11 am »
No you don't need to do that. If you have done it, then Windows is probably remembering something. Delete any shares you have connected to (even ones that don't have a drive letter associated with them). Make sure your PCs are in the LinuxMCE workgroup and reboot. Then just browse through Network Neighbourhood down until you get to the LinuxMCE workgroup, expand that and you will see all the shares, expand them, etc, etc....

Enigmus

  • Veteran
  • ***
  • Posts: 132
    • View Profile
Re: Cannot access linuxmce samba shares from XP machines.
« Reply #17 on: August 15, 2008, 05:46:54 pm »
Ok, and I use <username> rather then Pluto_<Username>?

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Cannot access linuxmce samba shares from XP machines.
« Reply #18 on: August 15, 2008, 11:19:52 pm »
I have never been prompted for user name and password for the samba shares, I just browse straight in, no problem. I assumed that was normal.

Enigmus

  • Veteran
  • ***
  • Posts: 132
    • View Profile
Re: Cannot access linuxmce samba shares from XP machines.
« Reply #19 on: August 18, 2008, 10:08:09 pm »
BTW, Thank you for lending me a hand on this Colin.

Can you think of anything else that you do differently on your setup?  I am still having the same issues.  This is what I have done.  I have changed the Workgroup on my XP system to linuxmce and I have attempted to access shares on the Core system.  It still does not let me connect without a username or password and it does not respond to either my <username> or Pluto_<Username> without me setting the smbpasswd on the core system.  The password clears every time the core or any of the diskless MDs restarts.

If anyone has any suggestions, I'm open to them. :)

Thanks.

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Cannot access linuxmce samba shares from XP machines.
« Reply #20 on: August 18, 2008, 10:49:57 pm »
Sorry, haven't really done anything in that space, and my password for Windows is different than LMCE, although the username is the same "colin", seems unlikely but Windows sometimes tries to authenticate as the "current user", if LMCE doesn't require the password to match due to some weird permissions (something similar happens accessing XP's shares) then perhaps that's how mine is getting it - but seems a very long shot! Windows firewall isn't on is it?

rodercot

  • Guest
Re: Cannot access linuxmce samba shares from XP machines.
« Reply #21 on: August 19, 2008, 12:01:07 pm »
 When I access any windows machine with an lmce share THAT IS NOT dcerouter (core) on windows, I need no password if I access the dcerouter computer share from windows for the first time in a session windows asks for a user and pass - This is the password that lmce gave you for accessing your private directories, webadmin, phone messages etc.. It works everytime I use it but only need once per reboot on the windows machine and only if I access the core computer share(dcerouter) Which I hardly EVER do from within windows, I usually use a putty for this.

 All my pc's and xbox's and Blu-Ray LG BH200 drive are on the internal network with one laptop on the external.

 rgds,

 Dave

Enigmus

  • Veteran
  • ***
  • Posts: 132
    • View Profile
Re: Cannot access linuxmce samba shares from XP machines.
« Reply #22 on: August 21, 2008, 11:58:16 am »
Rodercot,

  Your talking about the default samba user not any user you created, right?

Enigmus

  • Veteran
  • ***
  • Posts: 132
    • View Profile
Re: Cannot access linuxmce samba shares from XP machines.
« Reply #23 on: December 29, 2008, 04:59:48 pm »
Ok, for anyone interested I have resolved my issue.  Apparently, the SMB/CIFs part of the linuxmce does not like special characters in passwords.  If you use a password with special characters (like: #$%^&*@!) it will work in the web interface and everywhere else except with the SMB/CIFs shares.  Simply changing the password in Linuxmce and on your windows system to simple alpha numerical characters will solve the issue.