Author Topic: VDR - DVB-T and multichannel/surround sound??  (Read 868 times)

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
VDR - DVB-T and multichannel/surround sound??
« on: July 11, 2008, 03:49:41 am »
Is VDR currently set up to pass through surround sound (SPDIF)?

I never get anything other than stereo - although I know some of the transmissions (esp the HD AC3 ones) must have multichannel. I get full 5.1 from DVDs and some BT downloads, just not from VDR watching TV. I have played with the sound options in xineliboutput and cranked it up from the default Stereo 2.0 to 5.1, choosen upmix, disabled downmix and it doesn't seem to do anything.

Interestingly, on the few occasions I have used VDR to record TV, I seem to have hit some transmissions that have more than 2 channels and it seems to play them fine, just not for live TV....

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: VDR - DVB-T and multichannel/surround sound??
« Reply #1 on: August 21, 2008, 12:34:07 pm »
Hi,

have not yet got an installation of linuxmce (only did some testing in vmware) so I am not sure if it helps ...

In a normal VDR you have to set an Option in the VDR settings to get Dolby Digital with LiveTV.  Should be some thing like "Use Dolbydigital" = yes

Greetings
Christian

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: VDR - DVB-T and multichannel/surround sound??
« Reply #2 on: August 21, 2008, 01:57:50 pm »
Christian - in my /etc/vdr/setup.conf the usedolbydigital is set to 1, so I guess it is on.... can't work out whether there is something else that I need to switch.... maybe in xineliboutput..?

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4527
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: VDR - DVB-T and multichannel/surround sound??
« Reply #3 on: August 21, 2008, 09:57:18 pm »
Christian - in my /etc/vdr/setup.conf the usedolbydigital is set to 1, so I guess it is on.... can't work out whether there is something else that I need to switch.... maybe in xineliboutput..?

Hmmm... if you have a dolby digital surround enabled transmission it should be working... I'll see if i can test that tomorrow though

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Smart Home consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk