Author Topic: VDR stability / 0710RC2  (Read 865 times)

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
VDR stability / 0710RC2
« on: July 10, 2008, 06:38:05 am »
Hi all (Andrew!)

Just wanted to report my recent experiences with VDR under RC2. I was having problems with it for a while, but thought it was just down to a dodgy install. I have just rebuild the core clean, and I am seeing the same problems as the previous build. I didn't use to get this prior to RC2.

1. Occasionally, when changing channels with up/down, the screen will suddenly go black (no sound) instead of selecting the next channel and do nothing. I have to hit Stop, and then TV again and off it goes again. If I just try to change channels, the OSD indicates that it is doing so, but the screen stays black.

2. Sometimes, when I hit menu or channel up/down, it takes a very long time to respond. Sometimes 3-4 seconds, sometimes 10-15 seconds. From there it may return to normal speed, or it may continue being sluggish and then eventually come good. Next time I pick up the remote it does the same again, or sometimes it will be perfectly normal. It seems to queue the button presses so if you keep pressing it will often go nuts when it finally does wake up.

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4660
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: VDR stability / 0710RC2
« Reply #1 on: July 10, 2008, 09:35:15 am »
Hi all (Andrew!)

Just wanted to report my recent experiences with VDR under RC2. I was having problems with it for a while, but thought it was just down to a dodgy install. I have just rebuild the core clean, and I am seeing the same problems as the previous build. I didn't use to get this prior to RC2.

1. Occasionally, when changing channels with up/down, the screen will suddenly go black (no sound) instead of selecting the next channel and do nothing. I have to hit Stop, and then TV again and off it goes again. If I just try to change channels, the OSD indicates that it is doing so, but the screen stays black.

2. Sometimes, when I hit menu or channel up/down, it takes a very long time to respond. Sometimes 3-4 seconds, sometimes 10-15 seconds. From there it may return to normal speed, or it may continue being sluggish and then eventually come good. Next time I pick up the remote it does the same again, or sometimes it will be perfectly normal. It seems to queue the button presses so if you keep pressing it will often go nuts when it finally does wake up.

Thanks for the feedback Colin. These and a number of other less visible bugs are being (or have been) fixed now. These are not actually bugs inside the vdr (that has to be one of the most stable pieces of software I have ever used!) but in the code that acts as the glue between DCErouter/Appserver and vdr.

Anyway we do hope to have an update for these issues shortly.

All the best

Andrew
Andy Herron,
CHT Ltd

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, totallymaxed+inquiries@gmail.com via email or PM me here.

Get Dianemo-Rpi2 ARM Licenses http://forum.linuxmce.org/index.php?topic=14026.0

Get RaspSqueeze-CEC or Raspbmc-CEC for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: VDR stability / 0710RC2
« Reply #2 on: July 10, 2008, 02:13:58 pm »
Cool! I'm very glad you recognised them, I was expecting to be the only one who'd ever experienced them (...again!) don't suppose any of these updates are already on charon/linuxmce that I could try out? (TV'd broke, in trouble again :) )