Author Topic: WOL not possible for hybrid?  (Read 1294 times)

roberto99

  • Veteran
  • ***
  • Posts: 101
  • ...dreams of becoming a LMCExpert
    • View Profile
WOL not possible for hybrid?
« on: July 09, 2008, 09:58:43 pm »
Hi all

I today tried to wol (wake on lane) my hybrid from my ipcop firewall with wake-on-lane and from a linux machine with etherwake, but it did not work. In the bios of the hybrid mb the boot rom is enabled and wake up from pci/pcie events is enabled as well. I tried with the mac of both nics. Its an Asus P5N32-E SLI Plus motherboard.

what could be the problem? is the problem that it is a hybrid? wol from my ipcop firewall otherwise works fine for other machines on the lan

Maybe i do have to modify something in the nic properties under kde desktop? i could not find any settings corresponding to wol.

thanks
Roberto

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5505
  • DOES work for LinuxMCE.
    • View Profile
Re: WOL not possible for hybrid?
« Reply #1 on: July 09, 2008, 09:59:38 pm »
nforce's network chips have a weird bug in which the MAC address expected for the wake-on-lan is actually inverted.. it's a hardware bug.

-Thom

roberto99

  • Veteran
  • ***
  • Posts: 101
  • ...dreams of becoming a LMCExpert
    • View Profile
Re: WOL not possible for hybrid?
« Reply #2 on: July 09, 2008, 10:01:13 pm »
Hi tschak909

Inverted exactly 100% ? from for example 11:44:DD:55:66 i have to input 66:55:DD:44:11 ?
thanks
Roberto

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5505
  • DOES work for LinuxMCE.
    • View Profile
Re: WOL not possible for hybrid?
« Reply #3 on: July 09, 2008, 10:16:37 pm »
I believe so. Hari was talking to me about this at LinuxTag.

-Thom

roberto99

  • Veteran
  • ***
  • Posts: 101
  • ...dreams of becoming a LMCExpert
    • View Profile
Re: WOL not possible for hybrid?
« Reply #4 on: July 09, 2008, 10:32:58 pm »
no, it does not work what ever i trie.
so should it be possible to wol a hybrid/core anyway?
thanks
roberto

roberto99

  • Veteran
  • ***
  • Posts: 101
  • ...dreams of becoming a LMCExpert
    • View Profile
Re: WOL not possible for hybrid?
« Reply #5 on: July 09, 2008, 10:54:22 pm »
i really feel one should first enable wol in the network settings under kde, but can not find anything.
i know for example that on suse linux you have to do additional changes
again: maybe it is not possible to wol a hybrid/core but only a MD
any ideas?
Roberto

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: WOL not possible for hybrid?
« Reply #6 on: July 09, 2008, 11:18:35 pm »
WOL is ethernet not IP so there is no point trying to send to your internal interface from your external LAN or vice versa. Try sending from internal to internal (in case the FW is disabling it)

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: WOL not possible for hybrid?
« Reply #7 on: July 09, 2008, 11:56:15 pm »
You may also need to enable it in your motherboard's bios.
"Change is inevitable. Progress is optional."
-- Anonymous


PeteK

  • Guru
  • ****
  • Posts: 408
    • View Profile
Re: WOL not possible for hybrid?
« Reply #8 on: July 10, 2008, 06:06:23 pm »
I had a similar issue with an nforce2 chipset-based motherboard.  It would WOL succesfully if I shut down from Windows and attempted to WOL.  However, it would not WOL after being shut down from Linux (LMCE).

I believe the issue is similar to this:
http://linux.derkeiler.com/Mailing-Lists/Fedora/2007-07/msg00217.html

I'm using two Abit AN-M2HDs currently, and they're both working fine with no modifications.