Author Topic: Music indexing very slow  (Read 1494 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Music indexing very slow
« on: January 11, 2006, 09:06:38 pm »
I have a large music collection samba-mounted under /home/public/data/music. When I rebooted last night, Pluto (2.0.0.34) ran some sort of upgrade script, migrating the database etc.

Then it started on what looks like indexing the entire music collection. It started off doing this pretty quickly, but at some point progress because VERY slow (limit of physical memory?). I have a large collection (maybe 70Gb) and have had trouble in the past when media players try to index. I wasn't given the option not to perform it.

So it's still running, and at this rate (one track every minute or so) it's going to take weeks. How do I stop it gracefully and/or run it in the background as the server is useless while it's in this state.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Music indexing very slow
« Reply #1 on: January 12, 2006, 11:48:04 am »
Hi,

First time when sytem boots up, the whole /home/public/data is (re)indexed. If the user has many many files, this could be an issue indeed. So I think we'll add an option in website to enable/disable this.

However, it's very strange why it's running so slow ("one track every minute or so") and I would like to take a look at your system. Can you enable please remote access on your computer (go to pluto-admin website to wizard->security->outside access) and send me a private message with the installation number and password ?

Thanks,
Chris M.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Resources
« Reply #2 on: January 14, 2006, 02:22:20 pm »
I think this was indeed to do with resources. It ran faster and actually seemed to complete overnight, but now mysqld just falls over with an out of memory error on startup.

How can I clean up the pluto_media tables?

Thanks,
James

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Music indexing very slow
« Reply #3 on: January 16, 2006, 08:45:18 am »
Hi,

There are two things you can do.
To disable UpdateMedia (the application which indexes your media everytime you reboot), you'll have to go with mysql in pluto_main database and find in the table StartupScript a record with Command = "UpdateMediaDaemon.sh". Delete that record.

The mysql error is very weird, because mysql should be able to store millions of records. You can cleanup pluto_media running these sql queries:
Code: newbielink:javascript:void(0); [nonactive]
DELETE FROM File;
DELETE FROM File_Attribute;
DELETE FROM Attribute;
DELETE FROM SearchToken;
DELETE FROM SearchToken_Attribute;

However, we would like to see what's exactly wrong there, so please don't forget to send me a private message with your password for remote access. Also be sure you have no external firewall blocking 24388 and 24389 ports.

Regards,
Chris M.