Author Topic: (Solved) I think. Media Files Sync will not refesh or update.  (Read 9477 times)

jondecker76

  • Alumni
  • wants to work for LinuxMCE
  • *
  • Posts: 763
    • View Profile
Re: Media Files Sync will not refesh or update.
« Reply #30 on: July 10, 2008, 07:30:34 pm »
the one with spaces won't run because of the shell, not because of mediaUpdate.. Place the path in quotes and try it again. If it runs fine from here, it should be running fine from the web admin.
« Last Edit: July 10, 2008, 07:45:45 pm by jondecker76 »

rodercot

  • Guest
Re: Media Files Sync will not refesh or update.
« Reply #31 on: July 10, 2008, 07:45:51 pm »
THX JON. Yes they seem to update quickly this way from the command line as instructed. Here is the same one in quotes.

 
Code: [Select]
linuxmce@dcerouter:~$ sudo /usr/pluto/bin/UpdateMedia -d "/home/public/data/other/Windows Share-disk1 [49]/Movies1/American Wedding"
10      07/10/08 13:41:56.767           Activating Pluto Media Identifier... <0xb6a776c0>
10      07/10/08 13:41:56.768           Pluto Media Identifier activated. Extensions 27 <0xb6a776c0>
10      07/10/08 13:41:56.769           MediaState::LoadDbInfo ready to run big query <0xb6a776c0>
10      07/10/08 13:41:56.773           MediaState::LoadDbInfo got 1 rows <0xb6a776c0>
10      07/10/08 13:41:56.773           UpdateMedia::ReadDirectory /home/public/data/other/Windows Share-disk1 [49]/Movies1/American Wedding <0xb6a776c0>
10      07/10/08 13:41:57.829           UpdateMedia::ScanSubfolders dir /home/public/data/other/Windows Share-disk1 [49]/Movies1/American Wedding: subdirs found: 2 <0xb6a776c0>
10      07/10/08 13:41:57.829           '/home/public/data/other/Windows Share-disk1 [49]/Movies1/American Wedding' is a ripped dvd <0xb6a776c0>
10      07/10/08 13:41:57.928           Need to update file for /home/public/data/other/Windows Share-disk1 [49]/Movies1/American Wedding: current attr date 2008-07-06 13:21:17, has attr 1 <0xb6a776c0>
10      07/10/08 13:41:57.929           Sync mode for dir /home/public/data/other/Windows Share-disk1 [49]/Movies1/American Wedding: modeBoth <0xb6a776c0>
05      07/10/08 13:41:57.929           # PlutoMediaFile STARTED: dir /home/public/data/other/Windows Share-disk1 [49]/Movies1 file American Wedding <0xb6a776c0>
10      07/10/08 13:41:57.929           # ID3FileHandler::LoadAttributes: loading 0 attributes in the attribute file /home/public/data/other/Windows Share-disk1 [49]/Movies1/American Wedding/American Wedding.id3 <0xb6a776c0>
10      07/10/08 13:41:58.230           Serialize read bookmarks: 0 <0xb6a776c0>
10      07/10/08 13:41:58.230           # LoadPlutoAttributes: pluto attributes loaded (from id3 file - general object tag) 11 <0xb6a776c0>
=== GEOB (General encapsulated object): ()[]: , 1527 bytes
=== TPE1 (Lead performer(s)/Soloist(s)): Seann William Scott
=== TIT2 (Title/songname/content description): American Wedding (Full Screen Edition)
=== APIC (Attached picture): ()[, 0]: , 43199 bytes
10      07/10/08 13:41:58.431           # LoadPlutoAttributes: id3 attributes loaded (from id3 file - common tags) 3 <0xb6a776c0>
10      07/10/08 13:41:58.431           MergePictures: merging 0 pictures from our tag with 1 pictures from PIC tags <0xb6a776c0>
10      07/10/08 13:41:58.432           LoadPlutoAttributes: loading picture with size 43199 from PIC tag - md5sum bcb47226be62b5c722b82cba61a28ecb <0xb6a776c0>
10      07/10/08 13:41:58.432           Processing path /home/public/data/other/Windows Share-disk1 [49]/Movies1, file American Wedding. Found 11 attributes, 1 long attributes in file <0xb6a776c0>
10      07/10/08 13:41:58.433           SetFileAttribute /home/public/data/other/Windows Share-disk1 [49]/Movies1/American Wedding 1121 <0xb6a776c0>
10      07/10/08 13:41:58.433           Attr in db : type 31            value NTSC <0xb6a776c0>
10      07/10/08 13:41:58.433           Attr in db : type 31            value AC-3 <0xb6a776c0>
10      07/10/08 13:41:58.433           Attr in db : type 17            value Universal Studios <0xb6a776c0>
10      07/10/08 13:41:58.433           Attr in db : type 2             value Seann William Scott <0xb6a776c0>
10      07/10/08 13:41:58.433           Attr in db : type 2             value Jason Biggs <0xb6a776c0>
10      07/10/08 13:41:58.433           Attr in db : type 2             value Alyson Hannigan <0xb6a776c0>
10      07/10/08 13:41:58.433           Attr in db : type 2             value Eddie Kaye Thomas <0xb6a776c0>
10      07/10/08 13:41:58.433           Attr in db : type 2             value Thomas Ian Nicholas <0xb6a776c0>
10      07/10/08 13:41:58.433           Attr in db : type 13            value American Wedding (Full Screen Edition) <0xb6a776c0>
10      07/10/08 13:41:58.433           # LoadPlutoAttributes: pluto attributes merged with those from database 11 <0xb6a776c0>
10      07/10/08 13:41:58.433           Long attribute in db : type 37          value Pie movies pushed their luck with a third slice of their lucrative raunchy comedy franchise, and American Wedding cooked up surprisingly well. It's the sourest serving of Pie, with half of the original cast missing, and there's something undeniably desperate about comedic highlights (involving dog poop, a lusty old lady, two strippers to offset the absence of Shannon Elizabeth, and the ill-advised use of a trimming razor) that arise more from obligation than inspiration, on the assumption that another penile mishap is guaranteed to please. And yet, that's just what this movie does for devoted Pie-munchers: It gives 'em what they want, especially when the notorious Stifler (Seann William Scott) nearly ruins the frantic nuptials of Jim (Jason Biggs) and his band-camping sweetheart Michelle (Alyson Hannigan). Eugene Levy and Eddie Kaye Thomas also return for some reliable comic relief, but the one who's laughing most is three-time Pie writer Adam Herz--laughing loudly and often, all the way to the bank. --Jeff Shannon... <0xb6a776c0>
10      07/10/08 13:41:58.433           # LoadPlutoAttributes: pluto long attributes merged with those from database 1 <0xb6a776c0>
10      07/10/08 13:41:58.434           LoadCoverarts: loaded 1 unique pictures from file <0xb6a776c0>
10      07/10/08 13:41:58.435           LoadCoverarts: not loading picture with size 43199 from database, because we already have it in file - md5sum bcb47226be62b5c722b82cba61a28ecb <0xb6a776c0>
10      07/10/08 13:41:58.435           LoadBookmarkPictures: clear bookmarks from file.We'll use those from db: 0 <0xb6a776c0>
10      07/10/08 13:41:58.435           # SaveMiscInfo: FK_FileFormat 2, FK_MediaSubType 2 <0xb6a776c0>
10      07/10/08 13:41:58.435           File 1121 has now media type 3 <0xb6a776c0>
10      07/10/08 13:41:58.435           # GetPicAttribute: file 1121 <0xb6a776c0>
10      07/10/08 13:41:58.436           Found 1 pics for file <0xb6a776c0>
10      07/10/08 13:41:58.436           # GetPicAttribute: got picture 218 associated to file 1121 <0xb6a776c0>
10      07/10/08 13:41:58.436           SetPicAttribute /home/public/data/other/Windows Share-disk1 [49]/Movies1/American Wedding PK_Picture 218 <0xb6a776c0>
10      07/10/08 13:41:58.436           SetPicAttribute /home/public/data/other/Windows Share-disk1 [49]/Movies1/American Wedding PK_Picture 218 <0xb6a776c0>
10      07/10/08 13:41:58.436           # GetPicAttribute: file 1121 <0xb6a776c0>
10      07/10/08 13:41:58.436           Found 1 pics for file <0xb6a776c0>
10      07/10/08 13:41:58.436           # GetPicAttribute: got picture 218 associated to file 1121 <0xb6a776c0>
10      07/10/08 13:41:58.436           SetPicAttribute /home/public/data/other/Windows Share-disk1 [49]/Movies1/American Wedding PK_Picture 218 <0xb6a776c0>
10      07/10/08 13:41:58.571           # ID3FileHandler::SaveAttributes: saving 11 attributes in the attribute file /home/public/data/other/Windows Share-disk1 [49]/Movies1/American Wedding/American Wedding.id3 <0xb6a776c0>
05      07/10/08 13:41:58.571           # ID3FileHandler::SaveAttributes: saving 1 pictures into APIC tags to /home/public/data/other/Windows Share-disk1 [49]/Movies1/American Wedding/American Wedding.id3 <0xb6a776c0>
10      07/10/08 13:41:58.571           # ID3FileHandler::SaveAttributes: saving into APIC picture size 43199 <0xb6a776c0>
Writing: PK_Attr = -1000                ()[]:
Don't know yet how to save tag with PK_Attr = -1000 and value ()[]:
Writing: PK_Attr = 2            Seann William Scott
Writing: PK_Attr = 13           American Wedding (Full Screen Edition)
Writing: PK_Attr = 17           Universal Studios
Don't know yet how to save tag with PK_Attr = 17 and value Universal Studios
Writing: PK_Attr = 31           AC-3
Don't know yet how to save tag with PK_Attr = 31 and value AC-3
10      07/10/08 13:41:59.184           Serialize write bookmarks: 0 <0xb6a776c0>
10      07/10/08 13:42:00.088           # SyncDbAttributes: ready to sync db with attributes found in attribute file <0xb6a776c0>
10      07/10/08 13:42:00.088           # SyncDbAttributes: attributes is db 9, total 11 <0xb6a776c0>
10      07/10/08 13:42:00.088           # SyncDbAttributes: long attributes is db 1, total 1 <0xb6a776c0>
10      07/10/08 13:42:00.089           SaveCoverarts: got 1 coverarts in db. Merging with 1 from file <0xb6a776c0>
10      07/10/08 13:42:00.089           SaveCoverarts: not adding picture with size 43199, md5sum bcb47226be62b5c722b82cba61a28ecb since is already in db <0xb6a776c0>
10      07/10/08 13:42:00.089           # SaveMiscInfo: FK_FileFormat 2, FK_MediaSubType 2 <0xb6a776c0>
10      07/10/08 13:42:00.090           File /home/public/data/other/Windows Share-disk1 [49]/Movies1/American Wedding, PK_File 1121 - midmd5 is d41d8cd98f00b204e9800998ecf8427e <0xb6a776c0>
Mapped file /mnt/device/49 : 25 -> 49
Mapped file /mnt/device/55 : 33 -> 55
10      07/10/08 13:42:00.137           File /home/public/data/other/Windows Share-disk1 [49]/Movies1/American Wedding on pluto device 49 <0xb6a776c0>
10      07/10/08 13:42:00.137           File /home/public/data/other/Windows Share-disk1 [49]/Movies1/American Wedding assigned to user 0 <0xb6a776c0>
10      07/10/08 13:42:00.195           # PlutoMediaFile ENDED: dir /home/public/data/other/Windows Share-disk1 [49]/Movies1 file American Wedding, sync mode modeBoth <0xb6a776c0>
10      07/10/08 13:42:00.195           Sync'ing db with directory... <0xb6a776c0>
10      07/10/08 13:42:00.196           DB sync'd with directory! <0xb6a776c0>
10      07/10/08 13:42:00.197           AlarmManager::~AlarmManager start 0x80c4258 <0xb6a776c0>
10      07/10/08 13:42:00.197           AlarmManager::~AlarmManager done 0x80c4258 <0xb6a776c0>
linuxmce@dcerouter:~$

 Dave

jondecker76

  • Alumni
  • wants to work for LinuxMCE
  • *
  • Posts: 763
    • View Profile
Re: Media Files Sync will not refesh or update.
« Reply #32 on: July 10, 2008, 07:55:59 pm »
if you are comfortable modifying the web admin .php source code, the next step would be to comment out where updateMedia is called...

ssh into the core.. then change to the directory where the web admin page is stored..

cd /var/www/pluto-admin/operations/mediaBrowser

then, you need to edit editMediaFile.php (if you're doing it from the command line, you'll probably have to use Vim, also remember you must be root)

sudo vim editMediaFile.php

now, towards the bottom (about a few pages up from the bottom or so), you'll see
Code: [Select]
if(isset($_POST['update'])){
$type=(int)$_POST['type'];
$subtype=(int)$_POST['subtype'];
$subtype=($subtype==0)?NULL:$subtype;
$fileFormat=(int)$_POST['fileFormat'];
$fileFormat=($fileFormat==0)?NULL:$fileFormat;

if(file_exists($oldFilePath)){
if($path==$oldPath){
if($fileName!=$oldFilename){
$isRenamed=web_rename($oldFilePath,$newFilePath);
$error=($isRenamed==0)?'Rename failed':'';
}
}
else{
copy($oldFilePath,$newFilePath);
exec_batch_command('sudo -u root rm -f "'.bash_escape($oldFilePath).'"');
}
}
$mediadbADO->Execute('UPDATE File SET Filename=?, Path=?, EK_MediaType=?,FK_MediaSubType=?,FK_FileFormat=? WHERE PK_File=?',array($fileName,$path,$type,$subtype,$fileFormat,$fileID));

// update pics urls
$picsArray=explode(',',$_POST['picsArray']);
foreach ($picsArray AS $pic){
$picUrl=cleanString(@$_POST['url_'.$pic]);
$mediadbADO->Execute('UPDATE Picture SET URL=? WHERE PK_Picture=?',array($picUrl,$pic));
}

$cmd='sudo -u root /usr/pluto/bin/UpdateMedia -d "'.bash_escape($path).'"';
exec_batch_command($cmd);
header('Location: index.php?section=editMediaFile&fileID='.$fileID.'&msg='.$TEXT_MEDIA_FILE_UPDATED_CONST.'&err='.@$error);
exit();
}

the line... "exec_batch_command($cmd)" is what is calling UpdateMedia... simply comment it out (with //) so that you have:
Code: [Select]
if(isset($_POST['update'])){
$type=(int)$_POST['type'];
$subtype=(int)$_POST['subtype'];
$subtype=($subtype==0)?NULL:$subtype;
$fileFormat=(int)$_POST['fileFormat'];
$fileFormat=($fileFormat==0)?NULL:$fileFormat;

if(file_exists($oldFilePath)){
if($path==$oldPath){
if($fileName!=$oldFilename){
$isRenamed=web_rename($oldFilePath,$newFilePath);
$error=($isRenamed==0)?'Rename failed':'';
}
}
else{
copy($oldFilePath,$newFilePath);
exec_batch_command('sudo -u root rm -f "'.bash_escape($oldFilePath).'"');
}
}
$mediadbADO->Execute('UPDATE File SET Filename=?, Path=?, EK_MediaType=?,FK_MediaSubType=?,FK_FileFormat=? WHERE PK_File=?',array($fileName,$path,$type,$subtype,$fileFormat,$fileID));

// update pics urls
$picsArray=explode(',',$_POST['picsArray']);
foreach ($picsArray AS $pic){
$picUrl=cleanString(@$_POST['url_'.$pic]);
$mediadbADO->Execute('UPDATE Picture SET URL=? WHERE PK_Picture=?',array($picUrl,$pic));
}

$cmd='sudo -u root /usr/pluto/bin/UpdateMedia -d "'.bash_escape($path).'"';
//exec_batch_command($cmd);
header('Location: index.php?section=editMediaFile&fileID='.$fileID.'&msg='.$TEXT_MEDIA_FILE_UPDATED_CONST.'&err='.@$error);
exit();
}


and now it won't be automatically executed. Save the file, then try to reproduce the bug again by changing the media type from the web admin.. if it still hangs, then UpdateMedia and/or exec_batch_command is not resoponsible, and we can look elsewhere...

(A few notes on VIM - if you've never used it, it can be daunting.. Look up how to use it online if you have to. The basics are, use your arrow keys and find the line to change. Press "I" to go into insert (edit) mode. You can now make your changes. When finished, hit esc to get out of insert mode. type :w to save (colon folowed by a w), the :q to quit...)
« Last Edit: July 10, 2008, 08:03:11 pm by jondecker76 »

rodercot

  • Guest
Re: Media Files Sync will not refesh or update.
« Reply #33 on: July 10, 2008, 08:56:35 pm »
Hi Jon,

 Ok! tried that same issues still. I let the file run for 5 minutes after clicking update with no refresh. did I need to reboot the core at all. I did not. I edited the file, saved it. tried the webadmin and no luck so changed the file back.

 Thanks,

 Dave

jondecker76

  • Alumni
  • wants to work for LinuxMCE
  • *
  • Posts: 763
    • View Profile
Re: Media Files Sync will not refesh or update.
« Reply #34 on: July 10, 2008, 08:59:02 pm »
ok, at least we narrowed it down that much.. No, you did not have to reboot...

What browser are you using? Have you tried the web admin from any other browsers or computers?

rodercot

  • Guest
Re: Media Files Sync will not refesh or update.
« Reply #35 on: July 10, 2008, 09:28:36 pm »

 Here is the list.
 
 IE7 - on my XP MCE SP2 roll up 2 workstation - Int. and Ext.
 Firefox on Gutsy 7.10 Internal
 KDE - firefox - On core
 Pluto-Admin - from Computing Selection on core, I guess the same as FF on KDE
 IE6 and then 7 on XPSP2 Laptop from External Lan.

 I am now going through every disk share and every file to see if there is any cover art doubles or some file type or media sub-type would be set weird. It may not be a fix at all but at least I'll have piece of mind that the files are all set up correctly.

 thanks for your help.

 Dave

royw

  • Guru
  • ****
  • Posts: 261
    • View Profile
Re: Media Files Sync will not refesh or update.
« Reply #36 on: July 10, 2008, 11:52:02 pm »
Anything in /var/log/apache2/error.log?


rodercot

  • Guest
Re: Media Files Sync will not refesh or update.
« Reply #37 on: July 10, 2008, 11:56:07 pm »
Roy,

 You read my mind. I was just looking at it. I am not really sure what I am looking at though. I see a ton of errors where it is looking the /var directory for fav.ico file on a ip address that my system does not have. Can I e-mail you the file? PM me.

 THX,

 Dave

royw

  • Guru
  • ****
  • Posts: 261
    • View Profile
Re: Media Files Sync will not refesh or update.
« Reply #38 on: July 11, 2008, 05:43:02 am »
To stop all of the favicon.ico missing errors, you just need to install a favicon.ico.  Two ways.  First way is to copy the blank one from LinuxMCE wiki (if you are using firefox 3, goto wiki, right click on a page, View Page Info, Media, select favicon.ico and save) to dcerouter:/var/www/localhost/htdocs.  The second is reportedly (I haven't tried it) to simply touch /var/www/localhost/htdocs.

To ignore these messages when viewing a log, do an invert match with grep like: grep -v favicon | less

HTH,
Roy

rodercot

  • Guest
Re: Media Files Sync will not refesh or update.
« Reply #39 on: July 11, 2008, 12:31:32 pm »
Roy,

 I do not have that directory to save the ico file into. The error log is looking in var/www. Do I create that directory.

 rgds,

 Dave

rodercot

  • Guest
Re: Media Files Sync will not refesh or update.
« Reply #40 on: July 11, 2008, 06:01:27 pm »
Well I decided to reinstall after all the playing around I lost or badly degraded dvd playback from the server for some reason. Anyhow It is reinstalled now, I reinstalled got all my a/v devices setup and then plugged in the internal lan cable and let it detect all the computers again and it did fine so far, it is updating media now. So I will let it run and see how it progresses.

 thanks for all the assistance with this problem, I am not sure still if this is going to solve it as this is what I did on Sunday anyhow, except this time I obviously did not get the bad mac address for the file server as it was already changed.

 later,

 Dave

royw

  • Guru
  • ****
  • Posts: 261
    • View Profile
Re: Media Files Sync will not refesh or update.
« Reply #41 on: July 11, 2008, 08:32:13 pm »
My bad, mixing up systems in my head.  The favicon.ico would need to go in /var/www

Just FYI, if you look in /etc/apache2/sites-enabled then you can find the DocumentRoot in the file pluto.  The favicon.ico needs to be in the DocumentRoot.
Code: [Select]
linuxmce@dcerouter:/etc/apache2/sites-enabled$ grep DocumentRoot *
pluto:  DocumentRoot /var/www/

I think the reinstall was a good decision.  Hopefully it will work this time.

Have fun,
Roy

rodercot

  • Guest
Re: Media Files Sync will not refesh or update.
« Reply #42 on: July 11, 2008, 10:45:57 pm »
Well No Luck, I just got home and the server has been syncing with the db since my post this morning. It has only sync'd three out of 10 drives, it did sync the first three fairly quickly so I though I was on the road to recovery. I also tried a couple of updates on some files that were on drives that had been sync'd and no dice, same ole back to a 2 hour update.

 So to me there is something being left on the server in one of the id3 files between installs is all I can see. It picked the server up at 80.2 right away when it found it. I am at a lost now. I am not going to go through 900 files and delete id3 files and then reinstall again. There is a brand new board in that server and I have ran a couple parity checks on it since this issue has occured and it returns zero errors, no sync errors as well as no read and write errors.

 Regards,

 Dave

rodercot

  • Guest
Re: Media Files Sync will not refesh or update.
« Reply #43 on: July 12, 2008, 02:31:28 pm »
I just did a clean install on a total other machine, figuring maybe it was something in the Marvell chipset on the other system. No dice. This new system only has one nic, so I installed a realteck 1gb pci nic as the other. I used the realtek as the ext and the marvell on board as the internal but did not plug in the internal rj45 until the system was up. I also put the server on another 1gb linksys switch I have as well.

 I do not have any idea where to go from here. Maybe it is something in the way I am installing the system.

 Clean drive - I boot from the DVD let it do it's thing. Then it reboots, loads the av wizard I choose dvi/hdmi at 1080p it loads up 1080p in a 640x480 window then I choose my audio settings and then it starts the launch window which is completely unreadable. I ctl-alt-f2 to a prompt then i do the Nvidia 173.14.09 display driver setup with a telinit 1 when it is complete I reboot from the prompt that shows up after the display driver install.

 It loads up starts the launch window - loads required drivers and then starts the setup wizard I boot to kde and turn on the digital output for audio in the mixer unti I can hear sarah then I reload the router. back to kde and change the audio settings tab to manual settings (Intel HDA ADI1988B codec requirement to pass through properly). Then I complete the setup wizard rooms, users, etc... add no devices at this time, tv etc.. I do those after. Once it has completed the reload, I plug in the internal network cable wait a few minutes and it starts up the detection scripts and finds all my internal computers. It finds the media server -TOWER-TOWER and I choose file server, then it finds the flash which the server boots from I choose ignore always, then it finds the shares and I choose - Windows Share, yes to save files, make public - OK for all 10 drives. Then it sets my other machines up in out of pluto devices range. Then it starts to sync the db with update_media.

 Unless this is an issue with me not letting the first inital load after a/v wizard completes and before I install the NVIDIA driver then I do not know.

 One more THING - Before tried the install on this new machine, I did let the old one find the server again and ignored all drive but drive 1. lmce syn'd disk1 almost immediately and all my media from that drive showed up fine in the UI under all or Movies - DVD but I still had the slow to update/refresh issue in the Webadmin page. Just trying to give you all the info I can supply.

 regards,

 Dave
« Last Edit: July 12, 2008, 04:35:05 pm by rodercot »

rodercot

  • Guest
(SOLVED) I think Re: Media Files Sync will not refesh or update.
« Reply #44 on: July 12, 2008, 05:59:29 pm »
SO MY Setup is like so.

 I have the hybrid in the living room which is about 25' from the server closet in the basement. The house is wired (Cat 5E) via an ONQ panel where all is terminated in the basement and within the server closet. Anyhow, I have a cable going into the hybrid which is from the router (server) closet as well and then a cable for the internal lan feeding back the 25' to the switch 1Gb 8 port linksys Jumbo frames etc... There good one (if they really have a good one) anyhow to fix the problem I installed another 5 port 1gb switch at the hybrid in the living room and ran a shorter cable from the hybrid into the new 5 port switch and then plugged the long run cable into the uplink port on the 5 port and that patches to the 8 port switch in the basement. Well I am not sure if the Marvell chipsets cannot take the long runs but 25' is not that long of a run and I have not had any issues before the pwr outage of a couple months ago, so I am wondering then if lightning or the like actually damaged that cable. I have it working now at least I can update a media file in less than 10 seconds weather I am changing media sub-types or actually deleting a bunch of attributes it is the same 10 seconds.

 Thanks for your patience everyone and the assistance with this issue. I am going to do another clean install on that system right now and I will report back once the media is all updated. This was an expensive fix as well. I have mainly 1tb and 750 drives in that server I speak off I had only a 250gb for the music and a couple other 500gb drives that are fairly old so I replaced them with 750gb thinking that maybe the drives were at fault. That is not an easy task either it takes roughly 8 hours to change one drive and you can only change one at a time. It has to ready the drives with reiserFS and then it formats it and rebuilds the data and then expands the partition for the new free space and then a parity check on a 1Tb parity drive.

 Anyhow,, thanks again.

 I had this question prior on this thread - When adding a new MD with 710rc2 do we still run the setup-diskless md script prior to booting for the first time on that md. I read some post that mentioned it was not necessary from this version and I want to be sure.

 Also - Roy - with that favico.ico issue, I copied that file from the wiki to my desktop - then I opened up dolphin and the /var/www files as root to past the file into that directory. When I ext Dolphin now I get an error that dolphin could not save the bookmark - What am I doing wrong here. I am not sure how to do this from terminal or the prompt.

 onwards and upwards... guys.

 Rgds,

 Dave