Author Topic: VDR deinterlacing  (Read 3473 times)

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
VDR deinterlacing
« on: June 18, 2008, 02:44:19 pm »
I have a "combed" screen when watching TV through VDR. My DVD's play without this, so it must be a VDR deinterlacing problem.

I found the VDR setup.conf in /var/lib/vdr/
Which contains the options: "xineliboutput.video.deinterlace" and "xineliboutput.video.deinterlaceoptions" but I'm not sure what best to set these to (nor the parameters that are accepted)

My video out is dvi to hdmi @ 1080p using UI2 masked
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4437
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: VDR deinterlacing
« Reply #1 on: June 18, 2008, 05:35:46 pm »
I have a "combed" screen when watching TV through VDR. My DVD's play without this, so it must be a VDR deinterlacing problem.

I found the VDR setup.conf in /var/lib/vdr/
Which contains the options: "xineliboutput.video.deinterlace" and "xineliboutput.video.deinterlaceoptions" but I'm not sure what best to set these to (nor the parameters that are accepted)

My video out is dvi to hdmi @ 1080p using UI2 masked

Try adding the following lines to your /var/lib/vdr/setup.conf


xineliboutput.Video.Deinterlace = tvtime
xineliboutput.Video.DeinterlaceOptions = method=Linear,cheap_mode=1,pulldown=none,framerate_mode=full,judder_correction=1,use_progressive_frame_flag=1,chroma_filter=0,enabled=1
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: VDR deinterlacing
« Reply #2 on: June 19, 2008, 01:18:05 am »
Andrew - I have seen this too, and have tried those options (both in the config file, and through the VDR OSD menus) with some good results. However, I have never really been clear on this - I am displaying to a 1080p as well, and some of my TV channels are p, some are i. Obviously only the i exhibits the combing effect on a p screen. So if you set the deinterlacing options on, wouldn't it also try to deinterlace the p channels? If so, wouldn't this reduce/corrupt the quality of those channels? Is there any way of making it selective on channel, or does it auto detect whether the deinterlacing is required?

If it is just on or off, irrespective of channel format - would a feature enhancement of being able to configure per-channel the setting be possible? Or is VDR just configured for one or the other at start up and cannot change?

I'm currious - in the UK are all channels p? Or do you see this issue as well? Do you just turn on deinterlace and deal with the effect on p channels?

Sorry for all the questions!

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: VDR deinterlacing
« Reply #3 on: June 19, 2008, 11:50:46 am »
Those settings worked for me!

Cheers Andrew.

Colin, I am only receiving SD TV channels all of the same format (through a DVB-T card), so cannot comment whether VDR deinterlacing is affected by i or p broadcasts
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: VDR deinterlacing
« Reply #4 on: July 10, 2008, 12:52:24 am »
Just following up on this again with my latest results. After a recent rebuild I noticed that resolution was very poor, esp on SD channels. Very noticable blockiness, that I didn't recall it looking like in the past.

I traced this down to the deinterlace options - although from memory I was using those options previous as they are the ones that Andrew suggested. Anyhow, if I turned off deinterlace - not only does the combing come back, but also the resolution! I have been googling trying to find out more about what each of the options do, but can't find anything - if anyone has a good reference, please let me know!

I tried cheap_mode=2 with uncertain results. Then =0 - big difference! Only then did it become clear how much tvtime seemed to be effecting the frame rate. All of a sudden the video is much smoother. It is still deinterlaced well. The only negative I can see so far is - the compression artifacts are worse giving some pictures a somewhat more "dirty" appearance.

Can someone else try this option and let me know what they think?

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: VDR deinterlacing
« Reply #5 on: July 11, 2008, 10:43:13 am »
Hi colin,

I tried adding the option 0 after cheap mode and it too improved my VDR playback! The de-interlacing is much better than with cheapmode = 1, and the picture matches that from my sky box (both are slightly "dirty" but thats possibly the signal)

what is it that "cheapmode" is supposed to do?
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: VDR deinterlacing
« Reply #6 on: July 12, 2008, 01:01:52 am »
Don't know - keep getting hits on tvtime the program, which I imagine is related but nothing on those options.