Author Topic: How to disable all the X10 Light commands when you Select TV/Video/Etc  (Read 2755 times)

freymann

  • Douchebag
  • Guru
  • *
  • Posts: 380
    • View Profile
One thing that is driving me crazy is the way LMCE has decided to automagically start controlling my lights. If I hit the green media button it seems to be able to turn on my TV in the basement, or my Stereo and TV in the living-room, and that's good.

Then I navigate to Media > TV and various things turn on (or off) and I don't want that to happen, especially in daylight hours. When I stop TV then it flips on all 4 lights in the basement which I definitely don't want.

Where are these triggers configured and how to disable them all?

I much prefer to move about my media and then manage the lights on my own from the Lights menu...

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5499
  • DOES work for LinuxMCE.
    • View Profile
If you have a media director in a room with lights, a scenario called Showtime is created. This scenario is triggered when media is started.. This scenario can be changed. I typically change it to dim my lights to 30%.

When the movie ends, it triggers the On scenario. You can adjust the On scenario to a comfortable light level.

-Thom

freymann

  • Douchebag
  • Guru
  • *
  • Posts: 380
    • View Profile
If you have a media director in a room with lights, a scenario called Showtime is created. This scenario is triggered when media is started.. This scenario can be changed. I typically change it to dim my lights to 30%.

When the movie ends, it triggers the On scenario. You can adjust the On scenario to a comfortable light level.

 I suppose I could make 'showtime' and 'on' lighting scenarios leave everything unchanged.. then I could utilize the TV-Mode and Movie-Mode lighting scenarios I created manually like I want...

 Thanks for the tip!



tschak909

  • LinuxMCE God
  • ****
  • Posts: 5499
  • DOES work for LinuxMCE.
    • View Profile
no, go into Events, and alter the watching/stopped watching media events to not fire the command groups for showtime and on.

-Thom

freymann

  • Douchebag
  • Guru
  • *
  • Posts: 380
    • View Profile
no, go into Events, and alter the watching/stopped watching media events to not fire the command groups for showtime and on.

 Ok, for us "newbies" that would be...

 Automation > Execute scenarios, located up at the top menu bar in the admin panel?

 The click on "Edit"

 What do you change to make it 'not fire' ?

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5499
  • DOES work for LinuxMCE.
    • View Profile
you can delete the event. The event always fires, what you're editing is what happens when that event fires.

-Thom

freymann

  • Douchebag
  • Guru
  • *
  • Posts: 380
    • View Profile
you can delete the event. The event always fires, what you're editing is what happens when that event fires.

 Hi Thom.

 I must be missing something, because I just deleted the ON and SHOWTIME lighting events, rebuilt the orbiter, and they are back.

 That's why I asked what screen to do this on...

 I'm playing with the hybrid/core in the basement, and even after deleting ON and SHOWTIME, it's still flipping lights on and off and I really don't want it doing anything with the lights automatically. I'd much rather do that on my own.

 Could you please be specific as to which area of the admin web I should be in?

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5499
  • DOES work for LinuxMCE.
    • View Profile
oh crap, that's right... UpdateEntArea adds them..... it shouldn't mess with them if they already exist though.

-Thom

jondecker76

  • Alumni
  • wants to work for LinuxMCE
  • *
  • Posts: 763
    • View Profile
Just go to Scenarios -> Lighting scenarios in the web admin and use the lighting wizard to leave all of the lights unchanged.

Another way that should work, while preserving your Showtime and On scenarios (so you can use them manually), would be to go to the web admin,
Advanced->Configuration->Events.
The events you are looking to edit will be 'Watching - Room_Name' and 'Not Watching - Room_Name'. These are the actual events that fire when you start and stop media. If you edit the commands,  you will notice that you have a DCERouter command of Execute Command, with a command Group parameter. That parameter is actually the primary key of your On/Showtime scenarios.
Now, while you are editing, just hit "Remove" to remove the command totally. This will leave you with an empty command list. That is ok, by leaving these Watching and Not Watching events, it will keep UpdateEntArea from trying to re-add these. And at the same time, you will still have a showtime button that will work as it should (when you want it to)
[EDIT - Nope, that doesn't work either - I just tried it. It even rebuilds the whole thing if you just modify the event responses]

Ok some more suggestions... (I won't have time to test these). Try changing your room type. From what I've noticed on my 4-MD setup, the Showtime scenario is only generated in Living Room, Theatre Room, Bedroom and Master Bedroom. Try changing the room type, then deleting the events and/or scenarios you want to get rid of then doing a reload. For example, try changing the room type to Miscellaneous.

Or, go to Scenarios -> Lighting. You will see the auto-generated scenarios at the top of the list for each room. They have check boxes next to each one. Have you tried unchecking the checkboxes to see what happens?

If all fails then a mantis ticket should be in order. While I like how LMCE auto-generates a lot of helpful things, it would be nice to have some kind of control over it. One suggestion for a Mantis Ticket would be to limit the showtime effect to Theatre Room types for example.
One of the methods above should work though. I'd be interested in hearing how you make out on this.
« Last Edit: June 18, 2008, 12:16:35 pm by jondecker76 »

freymann

  • Douchebag
  • Guru
  • *
  • Posts: 380
    • View Profile
Just go to Scenarios -> Lighting scenarios in the web admin and use the lighting wizard to leave all of the lights unchanged.

 In the end, this is what I did.

 Now when I start/stop media, the lights aren't doing weird things for me.

 Anytime I tried to delete or disable, the events 'came back' so just setting the lighting scenario to leave everything alone worked out.


jondecker76

  • Alumni
  • wants to work for LinuxMCE
  • *
  • Posts: 763
    • View Profile
Did you try the checkboxes? If they do indeed disable the auto-generated scenarios, then it will allow you to make your own additional Showtime scenario that will operate like it should when you want it to.

The only think I don't like about just leaving everything unchanged is that you end up with a Showtime scenario on your orbiter that essentiall does nothing

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5499
  • DOES work for LinuxMCE.
    • View Profile
for the record, I rather like the automatic scenarios, and I am doing a whole set of truth tables to do more intelligent scenarios...

-Thom

freymann

  • Douchebag
  • Guru
  • *
  • Posts: 380
    • View Profile
Did you try the checkboxes? If they do indeed disable the auto-generated scenarios, then it will allow you to make your own additional Showtime scenario that will operate like it should when you want it to.

 Hmmm. I do recall unchecking them and rebuilding orbiters...

 I was doing a lot of little things on the system yesterday so I can't remember exactly, but I think even with them unchecked, it would auto fire the events anyway... which led me to just changing the lighting scenarios to leave everything untouched.




freymann

  • Douchebag
  • Guru
  • *
  • Posts: 380
    • View Profile
for the record, I rather like the automatic scenarios, and I am doing a whole set of truth tables to do more intelligent scenarios...

 Hi Thom.

 I think this should be a feature set that can be turned On or Off depending on personal preference.

 Something in the admin control panel where you can say "Use Automatic Lighting Events:  Y/N"

 I find them extremely annoying, especially in the daytime when it turns on the fireplace and the corner table lamp when I start TV. So I use the gyro and navigate to Lights > Off.

 Then when I stop TV, it turns the fireplace and corner table lamp back on, and the floor lamp! So I use the gyro and navigate to Lights > Off.

 Oh, but then I start a Video and the lights change again!

 Can you recognize how annoying that can be? I'd much rather prefer to run the lights by myself. In the daytime, I don't need lights. At night, I can flip on the system and navigate to Lights > "TV Mode" or Lights > "Movie Mode" (which are a couple lighting scenarios I created) as I require, with or without media active.

 I have other problems with these auto-generated events too. For some reason, in the basement, the core keeps shutting my TV off at weird places. Sometimes I just click the gyro mouse and off goes the TV. Or while watching TV, I click the media button and select OFF and not only does it stop watching TV -- it shuts my TV off!

 I'm about ready to remove the TV as a device completely because just like the lights, it might be better to just let me control it. The core is also flipping through the inputs on the TV, for reasons I don't know, since the only thing I use that TV for is LMCE on HDMI, but it likes to turn the TV on and then start hitting the INPUT button. There are about 6 input selections, and it starts hitting INPUT while the TV is in the middle of turning on (at which point the TV doesn't respond to remote key presses) so it leaves me at VIDEO2, forcing me to grab the TV remote and hit INPUT 3 more times to get to HDMI. So I'm either using the TV remote to constantly turn the TV back ON or adjust the INPUT.

 I did edit the TV device template to remove the various Inputs, but that hasn't helped, or else I have to use the ReSync button in the edit A/V Properties area?

 Upstairs, the MD seems to control the TV and Stereo power just fine, at the appropriate times. I like that. It works great!

 I don't know what's up with the core in the basement! HAL is having fun with me! :-)

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5499
  • DOES work for LinuxMCE.
    • View Profile
Yay, another person who says "Let's just add a preference!"

no.

Let's actually try to think things through.

We need to do some serious state table work on the various logic plugins. This will eliminate a lot of the issues that you are seeing. I will not support adding additional UI complexity, just to satisfy the needs of a few people, sorry.

Also, I'm guessing that you have a TV under IR control, with a power toggle, instead of discrete power on/off commands?

guess what?

when you do a quick reload router, the state of all AV devices is reset to assume the device is off, so if you tap the remote, it will think, "Oh, I need to turn on the TV!" and do the power toggle, which...turns the TV off....

Keep this in mind, when you do a quick router reload, turn the TV off...

don't like that? look for a discrete power command, and implement it.

Seek to understand WHY the system is acting like this, instead of blindly just saying, "fsck it! I wanna control it myself!" ..

*shake-head*

-Thom

for the record, I rather like the automatic scenarios, and I am doing a whole set of truth tables to do more intelligent scenarios...

 Hi Thom.

 I think this should be a feature set that can be turned On or Off depending on personal preference.

 Something in the admin control panel where you can say "Use Automatic Lighting Events:  Y/N"

 I find them extremely annoying, especially in the daytime when it turns on the fireplace and the corner table lamp when I start TV. So I use the gyro and navigate to Lights > Off.

 Then when I stop TV, it turns the fireplace and corner table lamp back on, and the floor lamp! So I use the gyro and navigate to Lights > Off.

 Oh, but then I start a Video and the lights change again!

 Can you recognize how annoying that can be? I'd much rather prefer to run the lights by myself. In the daytime, I don't need lights. At night, I can flip on the system and navigate to Lights > "TV Mode" or Lights > "Movie Mode" (which are a couple lighting scenarios I created) as I require, with or without media active.

 I have other problems with these auto-generated events too. For some reason, in the basement, the core keeps shutting my TV off at weird places. Sometimes I just click the gyro mouse and off goes the TV. Or while watching TV, I click the media button and select OFF and not only does it stop watching TV -- it shuts my TV off!

 I'm about ready to remove the TV as a device completely because just like the lights, it might be better to just let me control it. The core is also flipping through the inputs on the TV, for reasons I don't know, since the only thing I use that TV for is LMCE on HDMI, but it likes to turn the TV on and then start hitting the INPUT button. There are about 6 input selections, and it starts hitting INPUT while the TV is in the middle of turning on (at which point the TV doesn't respond to remote key presses) so it leaves me at VIDEO2, forcing me to grab the TV remote and hit INPUT 3 more times to get to HDMI. So I'm either using the TV remote to constantly turn the TV back ON or adjust the INPUT.

 I did edit the TV device template to remove the various Inputs, but that hasn't helped, or else I have to use the ReSync button in the edit A/V Properties area?

 Upstairs, the MD seems to control the TV and Stereo power just fine, at the appropriate times. I like that. It works great!

 I don't know what's up with the core in the basement! HAL is having fun with me! :-)