Author Topic: can't find /usr/pluto/diskless directory.  (Read 2293 times)

vmann

  • Newbie
  • *
  • Posts: 13
    • View Profile
can't find /usr/pluto/diskless directory.
« on: June 11, 2008, 02:00:19 am »
I am tring to network boot a media director with a marvell yukon nic card, The  network boot detects but it stops at kernal panic can't find eth0. I understand that this is a driver issue and i have to go to the /usr/pluto/diskless directory, however it's not there. There is /usr/pluto but no "diskless" folder. What am i missing here? My MCE is the DVD x386 install, latest version. I have network booted other systems as media directors, but everything was detected fine on those.

Thanks in advance

freymann

  • Douchebag
  • Guru
  • *
  • Posts: 380
    • View Profile
Re: can't find /usr/pluto/diskless directory.
« Reply #1 on: June 11, 2008, 03:37:19 am »
I am tring to network boot a media director with a marvell yukon nic card, The  network boot detects but it stops at kernal panic can't find eth0. I understand that this is a driver issue and i have to go to the /usr/pluto/diskless directory, however it's not there. There is /usr/pluto but no "diskless" folder. What am i missing here?

 Are you looking on the CORE or the MD? You need to look on the CORE's harddrive to find the actual files used for that MD.

 It will be on the core in /usr/pluto/diskless/[##] 

 Where [##] is the device number of the MD.


vmann

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: can't find /usr/pluto/diskless directory.
« Reply #2 on: June 11, 2008, 03:52:16 am »
Thanks for the response

I am looking on the Core, the actual media director won't get past the nic card install.

jpmswiss

  • Guest
Re: can't find /usr/pluto/diskless directory.
« Reply #3 on: June 11, 2008, 07:57:48 am »
Oh no...i also have a mavel yukon nic card! Same results.

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: can't find /usr/pluto/diskless directory.
« Reply #4 on: June 11, 2008, 11:38:33 am »
"Change is inevitable. Progress is optional."
-- Anonymous


vmann

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: can't find /usr/pluto/diskless directory.
« Reply #5 on: June 13, 2008, 02:16:36 am »
I followed the directions as posted here http://wiki.linuxmce.org/index.php/Unrecognized_NIC

Initially there is no directory at /usr/pluto/diskless

After running these

sudo <editor-of-choice> /etc/initramfs-tools-interactor/modules

and adding the line sky2 (marvell nic driver)

then running

/usr/pluto/bin/Diskless_BuildDefaultImage.sh
and
mkinitramfs -d /etc/initramfs-tools-interactor/ -o /tftpboot/default/initrd

and powering on the media director it actually pics up the nic on the media director and installs

then the media director  reboots itself and I get back to "can't find eth0"

However now there is the directory /usr/pluto/diskless in the mce core and the media director is 50.

Now I did the following

/usr/pluto/diskless/50/etc and and put the line "sky2" into a file called "modules"

/usr/pluto/diskless/50/etc/initramfs-tools and put the line "sky2" into a file called "modules"


To create a new initial ram disk the command is

cd /usr/pluto/diskless/
chroot <mediadirector-id>
cd /boot
mkinitramfs -o initrd.img-`uname -r` `uname -r`
exit

the media director still doesn't work, I still get 'Kernel Panic' during the initial PXE boot process can't find eth0.


Does anyone have any suggestions?

can it be this caveat


"The above steps do not work, if the media director and the core utilize two different CPU architectures,ie. one is using AMD64 the other i386 (chroot won't work)."

My core is I386 and my media director is being loaded as AM64.

should I reload my core with the AM64 install? (it is 64 capable 2.4ghz core 2 duo processor)

Any help would be greatly appreciated.

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: can't find /usr/pluto/diskless directory.
« Reply #6 on: June 13, 2008, 01:04:41 pm »
...

"The above steps do not work, if the media director and the core utilize two different CPU architectures,ie. one is using AMD64 the other i386 (chroot won't work)."

My core is I386 and my media director is being loaded as AM64.

should I reload my core with the AM64 install? (it is 64 capable 2.4ghz core 2 duo processor)

Any help would be greatly appreciated.


Yes I'm affraid for now you'll have to either use amd64 on your core as well, or use the MD as i386, to get over this hump.
"Change is inevitable. Progress is optional."
-- Anonymous


jpmswiss

  • Guest
Re: can't find /usr/pluto/diskless directory.
« Reply #7 on: June 13, 2008, 11:00:41 pm »
Hello

So far I've been able to initially network boot - but after re-start Kernel Panic is back.

I get stuck here...
 
cd /usr/pluto/diskless/
chroot <mediadirector-id>

Response:

chroot: cannot run command `/bin/bash': Exec format error

----

CPU architecture are the same for both machines.

Any tips?

thanks
John

vmann

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: can't find /usr/pluto/diskless directory.
« Reply #8 on: June 16, 2008, 06:20:19 am »
I've got mine to work and this is what I did

In this instance my CORE is i386 and it detects my media director as amd64

follow the directions as posted here

http://wiki.linuxmce.org/index.php/Unrecognized_NIC

then you have to manually change your media director to i386. Go to mce admin - media directors and change the line that says amd64 to i386.

click update and then click rebuild media director.

once that is finished go and redo the steps listed here http://wiki.linuxmce.org/index.php/Unrecognized_NIC

It should be good to go after that.

anytime you rebuild the media director you have to rerun all the steps in that post.

I hope this helps

vmann

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: can't find /usr/pluto/diskless directory.
« Reply #9 on: June 16, 2008, 06:22:11 am »
PS

you have to do all commands with SUDO.

I allways got permission denied if I didn't use it.



vmann

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: can't find /usr/pluto/diskless directory.
« Reply #10 on: June 16, 2008, 06:24:41 am »
"I get stuck here..."
 
cd /usr/pluto/diskless/
chroot <mediadirector-id>

Response:

chroot: cannot run command `/bin/bash': Exec format error

It should be sudo chroot and the number of the media director in my case it would be

sudo chroot 50

I hope this helps

jpmswiss

  • Guest
Re: can't find /usr/pluto/diskless directory.
« Reply #11 on: June 16, 2008, 08:01:49 am »
Hi VMANN - thanks for the legwork. Will give that a try later! ;D

Good news / bad news.

I was able to boot - but now it gets stuck when loading the GI.

I get the following code:

after ....command Schedule chrond (or similar)

etc/init.d/rc  exited outside.....

It looks like http://forum.linuxmce.org/index.php?topic=1336.0   but i can't load the driver by network boot.
I modified by xorg.conf and also changed the graphic card to Geforce in the admin control panel.

Back to the drawing board.

Cheers
John






« Last Edit: June 17, 2008, 12:00:11 pm by jpmswiss »