Author Topic: [RC1] TT-Budget/WinTV-NOVA-CI is recognized as sound card  (Read 1361 times)

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
[RC1] TT-Budget/WinTV-NOVA-CI is recognized as sound card
« on: June 05, 2008, 11:21:16 am »
Hi,

Recently I upgraded my LMCE 0710 Beta 4 up to RC1 (I don't think that there is a some significant difference between RC1 and RC2). After a first reboot it was everything fine - sound was presented, DVB card is recognized as DVB, VDR worked fine and showed Russian EPG correctly. But when I booted my core next day I found that DVB card is recognized as sound card:
Code: [Select]
linuxmce@dcerouter:~$ cat /proc/asound/cards
 0 [Audiowerk2     ]: aw2 - Audiowerk2
                      Audiowerk2 with SAA7146 irq 16
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe020000 irq 20
I fixed issued with sound just making NVidia as default sound card in the system. But DVB card is till is not recognized as DVB. I can see that message in the dmesg:
Code: [Select]
[   81.311527] saa7146: register extension 'budget_ci dvb'.but the rest messages which usually present are missed:
Code: [Select]
[   81.311616] DVB: registering new adapter (TT-Budget/WinTV-NOVA-CI PCI).
[   81.351799] input: Budget-CI dvb ir receiver saa7146 (0) as /class/input/input5
[   81.578499] DVB: registering frontend 0 (ST STV0299 DVB-S)...
[   83.696625] dvb_ca adapter 0: DVB CAM detected and initialised successfully
[  150.933998] dvb_ca adapter 0: DVB CAM detected and initialised successfully
On the fresh RC1 installation it works ok. Any suggestion how to solve that?

Thanks in advance.
« Last Edit: June 09, 2008, 08:40:25 am by nite_man »
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: [Upgraded RC1] TT-Budget/WinTV-NOVA-CI is recognized as sound card
« Reply #1 on: June 05, 2008, 12:28:22 pm »
I fixed issued with sound just making NVidia as default sound card in the system.
I think somebody else is having this same problem: http://forum.linuxmce.org/index.php?topic=5267.msg31639#msg31639 would you mind lending him a hand?

The only thing that comes to mind about your issue is that maybe not all the right kernel modules are loaded automaticly at boottime?
"Change is inevitable. Progress is optional."
-- Anonymous


nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: [Upgraded RC1] TT-Budget/WinTV-NOVA-CI is recognized as sound card
« Reply #2 on: June 05, 2008, 01:45:23 pm »
Hi Zaerc,

Already post there how to solve problem with sound. Your guessing sounds reasonable. Will dig the boot procedure to find why DVB is not recognized properly.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: [Upgraded RC1] TT-Budget/WinTV-NOVA-CI is recognized as sound card
« Reply #3 on: June 05, 2008, 09:03:20 pm »
Thanks for addressing the other problem, wasn't sure you had seen it and it sounded the same.

I've just had a look at my system (which is obviously different), maybe it helps a bit to compare.
I think these are the relevant lines from lsmod:
Code: [Select]
...
budget_av              21248  16
saa7146_vv             50688  1 budget_av
videobuf_dma_sg        14852  1 saa7146_vv
videobuf_core          19588  2 saa7146_vv,videobuf_dma_sg
videodev               34176  1 saa7146_vv
v4l1_compat            16004  2 saa7146_vv,videodev
budget_core            13060  1 budget_av
dvb_core               81052  2 budget_av,budget_core
saa7146                20360  3 budget_av,saa7146_vv,budget_core
ttpci_eeprom            3456  1 budget_core
...

And I see this in dmesg:
Code: [Select]
# dmesg | egrep -i '(dvb|saa)'
[   16.048000] saa7146: register extension 'budget_av'.
[   16.048000] saa7146: found saa7146 @ mem f8a70000 (revision 1, irq 22) (0x1894,0x003a).
[   16.048000] saa7146 (0): dma buffer size 192512
[   16.048000] DVB: registering new adapter (Satelco EasyWatch DVB-T)
[   16.628000] DVB: registering frontend 0 (Philips TDA10046H DVB-T)...

And I have this in /dev/dvb/adapter0:
Code: [Select]
# l /dev/dvb/adapter0/
total 0
drwxr-xr-x 2 root root     140 2008-06-05 20:05 .
drwxr-xr-x 3 root root      60 2008-06-05 20:05 ..
crw-rw---- 1 root video 212, 6 2008-06-05 20:05 ca0
crw-rw---- 1 root video 212, 4 2008-06-05 20:05 demux0
crw-rw---- 1 root video 212, 5 2008-06-05 20:05 dvr0
crw-rw---- 1 root video 212, 3 2008-06-05 20:05 frontend0
crw-rw---- 1 root video 212, 7 2008-06-05 20:05 net0

I had to compile the latest v4l-dvb from the repository myself to get the card going though, so I'm not sure if this has any relevance to your situation at all.

"Change is inevitable. Progress is optional."
-- Anonymous


nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: [Upgraded RC1] TT-Budget/WinTV-NOVA-CI is recognized as sound card
« Reply #4 on: June 08, 2008, 08:51:47 pm »
Thanks, Zaerc, for your info. I suspect it somehow related with new drivers in RC1. I used the same configuration a few monthes with different beta versions and everything worked fine. Now I have the same problem on the fresh RC1 installation. Will try tonight RC2.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: [Upgraded RC1] TT-Budget/WinTV-NOVA-CI is recognized as sound card
« Reply #5 on: June 09, 2008, 08:39:40 am »
After discussion in the linux-dvb mailing list found what is causing that:

Quote
Complain to the developers of the Audiowerk2 driver for this:

| static struct pci_device_id snd_aw2_ids[] = {
|       {PCI_VENDOR_ID_SAA7146, PCI_DEVICE_ID_SAA7146, PCI_ANY_ID, PCI_ANY_ID,
|        0, 0, 0},
|       {0}
| };

This will grab _all_ saa7146-based cards. :-(

So, Audiowerk2 should be added into black list. Will try it tonight.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: [RC1] TT-Budget/WinTV-NOVA-CI is recognized as sound card
« Reply #6 on: June 09, 2008, 11:40:51 am »
And I thought you actually had one of those cards.  Way to go Audiowerk2 developers! :P

To blacklist a module simply add a line to /etc/modprobe.d/blacklist like:
Code: [Select]
blacklist <module>
« Last Edit: June 09, 2008, 11:47:15 am by Zaerc »
"Change is inevitable. Progress is optional."
-- Anonymous


Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: [RC1] TT-Budget/WinTV-NOVA-CI is recognized as sound card
« Reply #7 on: June 18, 2008, 03:44:16 pm »
I've just ran into the exact same problem myself after a fresh install of 0710rc2-amd64, the module is called snd_aw2.  I probably didn't notice earlier because I think I added the dvb-t card lateron.  Anyway, to fix this problem from the command line in, a nutshell:
Code: [Select]
echo "blacklist snd_aw2" >>/etc/modprobe.d/blacklist
reboot

Thanks for doing all the legwork in sorting this out nite_man!
"Change is inevitable. Progress is optional."
-- Anonymous