Author Topic: Playback getting a little choppy  (Read 4671 times)

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: Playback getting a little choppy
« Reply #30 on: April 04, 2009, 09:28:20 pm »
Hallo Andrew,

Quote
Well taking the above onboard it would seem like the xorg setup under LinuxMCE is possibly incompatible with the performance of your hardware in someway. Under EasyVDR the xorg is configured in some way differently and works ok.

Well, is this your experience with other mainboards that xorg could be the problem ?
So can I change something about the configuration to get things fixed or is it only fixed by new hardware ? Use another nvidia driver ? Or what can I try to change ?

How can I do a quick reload of X without rebooting ?


I just remebered that your company previously has tested the same mainboard GA-MA78GM-S2H in my MD that has got the problem:
http://forum.linuxmce.org/index.php?topic=6053.msg36430#msg36430
What was the result of those tests ?


I now tested DVD replay of a ripped DVD and it did also stutter the same way.

Now is DVD replay also using xine ?


Quote
Sure send me a 20 sec chunk that you know has the playback problem.
OK, per mail or have you got a place where i can upload it ?


EasyVDR is using xorg 7.1 by the way and LinuxMCE 7.2.


Greetings
Viking

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: Playback getting a little choppy
« Reply #31 on: April 10, 2009, 02:11:42 am »
Hi again,

after quite some hours I have found out what probably is the cause :)

IRQ-sharing or some kind of IRQ-misconfiguring.

On this board all important things are using the same interrupt with the 0710 kernel :(

The graphics card, The Network Card and USB.


I first disabled USB completely in the BIOS and it helped fixing the problem, but nothing works without USB, so I tried only disabling EHCI (USB 2.0) that worked partly - after the boot it was OK, but quite fast it did start stuttering again :(


So the solution I came up with is updating the kernel to 2.6.28.7 (the same EasyVDR is using) and it looks good. IRQ's are used different (see below) and replay is really smooth :)

I changed the Wiki for my Mainboard and noted it as not recommended.


Take a look at this, this are the interrups before Kernel upgrade :

Code: [Select]
Linuxmce# cat /proc/interrupts
           CPU0       CPU1
  0:        143          0   IO-APIC-edge      timer
  1:          4        170   IO-APIC-edge      i8042
  6:          1          4   IO-APIC-edge      floppy
  8:          1          6   IO-APIC-edge      rtc
  9:          0          1   IO-APIC-fasteoi   acpi
 12:          6        105   IO-APIC-edge      i8042
 14:         11        398   IO-APIC-edge      ide0
 16:       2484     444417   IO-APIC-fasteoi   ohci_hcd:usb3, ohci_hcd:usb4, ohci_hcd:usb5, eth0, nvidia
 17:       3923     217935   IO-APIC-fasteoi   ohci_hcd:usb1, ohci_hcd:usb2, HDA Intel
 18:          1          3   IO-APIC-fasteoi   ehci_hcd:usb6
 19:          0          0   IO-APIC-fasteoi   ehci_hcd:usb7
 20:       2137     172294   IO-APIC-fasteoi   saa7146 (0)
NMI:          0          0
LOC:     197824     197923
ERR:          0
MIS:          0

After Kernel upgrade to 2.6.28.7 it looks like this :
Code: [Select]
# cat /proc/interrupts
           CPU0       CPU1
  0:        124          0   IO-APIC-edge      timer
  1:          0         16   IO-APIC-edge      i8042
  4:         84       8761   IO-APIC-edge
  6:          0          5   IO-APIC-edge      floppy
  9:          0          0   IO-APIC-fasteoi   acpi
 12:         12        100   IO-APIC-edge      i8042
 14:          8        539   IO-APIC-edge      ide0
 15:          0          0   IO-APIC-edge      ide1
 16:       8399    1288367   IO-APIC-fasteoi   ohci_hcd:usb2, ohci_hcd:usb4, HDA Intel
 17:          0          6   IO-APIC-fasteoi   ehci_hcd:usb1
 18:       3898     516123   IO-APIC-fasteoi   ohci_hcd:usb5, ohci_hcd:usb6, ohci_hcd:usb7, nvidia
 19:          0          0   IO-APIC-fasteoi   ehci_hcd:usb3
 22:          0          3   IO-APIC-fasteoi   ohci1394, ahci
508:      21497    3606180   PCI-MSI-edge      eth0
511:    4546432          0  HPET_MSI-edge      hpet2
NMI:          0          0   Non-maskable interrupts
LOC:        110    4546761   Local timer interrupts
RES:     534014     190887   Rescheduling interrupts
CAL:       9550       9215   Function call interrupts
TLB:      20053       4757   TLB shootdowns
SPU:          0          0   Spurious interrupts
ERR:          0
MIS:          0

Colin, how are your interrupts shared ?

Greetings
Viking

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Playback getting a little choppy
« Reply #32 on: April 10, 2009, 09:58:37 am »
Mine seem OK, but as I say, I suspect that may stuttering issue isn't exactly the same as yours...

Code: [Select]
           CPU0       CPU1
  0:        256       5081   IO-APIC-edge      timer
  1:          0         12   IO-APIC-edge      i8042
  6:          0          2   IO-APIC-edge      floppy
  8:   17715741  896660786   IO-APIC-edge      rtc
  9:        311      22667   IO-APIC-fasteoi   acpi
 14:     195629   12291822   IO-APIC-edge      ide0
 16:    2665544  144790915   IO-APIC-fasteoi   ohci_hcd:usb1, eth0
 17:    1537719   76970596   IO-APIC-fasteoi   ohci_hcd:usb2, ahci
 18:      21544     880713   IO-APIC-fasteoi   ehci_hcd:usb3, nvidia
 19:      70398    3734587   IO-APIC-fasteoi   ehci_hcd:usb4, HDA Intel
 20:     980860   68648116   IO-APIC-fasteoi   ehci_hcd:usb5, ohci1394
 21:   14788452 1123395046   IO-APIC-fasteoi   uhci_hcd:usb7, eth1
 22:          0          0   IO-APIC-fasteoi   uhci_hcd:usb6
 23:    1500453  102187452   IO-APIC-fasteoi   nvidia
NMI:          0          0
LOC:  255690575  256749061
ERR:          1
MIS:          0

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4464
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Playback getting a little choppy
« Reply #33 on: April 10, 2009, 01:59:52 pm »
Hi again,

after quite some hours I have found out what probably is the cause :)

IRQ-sharing or some kind of IRQ-misconfiguring.

On this board all important things are using the same interrupt with the 0710 kernel :(

The graphics card, The Network Card and USB.


I first disabled USB completely in the BIOS and it helped fixing the problem, but nothing works without USB, so I tried only disabling EHCI (USB 2.0) that worked partly - after the boot it was OK, but quite fast it did start stuttering again :(


So the solution I came up with is updating the kernel to 2.6.28.7 (the same EasyVDR is using) and it looks good. IRQ's are used different (see below) and replay is really smooth :)

I changed the Wiki for my Mainboard and noted it as not recommended.


Take a look at this, this are the interrups before Kernel upgrade :

Code: [Select]
Linuxmce# cat /proc/interrupts
           CPU0       CPU1
  0:        143          0   IO-APIC-edge      timer
  1:          4        170   IO-APIC-edge      i8042
  6:          1          4   IO-APIC-edge      floppy
  8:          1          6   IO-APIC-edge      rtc
  9:          0          1   IO-APIC-fasteoi   acpi
 12:          6        105   IO-APIC-edge      i8042
 14:         11        398   IO-APIC-edge      ide0
 16:       2484     444417   IO-APIC-fasteoi   ohci_hcd:usb3, ohci_hcd:usb4, ohci_hcd:usb5, eth0, nvidia
 17:       3923     217935   IO-APIC-fasteoi   ohci_hcd:usb1, ohci_hcd:usb2, HDA Intel
 18:          1          3   IO-APIC-fasteoi   ehci_hcd:usb6
 19:          0          0   IO-APIC-fasteoi   ehci_hcd:usb7
 20:       2137     172294   IO-APIC-fasteoi   saa7146 (0)
NMI:          0          0
LOC:     197824     197923
ERR:          0
MIS:          0

After Kernel upgrade to 2.6.28.7 it looks like this :
Code: [Select]
# cat /proc/interrupts
           CPU0       CPU1
  0:        124          0   IO-APIC-edge      timer
  1:          0         16   IO-APIC-edge      i8042
  4:         84       8761   IO-APIC-edge
  6:          0          5   IO-APIC-edge      floppy
  9:          0          0   IO-APIC-fasteoi   acpi
 12:         12        100   IO-APIC-edge      i8042
 14:          8        539   IO-APIC-edge      ide0
 15:          0          0   IO-APIC-edge      ide1
 16:       8399    1288367   IO-APIC-fasteoi   ohci_hcd:usb2, ohci_hcd:usb4, HDA Intel
 17:          0          6   IO-APIC-fasteoi   ehci_hcd:usb1
 18:       3898     516123   IO-APIC-fasteoi   ohci_hcd:usb5, ohci_hcd:usb6, ohci_hcd:usb7, nvidia
 19:          0          0   IO-APIC-fasteoi   ehci_hcd:usb3
 22:          0          3   IO-APIC-fasteoi   ohci1394, ahci
508:      21497    3606180   PCI-MSI-edge      eth0
511:    4546432          0  HPET_MSI-edge      hpet2
NMI:          0          0   Non-maskable interrupts
LOC:        110    4546761   Local timer interrupts
RES:     534014     190887   Rescheduling interrupts
CAL:       9550       9215   Function call interrupts
TLB:      20053       4757   TLB shootdowns
SPU:          0          0   Spurious interrupts
ERR:          0
MIS:          0

Colin, how are your interrupts shared ?

Greetings
Viking

We have tested the GA-MA78GM-S2H under LinuxMCE-0710 and now are testing it under LinuxMCE-0810 Alpha's. As usual the ATI3200 poses a few challenges but these are expected.

We certainly do not see any of the issues you are experiencing under 0710 or 0810. As far as I know we have not made any changes in bios relating to Interrupts..I will check with one of our guys next week to be sure though.

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-7C

Contact me for Smart Home consulting advice here;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: Playback getting a little choppy
« Reply #34 on: April 12, 2009, 08:52:32 pm »
Hallo Andrew,

Thanks for checking :)

What are you doing to get the ATI 3200 running. I already tried the newer ATI drivers, but the OSD menues are really slow.

Greetings
Viking