Author Topic: How to set default mixing channel  (Read 914 times)

Afkpuz

  • Guru
  • ****
  • Posts: 211
    • View Profile
How to set default mixing channel
« on: May 18, 2008, 09:16:52 pm »
I have an external sound card and LMCE defaults to the wrong mixer channel.  How do I change it? 

P.S. If I goto kubuntu and change it in kmix, it doesn't affect the already running LMCE and a reboot will set it back to the wrong channel

Please help me!  I'm so close to getting a fully working system, but there seems to be no one who can/is willing to help me on these forums!

bulek

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 886
  • Living with LMCE
    • View Profile
Re: How to set default mixing channel
« Reply #1 on: May 18, 2008, 11:05:43 pm »
I have an external sound card and LMCE defaults to the wrong mixer channel.  How do I change it? 

P.S. If I goto kubuntu and change it in kmix, it doesn't affect the already running LMCE and a reboot will set it back to the wrong channel

Please help me!  I'm so close to getting a fully working system, but there seems to be no one who can/is willing to help me on these forums!
Not sure, but maybe Xine player page on Web-admin could have such setting ?

Regards,

Bulek.
Thanks in advance,

regards,

Bulek.

chrisbirkinshaw

  • Guru
  • ****
  • Posts: 431
    • View Profile
Re: How to set default mixing channel
« Reply #2 on: May 18, 2008, 11:59:43 pm »
Do you mean that

a) there is no sound at all as lmce tries to use the first card
b) Your master PCM slider is called something else so volume control doesn't work

Problem A can be solved by blocking the driver from loading for the first card. I haven't found a solution to problem B.

Chris


Afkpuz

  • Guru
  • ****
  • Posts: 211
    • View Profile
Re: How to set default mixing channel
« Reply #3 on: May 21, 2008, 05:33:11 am »
The sound works, I just can't change volume.  Now, even the kubuntu mixer is set to the proper channel, but linuxmce won't change volume levels.  I made a work around by controling my audio receiver through IR (via my fiire chief), but you can't use the cool gyro-volume when using infrared. 

chrisbirkinshaw

  • Guru
  • ****
  • Posts: 431
    • View Profile
Re: How to set default mixing channel
« Reply #4 on: May 21, 2008, 03:08:47 pm »
I have this problem with all 3 of my systems. From memory LMCE tries to change the slider called "PCM". On two of my systems it is called something else eg. mono out, or front etc. On the third systems I have 3 PCM sliders which all need moving together and this doesn't work either.