Author Topic: Slimserver and MythTV plugin wont load after 710 upgrade  (Read 960 times)

sambuca

  • Guru
  • ****
  • Posts: 446
    • View Profile
Slimserver and MythTV plugin wont load after 710 upgrade
« on: May 12, 2008, 12:30:50 am »
Hi

After upgrading from 710b4 to 710RC1, I see some strange errors in DCERouter.log, and I am unable to view live TV on the MD. I tried to downgrade the pluto-mythtv-plugin to the previous version (two versions were available - 2.0.0.44.0802262200 and 2.0.0.44.0804112200), which "fixed" the issue for the MythTV plugin, although I don't think this is the correct thing to do.

Code: [Select]
01      05/11/08 23:25:43.548           ESC[31;1mCan't open plug-in file './SlimServer_PlugIn.so': ./SlimServer_PlugIn.so: undefined symbol: _ZN3DCE11MediaStream13SetNowPlayingEPNS_10OH_OrbiterEbbPNS_7MessageEESC[0m <0xb6c9d6c0>
01      05/11/08 23:25:43.548           ESC[31;1mCannot load plug-in for device: 148. Be sure the file SlimServer_PlugIn existsESC[0m <0xb6c9d6c0>

Anyone care to shed some light on what may have happened here?
Maybe some packages not updated correctly so that this symbol don't exist?

sambuca

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4426
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Slimserver and MythTV plugin wont load after 710 upgrade
« Reply #1 on: May 12, 2008, 10:21:35 am »
Hi

After upgrading from 710b4 to 710RC1, I see some strange errors in DCERouter.log, and I am unable to view live TV on the MD. I tried to downgrade the pluto-mythtv-plugin to the previous version (two versions were available - 2.0.0.44.0802262200 and 2.0.0.44.0804112200), which "fixed" the issue for the MythTV plugin, although I don't think this is the correct thing to do.

Code: [Select]
01      05/11/08 23:25:43.548           ESC[31;1mCan't open plug-in file './SlimServer_PlugIn.so': ./SlimServer_PlugIn.so: undefined symbol: _ZN3DCE11MediaStream13SetNowPlayingEPNS_10OH_OrbiterEbbPNS_7MessageEESC[0m <0xb6c9d6c0>
01      05/11/08 23:25:43.548           ESC[31;1mCannot load plug-in for device: 148. Be sure the file SlimServer_PlugIn existsESC[0m <0xb6c9d6c0>

Anyone care to shed some light on what may have happened here?
Maybe some packages not updated correctly so that this symbol don't exist?

sambuca

Hi there,

Sounds like something you should Mantis so that one of the Dev team can see whats gone wrong.

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

sambuca

  • Guru
  • ****
  • Posts: 446
    • View Profile
Re: Slimserver and MythTV plugin wont load after 710 upgrade
« Reply #2 on: May 13, 2008, 09:34:31 am »
Hi

Thanks for the suggestion. I would certainly mantis it, if I knew it was a bug, and not just me messing around too much  ;)

sambuca