Author Topic: Using a newer version of Myth  (Read 1855 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Using a newer version of Myth
« on: December 08, 2005, 08:43:11 am »
Hi, I'm trying to get a newer version of Myth to work with pluto.

Myth compiles without any problems, however after installing it I get:
Code: newbielink:javascript:void(0); [nonactive]
10      12/07/05 23:56:22.340           MythTvWrapper::initMythTVGlobalContext() MythContext object was created.
2005-12-07 23:56:22.340 This app was compiled against libmyth version: 0.18.20050409-1
                        but the library is version: 0.19.20051026-1
                        You probably want to recompile everything, and do a
                        'make distclean' first.
01      12/07/05 23:56:22.341           MythTvWrapper::initMythTVGlobalContext() Could not init the MythContext object.
01      12/07/05 23:56:22.342           Plugin 50748 threw an exception
05      12/07/05 23:56:22.342           Plugin 50748 activated
01      12/07/05 23:56:22.342           Cannot initialize plug-in for device: 50748


...so I assumed that I need to rebuild the myth backend proxy, however I can't seem to get it to compile due to some files being missing...

The makefile refers to a 'PlutoUtils/make.rules', however it doesn't exist. If I comment it out, and run make all from the MythTV_Backend_Proxy, I get:
Code: newbielink:javascript:void(0); [nonactive]
MythTV_Backend_Proxy.h:7:50: Gen_Devices/MythTV_Backend_ProxyBase.h: No such file or directory followed by a bunch of errors.

..so my question is, what packages do I need to install to get this working?

Cheers,
-Kent